SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-06-2008, 11:02 PM   #1
Gnfanatic
Member
Gnfanatic has a spectacular aura aboutGnfanatic has a spectacular aura about
 
Gnfanatic's Avatar
 
Join Date: Apr 2001
Posts: 282

2000 SL1
Default My sl1 revs to 2000 rpm when I put in park

Hey guys, Once in awhile after a drive (car is hot) when I park the car the engine will rev to 2000 rpm and stay there until i tap on the gas pedal. Once I do that it will go back down to 625 rpms. Weird. I did not test my intake gasket yet but going to soon.

any ideas??

thanks!

REWARD EXCELLENCE!

Add to Gnfanatic's Reputation
Rate the quality of this post and help Gnfanatic reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Gnfanatic is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-06-2008, 11:20 PM   #2
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 64,909
 

1998 SC2
Default Re: My sl1 revs to 2000 rpm when I put in park

You have a bad TPS or a sticking throttle blade. Clean the Throttle Body and see if that fixes it. If you decide to replace the TPS the dealer part is a better investment. All of the aftermarket ones I have used are not impressive. The OEM part is expensive, cleaning is cheap.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 10-07-2008, 08:51 AM   #3
Gnfanatic
Member
Gnfanatic has a spectacular aura aboutGnfanatic has a spectacular aura about
 
Gnfanatic's Avatar
 
Join Date: Apr 2001
Posts: 282

2000 SL1
Default Re: My sl1 revs to 2000 rpm when I put in park

Hey Oldnuc, thanks for the reply. I took off the TB 3 weeks ago and cleaned it bigtime, doesnt stick anymore! The tps I never touched. I didnt think a tps could do this, you mean the tps gets stuck and once I rev it ,it gets unstuck? I am surprised the ses light wouldnt go on becuase of it either.

thanks!

REWARD EXCELLENCE!

Add to Gnfanatic's Reputation
Rate the quality of this post and help Gnfanatic reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Gnfanatic is offline   Reply With Quote
Old 10-07-2008, 09:10 AM   #4
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 64,909
 

1998 SC2
Default Re: My sl1 revs to 2000 rpm when I put in park

No, the TPS is supposed to produce a closed throttle voltage, this is .4 volts plus/minus .2 volts. If this voltage happens to be above limits the car will start once and be fine but when you let the throttle close and then put the auto trans in neutral the engine will not know its supposed to be at idle and will rev up. One way to check this is to turn off the engine and then restart it and if it idles back down its the TPS. When you do this test don't shift the trans or touch the throttle. The problem can be caused by a defective ECTS or connector also. Also, check for an intake manifold vacuum leak. Spray with carb cleaner and see if idle changes.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 10-08-2008, 11:56 AM   #5
Gnfanatic
Member
Gnfanatic has a spectacular aura aboutGnfanatic has a spectacular aura about
 
Gnfanatic's Avatar
 
Join Date: Apr 2001
Posts: 282

2000 SL1
Default Re: My sl1 revs to 2000 rpm when I put in park

Oldnuc, thanks for the reply. I did replace the ECTS BUT I did not replace the connector! Can I buy the connector locally?? or Dealership only???

thanks!

REWARD EXCELLENCE!

Add to Gnfanatic's Reputation
Rate the quality of this post and help Gnfanatic reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Gnfanatic is offline   Reply With Quote
Old 10-08-2008, 12:59 PM   #6
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 64,909
 

1998 SC2
Default Re: My sl1 revs to 2000 rpm when I put in park

Pop the connector of and look at it closely with a bright light. Is it corroded? If not its probably not the problem. the dealer does sell a replacement, for 35.00 or so and the best thing to do if you need a new one is to go to the J/Y and get the connector of of the IAT sensor. Its the same connector.

Also, check your intake for a vacuum leak. Spray it down while idling with brake cleaner and if the idle changes you found it.

Go for the cheap easy items first.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 SL2 - Vehicle revs past 2000 RPM when putting in park. Why? 2002SaturnMan S-Series Tech 54 02-02-2009 11:06 PM
My 2002 Saturn SC1 idles at 2000 RPM while in park. There is also a knocking sound. travisj027 S-Series Tech 7 02-02-2009 10:43 PM
Engine revs up to 2000-3000 rpm ejmatus S-Series Tech 10 01-01-2008 05:23 PM
2000 sl1 wont start in park DoyleC S-Series Tech 4 02-15-2006 02:44 AM
Engine revs to 2000 RPMs when in park ddanea Ion General 4 12-09-2005 01:22 PM


All times are GMT -5. The time now is 02:02 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.