SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-21-2010, 04:11 PM   #1
d16tr
Member
d16tr is on a distinguished road
 
Join Date: Feb 2007
Location: SC
Posts: 110

1995 SW2
Default Some feedback about replacing CPS and thank you to all the forum members

Hi All,

I had that infamous CPS problem with all the symptoms, e.g. engine dying when driving, or when hot; some weird trouble code, can't exactly remember but something about not getting some quad signal etc. Actually when I reset the computer it wouldn't even give any trouble signal when it first died.

Anyway, I changed the CPS with a new original one and that fixed the problem.

I read a lot of valuable info on various threads, and watched a few videos on youtube shot by richpin. Big thank you to everyone here!

A small note: I was able to change the sensor without removing the starter, but it is not as easy as it would have been with starter removed.

Thanks again to the whole saturn fans family!

...
Audere est facere.

REWARD EXCELLENCE!

Add to d16tr's Reputation
Rate the quality of this post and help d16tr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
d16tr is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-21-2010, 04:22 PM   #2
wscreate
Member
wscreate is on a distinguished road
 
wscreate's Avatar
 
Join Date: Apr 2007
Posts: 467
Default Re: Some feedback about replacing CPS and thank you to all the forum members

Quote:
Originally Posted by d16tr View Post
Hi All,
Anyway, I changed the CPS with a new original one and that fixed the problem.
How many days have you been trouble-free since you replaced the CPS?

REWARD EXCELLENCE!

Add to wscreate's Reputation
Rate the quality of this post and help wscreate reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wscreate is offline   Reply With Quote
Old 07-21-2010, 04:59 PM   #3
d16tr
Member
d16tr is on a distinguished road
 
Join Date: Feb 2007
Location: SC
Posts: 110

1995 SW2
Default Re: Some feedback about replacing CPS and thank you to all the forum members

Hey,

This is the second day, and I drove the car probably 5 times for a total of about 40 miles in the city traffic. I will come back with an update tomorrow.



Quote:
Originally Posted by wscreate View Post
How many days have you been trouble-free since you replaced the CPS?

...
Audere est facere.

REWARD EXCELLENCE!

Add to d16tr's Reputation
Rate the quality of this post and help d16tr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
d16tr is offline   Reply With Quote
Old 07-21-2010, 11:06 PM   #4
wscreate
Member
wscreate is on a distinguished road
 
wscreate's Avatar
 
Join Date: Apr 2007
Posts: 467
Default Re: Some feedback about replacing CPS and thank you to all the forum members

Excellent. I hope things are resolved for you.

REWARD EXCELLENCE!

Add to wscreate's Reputation
Rate the quality of this post and help wscreate reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wscreate is offline   Reply With Quote
Old 07-24-2010, 02:29 AM   #5
d16tr
Member
d16tr is on a distinguished road
 
Join Date: Feb 2007
Location: SC
Posts: 110

1995 SW2
Default Re: Some feedback about replacing CPS and thank you to all the forum members

Hello again

So far so good, looks like the problem has really been solved. After 4 days and over 100 miles in city traffic the car runs just fine.

I will come back with another update if necessary.


Quote:
Originally Posted by wscreate View Post
Excellent. I hope things are resolved for you.

...
Audere est facere.

REWARD EXCELLENCE!

Add to d16tr's Reputation
Rate the quality of this post and help d16tr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
d16tr is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thank you Saturn Forum Members! agassiz51 S-Series General 1 04-24-2009 08:03 PM
Thanks to All Forum Members fquan59 S-Series General 3 02-22-2008 12:12 AM
Retailer Feedback Forum? SW2Muck Community Center 3 07-13-2003 02:15 PM
New members introduction forum XtremeGrandAm Community Center 31 06-24-2003 07:37 AM


All times are GMT -4. The time now is 03:00 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.