SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-03-2011, 04:21 PM   #1
Joshtheclockman
Member
Joshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura about
 
Join Date: Aug 2010
Posts: 52

1994 SL
2002 SL
Default Service Engine light but no code

So here's something strange, I had my engine rebuilt last week and when I went to start it the service engine soon light came on. The mechanic told me that my oil pressure sender was causing it, but it couldn't be because i took that stupid thing out and put a couple of gauges in way before I had the engine rebuilt and there was no light. When i drive the car the light will go out when i reach a speed of 30-35 mph after the engine warms up to operating temp, and will come back on when the car sits at an idle and the pattern repeats, I put a code scanner on it and it didn't pull any codes from it. I'm at a loss, any ideas?

1994 Saturn SL 5speed 180290 miles, engine rebuilt 200 miles ago

REWARD EXCELLENCE!

Add to Joshtheclockman's Reputation
Rate the quality of this post and help Joshtheclockman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joshtheclockman is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-03-2011, 05:19 PM   #2
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,713
 

1996 SW2
Default Re: Service Engine light but no code

Don't let that "mechanic" near your car again. Or at least make sure he's read the FSM before dispensing any advice. The oil pressure sender (and/or the gauge sender you have in now) doesn't communicate with the PCM at all, so it can't possibly set the SES light.

You don't need a scanner to obtain the codes. For that matter, if your scanner is for OBD-II, that would be the most obvious explanation why it won't show any codes. With OBD-I, however, for the most part it doesn't store codes, so you can only obtain a code when the light is on. Visit our How-To Library, and search on "paper clip" for a way to obtain the code(s) using, you guessed it, a paper clip. So you'll have to carry one with you, along with the instructions, to capture it when the light goes on again.

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 10-04-2011, 12:01 AM   #3
Joshtheclockman
Member
Joshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura about
 
Join Date: Aug 2010
Posts: 52

1994 SL
2002 SL
Default Re: Service Engine light but no code

Yea I don't like the mechanic very much myself (if he really is a mechanic), that's why i generally do all the mechanic work my self. The scanner i used was a universal scanner and is supposed to be able to read codes from OBD 1 and OBD 2 as it has connectors and stuff for both and i told it to scan while the car was on but it still failed me, but i will defiantly try the paperclip, it sounds more promising.


Thanks!

REWARD EXCELLENCE!

Add to Joshtheclockman's Reputation
Rate the quality of this post and help Joshtheclockman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joshtheclockman is offline   Reply With Quote
Old 10-04-2011, 12:03 AM   #4
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 65,108
 

1998 SC2
Default Re: Service Engine light but no code

This is easier and the data is correct.

http://www.saturnwiki.net/index.php/..._Trouble_Codes

and

http://www.saturnwiki.net/index.php/..._Trouble_Codes

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is online now   Reply With Quote
Old 10-04-2011, 12:06 PM   #5
Joshtheclockman
Member
Joshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura about
 
Join Date: Aug 2010
Posts: 52

1994 SL
2002 SL
Default Re: Service Engine light but no code

SO when i do the paperclip thing, is the cooling fan supposed to turn on when i turn the ignition to the on position?

REWARD EXCELLENCE!

Add to Joshtheclockman's Reputation
Rate the quality of this post and help Joshtheclockman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joshtheclockman is offline   Reply With Quote
Old 10-04-2011, 12:15 PM   #6
Joshtheclockman
Member
Joshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura about
 
Join Date: Aug 2010
Posts: 52

1994 SL
2002 SL
Default Re: Service Engine light but no code

Never mind scratch that, so i did the paperclip thing and i got code 12 and code 26

What is code 26 quad driver?

REWARD EXCELLENCE!

Add to Joshtheclockman's Reputation
Rate the quality of this post and help Joshtheclockman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joshtheclockman is offline   Reply With Quote
Old 10-04-2011, 12:31 PM   #7
PlasticCarsRock
Master Member
PlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the rough
 
PlasticCarsRock's Avatar
 
Join Date: Dec 2005
Location: Brookline, MA
Posts: 4,317
 

1995 SL2
Default Re: Service Engine light but no code

Quote:
Originally Posted by Joshtheclockman View Post
Never mind scratch that, so i did the paperclip thing and i got code 12 and code 26

What is code 26 quad driver?
Code 12 just means the diagnostics is working. You should always get that code, even with the light off.

http://www.differentracing.com/tech_...es/dtc/26.html

from: http://www.differentracing.com/tech_...dtc_chart.html

from: http://www.differentracing.com/tech_articles/index.html

And yes, the cooling fan should run, when in diagnostics mode. That provides a way of checking the fan motor, relay, etc without jumping anything or waiting for the car to warm up.

REWARD EXCELLENCE!

Add to PlasticCarsRock's Reputation
Rate the quality of this post and help PlasticCarsRock reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
PlasticCarsRock is offline   Reply With Quote
Old 10-04-2011, 12:37 PM   #8
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 65,108
 

1998 SC2
Default Re: Service Engine light but no code

Follow this trouble chart.
http://saturnwiki.org/index.php/26_Q...r_Output_Fault

Use the links I posted above.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is online now   Reply With Quote
Old 10-05-2011, 06:24 PM   #9
Joshtheclockman
Member
Joshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura about
 
Join Date: Aug 2010
Posts: 52

1994 SL
2002 SL
Default Re: Service Engine light but no code

Thanks for the links, ill get a chance to look at the car on friday. I think i have narrowed it down to the EGR solenoid or the purge canister solenoid. Neither sound like fun to get to.

REWARD EXCELLENCE!

Add to Joshtheclockman's Reputation
Rate the quality of this post and help Joshtheclockman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joshtheclockman is offline   Reply With Quote
Old 10-08-2011, 04:49 PM   #10
Joshtheclockman
Member
Joshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura about
 
Join Date: Aug 2010
Posts: 52

1994 SL
2002 SL
Default Re: Service Engine light but no code

So after narrowing my search down the the egr solenoid or the puge solenoid, i was able to find the egr solenoid to find out it is still good. I cant find the purge solenoid. Do you guys know where i can find it?

Thanks!

REWARD EXCELLENCE!

Add to Joshtheclockman's Reputation
Rate the quality of this post and help Joshtheclockman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joshtheclockman is offline   Reply With Quote
Old 10-08-2011, 04:55 PM   #11
dbsanfte
Member
dbsanfte is on a distinguished road
 
Join Date: Nov 2010
Location: London, UK
Posts: 392

1999 SW2
Default Re: Service Engine light but no code

Rear of the engine beneath the throttle body, no?

REWARD EXCELLENCE!

Add to dbsanfte's Reputation
Rate the quality of this post and help dbsanfte reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dbsanfte is offline   Reply With Quote
Old 10-08-2011, 05:15 PM   #12
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 65,108
 

1998 SC2
Default Re: Service Engine light but no code

It is right above the starter under the #3 and #4 intake runners. Throttle body is close.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is online now   Reply With Quote
Old 10-10-2011, 02:47 PM   #13
Joshtheclockman
Member
Joshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura aboutJoshtheclockman has a spectacular aura about
 
Join Date: Aug 2010
Posts: 52

1994 SL
2002 SL
Default Re: Service Engine light but no code

I found it and plugged it back in. I guess it was unplugged by accident when the engine was rebuilt, and it just didnt get plugged back in. The engine light is off now..

Thanks!

REWARD EXCELLENCE!

Add to Joshtheclockman's Reputation
Rate the quality of this post and help Joshtheclockman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joshtheclockman is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Service Engine Soon Light with P0133 Code LoganSan S-Series General 11 10-03-2010 04:57 PM
Trouble Code and Service Engine Light Big__Daddy General Saturn Discussion 1 11-10-2005 11:15 PM
Trouble Code and Service Engine Light Big__Daddy S-Series General 7 11-07-2005 08:05 PM
Service Engine Soon Light – Error Code P0133 Filo S-Series Tech 5 02-16-2005 04:49 PM
Trouble Code 49 on Service Engine Soon Light 93sl1 S-Series Tech 10 11-19-2002 11:19 PM


All times are GMT -4. The time now is 11:28 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.