SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-12-2008, 08:22 AM   #1
banditkaine
Member
banditkaine is on a distinguished road
 
banditkaine's Avatar
 
Join Date: Sep 2007
Location: Miami, FL
Posts: 321
 

2002 SL2
Default 2002 SL2 High Idle

i have a 2002 SL2 and it strated idling at 2000 rpm, in neutral and park, when i put it in drive (auto trans) it rolls on its own rather fast. sometimes it won't idle high. turned it off and back on and it went back to normal, but when i drive for a bit it idles high again. also the airbag light flashed when i was at a stoplight. any ideas what this can be?

REWARD EXCELLENCE!

Add to banditkaine's Reputation
Rate the quality of this post and help banditkaine reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
banditkaine is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-12-2008, 10:58 AM   #2
rc1488
Master Member
rc1488 has a spectacular aura aboutrc1488 has a spectacular aura about
 
rc1488's Avatar
 
Join Date: Jun 2007
Location: Carmel, NY
Posts: 5,658
 

1997 SL2
1995 SC2
Default Re: 2002 SL2 High Idle

Clean your throttle body first off. Make sure all the passages are clean especially the IAC.

The airbag light makes me ponder tho. Search for information about it and see what turns up.

...
Current: 95 SC2 Man 97 SL2 Auto 98 SL1 Auto 01 SL1 Man 02 SL1 Man
Past: 94 SL2 Man 95 SL2 Man 95 SL2 Man 96 SL2 Auto 97 SL2 Man 98 SL2 Auto 99 SL2 Auto
2010 SCCA Mohud Street Championship-2nd Place

REWARD EXCELLENCE!

Add to rc1488's Reputation
Rate the quality of this post and help rc1488 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
rc1488 is offline   Reply With Quote
Old 03-12-2008, 01:06 PM   #3
fredsfix
Member
fredsfix is on a distinguished road
 
fredsfix's Avatar
 
Join Date: Feb 2008
Location: Corning NY
Posts: 222

1999 SL1
1997 SL1
Default Re: 2002 SL2 High Idle

Been into any of the quick lube places lately? Check any vacuum lines to be sure they're connected right, especially the one in the throttle body right beyond the oil fill cap. Worked for me.
As for the air bag light - lean waaaay back and reach for the steering wheel

...
You can't call yourself a mechanic if you're surprised it runs!

REWARD EXCELLENCE!

Add to fredsfix's Reputation
Rate the quality of this post and help fredsfix reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fredsfix is offline   Reply With Quote
Old 03-13-2008, 06:59 AM   #4
banditkaine
Member
banditkaine is on a distinguished road
 
banditkaine's Avatar
 
Join Date: Sep 2007
Location: Miami, FL
Posts: 321
 

2002 SL2
Default Re: 2002 SL2 High Idle

i disconnected the battery for a few hours and now everything works fine o.O beats me what the deal was.. maybe the PCM got confused? but the RPMs so far seem to be normal and the airbag light has not come on again.

REWARD EXCELLENCE!

Add to banditkaine's Reputation
Rate the quality of this post and help banditkaine reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
banditkaine is offline   Reply With Quote
Old 03-13-2008, 07:15 AM   #5
Phredawgy
Senior Member
Phredawgy is on a distinguished road
 
Phredawgy's Avatar
 
Join Date: Aug 2006
Location: Southeastern Arizona
Posts: 1,810
 

1996 SL2
Default Re: 2002 SL2 High Idle

Quote:
Originally Posted by banditkaine View Post
i disconnected the battery for a few hours and now everything works fine o.O beats me what the deal was.. maybe the PCM got confused? but the RPMs so far seem to be normal and the airbag light has not come on again.
How long were you having these symptoms?

...
The streets will flow with the blood of all the non-believers!!!! And all those who won't include their vehicles vital information in their posts!!!!

REWARD EXCELLENCE!

Add to Phredawgy's Reputation
Rate the quality of this post and help Phredawgy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Phredawgy is offline   Reply With Quote
Old 03-13-2008, 08:25 AM   #6
banditkaine
Member
banditkaine is on a distinguished road
 
banditkaine's Avatar
 
Join Date: Sep 2007
Location: Miami, FL
Posts: 321
 

2002 SL2
Default Re: 2002 SL2 High Idle

Quote:
Originally Posted by Phredawgy View Post
How long were you having these symptoms?
it only just started yesterday.. drove it a few miles today after disconnecting the battery and everything seems ok. it was raining hard when it started.. could that have something to do with it?

REWARD EXCELLENCE!

Add to banditkaine's Reputation
Rate the quality of this post and help banditkaine reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
banditkaine is offline   Reply With Quote
Old 03-13-2008, 08:33 AM   #7
Phredawgy
Senior Member
Phredawgy is on a distinguished road
 
Phredawgy's Avatar
 
Join Date: Aug 2006
Location: Southeastern Arizona
Posts: 1,810
 

1996 SL2
Default Re: 2002 SL2 High Idle

Quote:
Originally Posted by banditkaine View Post
it only just started yesterday.. drove it a few miles today after disconnecting the battery and everything seems ok. it was raining hard when it started.. could that have something to do with it?
hopefully then it was just a fluke

...
The streets will flow with the blood of all the non-believers!!!! And all those who won't include their vehicles vital information in their posts!!!!

REWARD EXCELLENCE!

Add to Phredawgy's Reputation
Rate the quality of this post and help Phredawgy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Phredawgy is offline   Reply With Quote
Old 03-13-2008, 09:13 AM   #8
wislauson
Junior Member
wislauson is on a distinguished road
 
Join Date: Jan 2008
Posts: 20
Default Re: 2002 SL2 High Idle

Had the same exact problem with my SC1. This is most likely the ECTS...what can happen is it can get stuck on a certain reading (high or low) and then continue to send the wrong information about what mixture to use. If it thinks the engine is cold, it will continue to call for a high idle. Shutting the car off and then starting it again basically lets it "reboot." The problem will come and go, but it will get progressively more frequent. If you let this go you'll get to a point where shutting the car off doesn't work any more. The good news is it's an easy fix...the technician will take a reading of the coolant temp and then compare that to what the ECTS is sensing and there will probably be a discrepancy. The IAC and throttle body being dirty can also cause this, and you should have those cleaned also, but your car is doing exactly what mine did and my money is on the ECTS.

A lot of people have experienced this. It's nothing exotic for the S-Series, just one of it's idiosyncracies.

REWARD EXCELLENCE!

Add to wislauson's Reputation
Rate the quality of this post and help wislauson reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wislauson is offline   Reply With Quote
Old 03-13-2008, 09:17 AM   #9
Phredawgy
Senior Member
Phredawgy is on a distinguished road
 
Phredawgy's Avatar
 
Join Date: Aug 2006
Location: Southeastern Arizona
Posts: 1,810
 

1996 SL2
Default Re: 2002 SL2 High Idle

Quote:
Originally Posted by wislauson View Post
Had the same exact problem with my SC1. This is most likely the ECTS...what can happen is it can get stuck on a certain reading (high or low) and then continue to send the wrong information about what mixture to use. If it thinks the engine is cold, it will continue to call for a high idle. Shutting the car off and then starting it again basically lets it "reboot." The problem will come and go, but it will get progressively more frequent. If you let this go you'll get to a point where shutting the car off doesn't work any more. The good news is it's an easy fix...the technician will take a reading of the coolant temp and then compare that to what the ECTS is sensing and there will probably be a discrepancy. The IAC and throttle body being dirty can also cause this, and you should have those cleaned also, but your car is doing exactly what mine did and my money is on the ECTS.

A lot of people have experienced this. It's nothing exotic for the S-Series, just one of it's idiosyncracies.
What year is your SC1. I'm not real familiar with alot of people with 2002 models having trouble with their ects

I wonder if the op problem could have been, or might be a goofy tps

...
The streets will flow with the blood of all the non-believers!!!! And all those who won't include their vehicles vital information in their posts!!!!

REWARD EXCELLENCE!

Add to Phredawgy's Reputation
Rate the quality of this post and help Phredawgy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Phredawgy is offline   Reply With Quote
Old 03-13-2008, 12:30 PM   #10
rc1488
Master Member
rc1488 has a spectacular aura aboutrc1488 has a spectacular aura about
 
rc1488's Avatar
 
Join Date: Jun 2007
Location: Carmel, NY
Posts: 5,658
 

1997 SL2
1995 SC2
Default Re: 2002 SL2 High Idle

Its NOT the ECTS.

2002 S-series have Brass sensors from the factory.

...
Current: 95 SC2 Man 97 SL2 Auto 98 SL1 Auto 01 SL1 Man 02 SL1 Man
Past: 94 SL2 Man 95 SL2 Man 95 SL2 Man 96 SL2 Auto 97 SL2 Man 98 SL2 Auto 99 SL2 Auto
2010 SCCA Mohud Street Championship-2nd Place

REWARD EXCELLENCE!

Add to rc1488's Reputation
Rate the quality of this post and help rc1488 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
rc1488 is offline   Reply With Quote
Old 03-13-2008, 02:53 PM   #11
banditkaine
Member
banditkaine is on a distinguished road
 
banditkaine's Avatar
 
Join Date: Sep 2007
Location: Miami, FL
Posts: 321
 

2002 SL2
Default Re: 2002 SL2 High Idle

ok so drove it some more to work and back. like 20 miles. didn't do it this time. at one point i thought it was a bit revved up but didn't get a chance to put it in neutral to find out what the rpm's were then.

REWARD EXCELLENCE!

Add to banditkaine's Reputation
Rate the quality of this post and help banditkaine reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
banditkaine is offline   Reply With Quote
Old 03-13-2008, 03:35 PM   #12
wislauson
Junior Member
wislauson is on a distinguished road
 
Join Date: Jan 2008
Posts: 20
Default Re: 2002 SL2 High Idle

It's always frustrating when problems are intermittent. Inevitably when you take it in it's not doing it and you get the "can't duplicate problem" response.

My SC1 is a 2001...I didn't know that the 02's had the brass sensors which apparently never go bad. If that's not the problem then I would guess the problem lies with a dirty throttle body, dirty/bad IAC, or a bad TPS sensor. My problem did go away once the ECTS was replaced but came back three months later with a vengenace. This time in addition to the high idle, the engine would choke itself off whenever I'd come to a stop. It's no fun driving an automatic with one foot on the brake and one on the gas...I had to shift it into neutral and manually keep the RPMs up to keep the car running.

Does it ever "feel" weird? I remember the on the day I had the TPS replaced and throttle body cleaned, it just didn't feel like it was running right at freeway speeds. I'd let my foot off the gas and instead of the car just sort of coasting it would bog down--again sort of like it was being choked off. My car's been running like a top since then, although it's now a two door coupe since I got in an accident and the passenger side door handle is pushed in and jammed. I still have the regular door and suicide door on the driver's side and since I'm the only one in my car it doesn't bother me all that much.

I'd get it looked at. Unfortunately this isn't going to go away and you don't want to wait too long and risk getting stranded and having to pay for a tow.

REWARD EXCELLENCE!

Add to wislauson's Reputation
Rate the quality of this post and help wislauson reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wislauson is offline   Reply With Quote
Old 03-13-2008, 06:25 PM   #13
rc1488
Master Member
rc1488 has a spectacular aura aboutrc1488 has a spectacular aura about
 
rc1488's Avatar
 
Join Date: Jun 2007
Location: Carmel, NY
Posts: 5,658
 

1997 SL2
1995 SC2
Default Re: 2002 SL2 High Idle

Quote:
Originally Posted by wislauson View Post
My SC1 is a 2001...This time in addition to the high idle,
Your car is a different situation. Id recommend you spray some brake cleaner near your intake manifold gasket during idle and listen for changes. If you hear a difference you just found your problem. Your intake manifold gasket is wrinkled.

...
Current: 95 SC2 Man 97 SL2 Auto 98 SL1 Auto 01 SL1 Man 02 SL1 Man
Past: 94 SL2 Man 95 SL2 Man 95 SL2 Man 96 SL2 Auto 97 SL2 Man 98 SL2 Auto 99 SL2 Auto
2010 SCCA Mohud Street Championship-2nd Place

REWARD EXCELLENCE!

Add to rc1488's Reputation
Rate the quality of this post and help rc1488 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
rc1488 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle Speed 2002 SL1 journeyman615 S-Series Tech 9 10-20-2014 03:20 PM
2002 l200 high idle revs tom_foolery L-Series Tech 2 06-13-2009 11:10 PM
HELP!! SL2 High Idle Fireball69 S-Series General 3 11-23-2006 11:51 AM
2002 SL 1.9L SOHC - High Idle Killjoy S-Series General 9 04-17-2006 08:35 PM
2002 AWD V6 high rev at idle Uzzi Vue Tech 13 03-28-2006 08:08 PM


All times are GMT -4. The time now is 08:12 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.