SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 12-04-2019, 04:04 PM   #1
marmitage
Member
marmitage is just really nicemarmitage is just really nicemarmitage is just really nicemarmitage is just really nice
 
marmitage's Avatar
 
Join Date: May 2010
Location: Buchanan ND
Posts: 270
 

1997 SL2
2003 VUE 3.0L
Default 97 sl2 ecm question

time to get back to the the 97. This is the one I had to swap columns on to get going.
Back story. The person I bought this from pulled it from the boneyard stuck a 98 ECM in it and drove it. It was throwing codes and running rough so I replaced the ECM with one from a 97 SL2. Most of the error codes went away and it seemed better. There was still a stumble but the ses light went away. Now when driving down the road there is a stumble at 70 mph + you feel it but it keeps going, at 60 mph it stumbles hard enough to kick cruise control off. Every morning the service wrench light is off by the time I hit the end of the driveway it is back on. The guy I am working with on this tells me the ECM seems to either loose its memory or gets wiped every time it is turned off.
Any ideas we should be trying? Bad ECM again?
Thanks in advance.

...
marmitage
03 Vue Silver, Daughters
97 SL2 Back from the grave
99 Sw2 Daily driver

REWARD EXCELLENCE!

Add to marmitage's Reputation
Rate the quality of this post and help marmitage reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
marmitage is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-04-2019, 04:55 PM   #2
billr
Master Member
billr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to all
 
Join Date: Jul 2013
Posts: 5,211
Default Re: 97 sl2 ecm question

What codes are being set? Check before you start out, to see if everything is really being reset. Then check again at the end of the driveway, when the CEL first comes on; and check after it has been driven for quite a while. I am looking for code history, flags/pending and all; even when the CEL is off.

REWARD EXCELLENCE!

Add to billr's Reputation
Rate the quality of this post and help billr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billr is offline   Reply With Quote
Old 12-04-2019, 06:30 PM   #3
marmitage
Member
marmitage is just really nicemarmitage is just really nicemarmitage is just really nicemarmitage is just really nice
 
marmitage's Avatar
 
Join Date: May 2010
Location: Buchanan ND
Posts: 270
 

1997 SL2
2003 VUE 3.0L
Default Re: 97 sl2 ecm question

My code reader says no codes being set don't have scanner that reads for cel codes. Guy I am working with says he sees things that should be throwing codes. I'll try to get more info from him.
CEL basically comes on asap and stays on until parked then back on in 30 seconds.

...
marmitage
03 Vue Silver, Daughters
97 SL2 Back from the grave
99 Sw2 Daily driver

REWARD EXCELLENCE!

Add to marmitage's Reputation
Rate the quality of this post and help marmitage reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
marmitage is offline   Reply With Quote
Old 12-04-2019, 06:57 PM   #4
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,959
Default Re: 97 sl2 ecm question

There could be several possibilities here. To start with, the PCM has been switched. I would do a crank relearn as that could be the cause of the miss at high speed. It could also be the cause of the wrench light. Hard to say exactly though, it could be from a burnt out bulb in the cluster. There could be other issues, but that is where I would start.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 12-04-2019, 09:02 PM   #5
marmitage
Member
marmitage is just really nicemarmitage is just really nicemarmitage is just really nicemarmitage is just really nice
 
marmitage's Avatar
 
Join Date: May 2010
Location: Buchanan ND
Posts: 270
 

1997 SL2
2003 VUE 3.0L
Default Re: 97 sl2 ecm question

Quote:
Originally Posted by bluesl2 View Post
There could be several possibilities here. To start with, the PCM has been switched. I would do a crank relearn as that could be the cause of the miss at high speed. It could also be the cause of the wrench light. Hard to say exactly though, it could be from a burnt out bulb in the cluster. There could be other issues, but that is where I would start.
Thought of bulbs have been caught before, all are lit.

I should have thought of the crank relearn will do that.

...
marmitage
03 Vue Silver, Daughters
97 SL2 Back from the grave
99 Sw2 Daily driver

REWARD EXCELLENCE!

Add to marmitage's Reputation
Rate the quality of this post and help marmitage reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
marmitage is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn question...(Possibly a dumb question) ninetynineSC2 S-Series Mods 8 02-18-2013 10:01 PM
Tranny Question and Splash Guard Question axslinger S-Series Tech 2 03-19-2007 06:25 PM
Newbie Question - Size of Air condenser compared to radiator? Also airbag question. 2002SaturnMan S-Series General 9 04-18-2006 09:53 AM
Ring job question and timing chain question Preachermannn S-Series General 5 03-10-2005 02:40 PM
Question on replacing differential cover gasket ( non-Saturn question) Mark G Miscellaneous Tech 3 10-27-2002 01:50 AM


All times are GMT -4. The time now is 06:02 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.