SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 12-30-2013, 12:04 AM   #1
Jeffjuice
New Member
Jeffjuice is on a distinguished road
 
Join Date: Dec 2013
Posts: 1
Default Not charging 96 sl2

I've replaced my alternator and tensioner cked voltage from back of alt to starter and only have 11.97 volts running or not.. Car will start and idle fine when I drive it all the lights gon dim air bag light comes on and brake light comes on and the lights go dim each time I hit the gas.. I have power on each side of the fusible link from alt to starter.. Just at a loss.. Since changing the alt the car squeals constantly now sound like power steering pump that's another curve ball it use to only do it when I first started the car then would stop when warmed up.. Any help will be greatly appreciated thanks..

REWARD EXCELLENCE!

Add to Jeffjuice's Reputation
Rate the quality of this post and help Jeffjuice reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Jeffjuice is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-30-2013, 12:54 AM   #2
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,693
 

1998 SC2
Default Re: Not charging 96 sl2

The squeal is your belt slipping, replace it. With the key on and engine off do you have 12v to ground on the 2 small wires to the side of the alternator?

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
charging a/c '97 sl1 dddaaa S-Series Tech 10 05-24-2013 01:03 PM
Not charging. GOF Vue Tech 6 11-26-2011 04:35 PM
charging ac mjoekingz28 S-Series Tech 1 08-19-2009 04:00 PM
Charging a/c ..... ii311hive S-Series Tech 12 06-22-2009 05:09 PM
SL1 Battery charging turtledawn S-Series General 14 12-09-2005 08:52 PM


All times are GMT -4. The time now is 04:47 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.