SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue General

Reply
 
Thread Tools Display Modes
Old 12-20-2019, 12:13 AM   #1
pickett85
New Member
pickett85 is a jewel in the roughpickett85 is a jewel in the roughpickett85 is a jewel in the rough
 
Join Date: Sep 2017
Posts: 9

2007 VUE 3.5L
Default P0341 Camshaft position sensor

Hello all,

I have a 2007 Saturn Vue AWD with the 3.5L Honda engine SOHC and 130K.

Today my wife was driving and the car started running rough then shut off. When I picked her up I could get it to start if I pressed the gas to the floor but it was very rough, I quickly shut it down. CEL came on with P0341. We live in Colorado and it has been cold lately. The car has been starting with a shudder for some time but quickly goes away. Lately this has gotten worse at startup but I attributed it to the cold.

The code comes up as a crankshaft position sensor intermittent interruption. I think I have found the sensor behind the timing belt at the front of the engine. The Hayes book says to take of the timing belt, cover, and sprocket to get to it. I saw a youtube video where a guy did it on a Honda Odyssey without the timing parts removal.

My question is that it seems this part does not typically go bad, part stores don't carry it and no information on the web with replacement, checking, Etc. Could I have slipped a tooth on the timing belt, bad wiring, or other issues causing this. Does anyone have experience with this issue? Anyone changed the CPS without the timing belt removal?

The car previously had the timing belt and tensioner, water pump, battery at 118K but I did the replacement so there is a chance I did it wrong.

Thanks,

-KP
pickett85 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-20-2019, 01:23 AM   #2
pickett85
New Member
pickett85 is a jewel in the roughpickett85 is a jewel in the roughpickett85 is a jewel in the rough
 
Join Date: Sep 2017
Posts: 9

2007 VUE 3.5L
Default Re: P0341 Camshaft position sensor

**code came up as camshaft sensor**
pickett85 is offline   Reply With Quote
Old 12-20-2019, 01:01 PM   #3
Manospeed
Member
Manospeed has a spectacular aura aboutManospeed has a spectacular aura aboutManospeed has a spectacular aura about
 
Join Date: Feb 2018
Posts: 50
Default Re: P0341 Camshaft position sensor

I was just about to ask if its the cam or crank shaft position sensor, but you clarified it in your second post. My 2007 2.2 Vue was throwing error codes as well, but I replaced the camshaft sensor when they did the timing chain work and its been smooth sailing since then. The part itself is pretty cheap.

Not sure where this is located on the 3.5 liter, but I have a repair manual at home. I'll see if I can find how to access this part and post some photos.

https://www.rockauto.com/en/catalog/...on+sensor,7192
Attached Images
File Type: jpg 2019-12-20_10-52-04.jpg (51.1 KB, 6 views)
Manospeed is offline   Reply With Quote
Old 11-12-2020, 07:53 PM   #4
pickett85
New Member
pickett85 is a jewel in the roughpickett85 is a jewel in the roughpickett85 is a jewel in the rough
 
Join Date: Sep 2017
Posts: 9

2007 VUE 3.5L
Default Re: P0341 Camshaft position sensor

Yes the cam position sensor can be taken out without removing the timing belt. Its 1 baby turn at a time with a slim and stubby 10MM (I think), its located on the back side of the timing cover front bank. Research shows this is almost never bad and this was not my problem either. Save your wrists and check the timing marks through the inspection holes 1st to rule out slipped timing/ broken belt. The rear bank timing slipped out 180 DEG damaging all the valves on that bank. You could shine a light through the sides of the valves while installed.

I have had a ton of trouble with the Dayco timing tensioners, DONT USE THEM. This is my second Dayco failure of the tensioner. Used the timing kit from Autozone because of the lifetime warranty, big mistake. Got a new Gates tensioner, E-bay head, had the new e-bay head rebuilt and checked the front bank head that was found to be good, both resurfaced, gates head gaskets, new head bolts if you have star bolts, water pump, timing belt, adjusted valves.

It has been running fine now for almost a year

Its not too bad of a job if you find yourself with a broken/ slipped timing belt and damaged heads.

I will post again if the wife finds a way to break this one.
pickett85 is offline   Reply With Quote
Old 11-12-2020, 10:09 PM   #5
pickett85
New Member
pickett85 is a jewel in the roughpickett85 is a jewel in the roughpickett85 is a jewel in the rough
 
Join Date: Sep 2017
Posts: 9

2007 VUE 3.5L
Default Re: P0341 Camshaft position sensor

Yes the cam position sensor can be taken out without removing the timing belt. Its 1 baby turn at a time with a slim and stubby 10MM (I think), its located on the back side of the timing cover front bank. Research shows this is almost never bad and this was not my problem either. Save your wrists and check the timing marks through the inspection holes 1st to rule out slipped timing/ broken belt. The rear bank timing slipped out 180 DEG damaging all the valves on that bank. You could shine a light through the sides of the valves while installed.

I have had a ton of trouble with the Dayco timing tensioners, DONT USE THEM. This is my second Dayco failure of the tensioner. Used the timing kit from Autozone because of the lifetime warranty, big mistake. Got a new Gates tensioner, E-bay head, had the new e-bay head rebuilt and checked the front bank head that was found to be good, both resurfaced, gates head gaskets, new head bolts if you have star bolts, water pump, timing belt, adjusted valves.

It has been running fine now for almost a year

Its not too bad of a job if you find yourself with a broken/ slipped timing belt and damaged heads.

I will post again if the wife finds a way to break this one.
pickett85 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0341 Camshaft Position Sensor johnwhittum S-Series Tech 1 02-14-2016 02:01 PM
ODB Code P0341 Camshaft Position Sensor Performance Dave3 S-Series Tech 10 08-16-2012 06:52 AM
Code: P0341 Camshaft Position (CMP) Sensor AtlanticBeach S-Series Tech 36 04-02-2012 08:13 AM
P0341 code Camshaft Position Sensor Isis S-Series Tech 1 04-09-2008 02:55 PM
camshaft position sensor out of range code is p0341 kitty S-Series General 1 04-28-2005 11:17 PM


All times are GMT -4. The time now is 11:26 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.