SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-13-2018, 05:16 PM   #1
freemancomputer
Junior Member
freemancomputer has a spectacular aura aboutfreemancomputer has a spectacular aura about
 
Join Date: Aug 2010
Posts: 33
Default A/C work check

Hello all. The A/C in my 07 ION is currently not working. I want to share what I have looked at and what I think before I start working to make sure I am looking at things correctly.

When I start the car and turn the A/C on the light by the button comes on. I started by checking the 10A fuse, it was blown, put a new one it same thing. Changed out the diode now the fuse says as it should. I swapped all the relays with known working, still no cold air. The pressure on the low side looks good, all I have is one of those can gauges this is what I'm going off of. The fan does not kick on until the car gets up to temp. I checked the voltage at the A/C connector which is showing 12v, clutch does not engage. I'm guessing because I am getting the 12 volts at the A/C the clutch/compressor is the problem.

The only thing that makes me think otherwise is the fans not kicking on even tho the voltage is being sent.

Thanks for the help.

REWARD EXCELLENCE!

Add to freemancomputer's Reputation
Rate the quality of this post and help freemancomputer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
freemancomputer is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-13-2018, 07:42 PM   #2
ruley73
Master Member
ruley73 is a name known to allruley73 is a name known to allruley73 is a name known to allruley73 is a name known to allruley73 is a name known to allruley73 is a name known to all
 
ruley73's Avatar
 
Join Date: Aug 2006
Location: Is this heaven?....No, it's Iowa!
Posts: 2,859
 

2007 ION-2 Quad Coupe
Default Re: A/C work check

Quote:
Originally Posted by freemancomputer View Post
Hello all. The A/C in my 07 ION is currently not working. I want to share what I have looked at and what I think before I start working to make sure I am looking at things correctly.

When I start the car and turn the A/C on the light by the button comes on. I started by checking the 10A fuse, it was blown, put a new one it same thing. Changed out the diode now the fuse says as it should. I swapped all the relays with known working, still no cold air. The pressure on the low side looks good, all I have is one of those can gauges this is what I'm going off of. The fan does not kick on until the car gets up to temp. I checked the voltage at the A/C connector which is showing 12v, clutch does not engage. I'm guessing because I am getting the 12 volts at the A/C the clutch/compressor is the problem.

The only thing that makes me think otherwise is the fans not kicking on even tho the voltage is being sent.

Thanks for the help.
There's no guessing about it. This confirms your compressor clutch is bad.

FWIW I replaced my compressor a couple years ago. The clutch suddenly stopped engaging on my compressor too. I bought a kit off ebay that included the compressor, expansion valve, o-rings, and compressor oil needed for the job.

I had a shop retrieve the refrigerant, vacuum it down, and recharge it after I installed the compressor for $100.

...
2007 Ion 2 Quad Coupe 5-speed manual 177K miles
2007 Chevy Equinox LT 183K miles

REWARD EXCELLENCE!

Add to ruley73's Reputation
Rate the quality of this post and help ruley73 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ruley73 is offline   Reply With Quote
Old 06-13-2018, 08:39 PM   #3
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 40,430
 

2003 L-Series 3.0L Sedan
Default Re: A/C work check

freemancomputer, unless you perform 100% repairs with all the equipment needed, the second best way to save money is as suggested by ruley73. Personally, I wouldn't replace the thermal expansion valve for two reasons - they have no record of failure and more importantly may bring additional problems by way of another leak if incorrectly replaced. A compressor, additional oil and O-rings are all that's needed and can be done by anyone with minimal tools.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 06-14-2018, 02:49 PM   #4
freemancomputer
Junior Member
freemancomputer has a spectacular aura aboutfreemancomputer has a spectacular aura about
 
Join Date: Aug 2010
Posts: 33
Default Re: A/C work check

Thanks for the input. This is the first car I have owned that had a problem with the A/C. Was always told that A/C was to hard to work on but after looking into it it does not look to bad its just emptying and filling it.

REWARD EXCELLENCE!

Add to freemancomputer's Reputation
Rate the quality of this post and help freemancomputer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
freemancomputer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed Smog Check After Erasing Check Engine Light Code trench619 Ion General 9 05-01-2015 10:58 AM
Check stabilitrack and check traction control lights gaurdien 2008 Vue 0 01-06-2015 09:07 PM
Gas Gauge doesn't work - What to check first? Major_Tom S-Series Tech 8 10-27-2010 12:35 AM
Did some work, check engine light is on. RBrown20 S-Series Tech 13 03-15-2009 02:34 AM


All times are GMT -5. The time now is 04:48 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.