SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue Green Line
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-22-2018, 03:55 PM   #1
Shadow_tek001
Advanced Member
Shadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of light
 
Shadow_tek001's Avatar
 
Join Date: May 2003
Location: Canada
Posts: 538
 
Default New tensioner assembly, new belt... Still getting p0a92. Help!

I've got a 2008 Saturn vue green line.
My tensioner was screwed causing the belt to slip, and I kept getting the p0a92 code for Hybrid generation performance. So I've replaced the whole tensioner assembly and belt, it no longer slips, but the code keeps coming back.

Do I need a new generator??

Edward.

REWARD EXCELLENCE!

Add to Shadow_tek001's Reputation
Rate the quality of this post and help Shadow_tek001 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Shadow_tek001 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-22-2018, 06:45 PM   #2
bern
Advanced Member
bern is just really nicebern is just really nicebern is just really nicebern is just really nicebern is just really nice
 
Join Date: Apr 2009
Location: San Diego CA
Posts: 567
 

2006 VUE 3.5L
2004 ION-2 Sedan
Default Re: New tensioner assembly, new belt... Still getting p0a92. Help!

I don't know of any Starter Generators that have failed, Is the replacement belt the correct one by application?

Also maybe the following may help :

Conditions for Clearing the DTC
•The diagnostic system has not been disabled.
•There are no crank sensor faults.
•There are no engine coolant temperature sensor faults.
•There are no mass air flow sensor faults.
•There are no intake air temperature sensor faults.
•There are no starter/generator temperature faults.
•There are no starter/generator position sensor faults.
•There are no starter/generator speed faults.
•There are no starter/generator torque delivered faults.

REWARD EXCELLENCE!

Add to bern's Reputation
Rate the quality of this post and help bern reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bern is offline   Reply With Quote
Old 07-22-2018, 09:24 PM   #3
Shadow_tek001
Advanced Member
Shadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of light
 
Shadow_tek001's Avatar
 
Join Date: May 2003
Location: Canada
Posts: 538
 
Default Re: New tensioner assembly, new belt... Still getting p0a92. Help!

Quote:
Originally Posted by bern View Post
I don't know of any Starter Generators that have failed, Is the replacement belt the correct one by application?

Also maybe the following may help :

Conditions for Clearing the DTC
•The diagnostic system has not been disabled.
•There are no crank sensor faults.
•There are no engine coolant temperature sensor faults.
•There are no mass air flow sensor faults.
•There are no intake air temperature sensor faults.
•There are no starter/generator temperature faults.
•There are no starter/generator position sensor faults.
•There are no starter/generator speed faults.
•There are no starter/generator torque delivered faults.
100% the right belt. Tried a dayco or belt first, which just started slipping after a month. So switched to the best belt rock auto was selling. No slippage anymore, but still getting that code.
No other faults reporting.

Edward

REWARD EXCELLENCE!

Add to Shadow_tek001's Reputation
Rate the quality of this post and help Shadow_tek001 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Shadow_tek001 is offline   Reply With Quote
Old 07-23-2018, 11:43 PM   #4
bern
Advanced Member
bern is just really nicebern is just really nicebern is just really nicebern is just really nicebern is just really nice
 
Join Date: Apr 2009
Location: San Diego CA
Posts: 567
 

2006 VUE 3.5L
2004 ION-2 Sedan
Default Re: New tensioner assembly, new belt... Still getting p0a92. Help!

Being at the dealer their is only one choose of belt ( the belt the parts guy gives me ) So I don't know if you the best one rock auto has is good enough.
I looked at (rock auto) the belts for 08 Vue hybrid, only one shows the OEM number.
See
https://www.gmpartsdirect.com/oem-pa...-belt-12629347

Back to rock auto. I don't believe 4 of 5 belts their showing is good enough for a Hybrid.
When check for the 08 Vue hybrid belt tensioner, some non hybrid tensioners are show.
Calling rock auto customer service to confirm cross reference to OEM belt number may be something to try.

REWARD EXCELLENCE!

Add to bern's Reputation
Rate the quality of this post and help bern reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bern is offline   Reply With Quote
Old 07-25-2018, 09:06 AM   #5
tackepj
Senior Member
tackepj will become famous soon enough
 
tackepj's Avatar
 
Join Date: Nov 2004
Location: West Lafayette, IN
Posts: 1,209
 

2008 Astra XE
Default Re: New tensioner assembly, new belt... Still getting p0a92. Help!

Agreed; it uses an aramid core belt that is pretty unique; don't think I've ever seen an aftermarket. Probably a dealer-only part.

...
Former: 2005 L300, 2007 VUE Green Line
Current: 2008 Astra XE

REWARD EXCELLENCE!

Add to tackepj's Reputation
Rate the quality of this post and help tackepj reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tackepj is offline   Reply With Quote
Old 08-02-2018, 11:30 PM   #6
Shadow_tek001
Advanced Member
Shadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of lightShadow_tek001 is a glorious beacon of light
 
Shadow_tek001's Avatar
 
Join Date: May 2003
Location: Canada
Posts: 538
 
Default Re: New tensioner assembly, new belt... Still getting p0a92. Help!

Well....

On everyone's advice I replaced the belt with the OEM gm belt. And GUESS WHAT!! IT DIDN'T WORK!

Drove it for 5 minutes and bam, same problem.

That's, new***dual*** tensioner assembly (and don't tell me it might be a non Hybrid tensioner, as only the hybrids come with the dual system)

A dayco belt, then a continental belt and now a GM aramid belt and still same &@$(- problem.





Edward

REWARD EXCELLENCE!

Add to Shadow_tek001's Reputation
Rate the quality of this post and help Shadow_tek001 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Shadow_tek001 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Belt tensioner and pully assembly saturnmommy S-Series Tech 9 11-14-2017 05:46 AM
help!! L81 V6 timing belt tensioner assembly removal nil5 Vue Tech 9 06-14-2012 09:25 AM
Tensioner rattle is back -- even with new AC Delco tensioner and belt! 2003MercMaraude S-Series Tech 18 10-15-2010 07:23 PM
belt tensioner/removal of serp belt sc95auto S-Series Tech 2 07-02-2008 03:45 PM
WTB: Good Cond. Belt Tensioner Pulley Assembly kickarse Classifieds 3 03-29-2006 09:04 PM


All times are GMT -4. The time now is 06:30 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.