SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-31-2012, 02:30 PM   #1
frankmassa
New Member
frankmassa is on a distinguished road
 
Join Date: Jan 2012
Location: Georgia
Posts: 3

2002 L-Series 2.2L Sedan
Default 2002 Saturn L100 running rough and trouble starting

Hello All,
I have a 2002 Saturn L100 2.2l (~170,000 miles) that has been giving me fits the last few days. Last week the check engine light came on so I took it to AutoZone to have the code read. The guy told me it was the front O2 sensor so I bought one to replace it but like an idiot I didn't ask for the code. I took the car home replaced the sensor that night and then backed it down the driveway. The next morning when I came out the car would not start. It turns over but never actually starts (even with spraying a little engine starter into TB). If I put the pedal all the way to the floor the engine would chug/weeze like it was trying to start but never would. I did some research on this site and thought that maybe the CPS was bad so I replaced it as well as the spark plugs (they were originals in need of replacing). After putting everything back together I got the same symptoms as before. This time after trying to start it for approximately 10 times or so the car finally started. Although it ran very rough at first, eventually as the car warmed the idle got better so I took it out to see how it would run under load. The car seemed a little sluggish/hesitant and there was definitely a little loss in power but the car would definitely go (while stopped the car would almost stall upon giving it gas but it never actually stalled). After running for 10 minutes or so I cut the car off and then tried to restart it and it fired right up as if nothing was wrong. This morning when I came out to start the car I experienced the same issues as before. I had to put the pedal to the floor to get it to crank and it chugged and weezed and finally started, but once it warmed up the engine ran ok other than being a bit hesitant. I've checked the gas pressure at the fuel rail and when I press the valve in it sprays gas about 6-10 inches (haven't actually checked the pressure but I can if I can find a valve) so I don't think it is a fuel pump issue (I can also hear it running for 2 seconds when I turn the key).

I'm not really sure where to turn from here but I'd like not to just throw money at what I think may be wrong with the car. I've had suggestions that maybe the CC is clogged (I'm not really sure how to test that) as well as IAC sensor, and possibly a new ICM or ignition pack. My question is, is there a way I can test these different items before just purchasing new ones?

Just as a heads up I unplugged the battery cable when I took off the starter to replace the CPS which reset the engine light codes and the check engine light has not come back on meaning the guy at Autozone can't run the code.

Any suggestions on what to check next would be greatly appreciated.
Thanks!
Frank

REWARD EXCELLENCE!

Add to frankmassa's Reputation
Rate the quality of this post and help frankmassa reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
frankmassa is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-31-2012, 06:54 PM   #2
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,939
Default Re: 2002 Saturn L100 running rough and trouble starting

It sounds like the catalytic converter is plugged, take the front o2 sensor out and start the engine to see if any improvement is noted. Ideally, you should check the back pressure in the exhaust. If you have a muffler shop nearby they could do it for you.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 02-01-2012, 10:16 AM   #3
frankmassa
New Member
frankmassa is on a distinguished road
 
Join Date: Jan 2012
Location: Georgia
Posts: 3

2002 L-Series 2.2L Sedan
Default Re: 2002 Saturn L100 running rough and trouble starting

A few updates ... I checked fuel pressure last night 52 psi so thats good. I cleaned the MAF sensor b/c it has never been done and I cleaned the IAC sensor and nothing seemed to help. When I drove it last night the SES light came on and so now I have a code
P0172 - Bank 1 System Too Rich is the only code that showed up in the system. Now to do some further research and see if I can't figure this out. Any suggestions would be greatly appreciated.
Also is there a way to check if a catylytic converter has gone bad, or should I just take it to a muffler shop?
Thanks!

REWARD EXCELLENCE!

Add to frankmassa's Reputation
Rate the quality of this post and help frankmassa reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
frankmassa is offline   Reply With Quote
Old 02-03-2012, 09:53 AM   #4
frankmassa
New Member
frankmassa is on a distinguished road
 
Join Date: Jan 2012
Location: Georgia
Posts: 3

2002 L-Series 2.2L Sedan
Default Re: 2002 Saturn L100 running rough and trouble starting

bluesl2 ... I finally got around to checking the O2 snesor last night. Before I removed the sensor the car bogged down when given gas (from the throttle body) and ran very rough. After I pulled the front O2 sensor the car ran much better (rather loudly though ) with no hesitation in acceleration.
Does this eliminate all other problems and isolate the catcon only? If so I'm gonna have to save some to be able to replace it (those things ain't cheap).

In the mean time my autozone sells a catcon delete (we have no emissions test in my area) for a much cheaper temporary fix. Does it throw my rear O2 sensor off if I run the car with no Catcon? I don't want the SES light constantly on and will just scrape the money up somehow if necessary.
Thanks All!

REWARD EXCELLENCE!

Add to frankmassa's Reputation
Rate the quality of this post and help frankmassa reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
frankmassa is offline   Reply With Quote
Old 02-03-2012, 11:56 AM   #5
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,939
Default Re: 2002 Saturn L100 running rough and trouble starting

It sounds like the cat is plugged by what you are saying. I don't know that much about the cat delete setups, if you use that I don't know what they have you do with the rear o2 sensor. If you leave it dangling it's probably going to set the ses light off. Try giving a muffler shop(midas,etc.) a call and get an estimate for a new cat. The aftermarket ones are not exact quality as oem but they should be a lot cheaper than oem.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 02-04-2012, 07:06 PM   #6
tdr1919
Junior Member
tdr1919 is on a distinguished road
 
Join Date: Jan 2012
Location: ny
Posts: 20

2003 L-Series 2.2L Sedan
Default Re: 2002 Saturn L100 running rough and trouble starting

another thing that you can do if you have a fuel pressure tester is to do a leak down test, this will elliminate a leaking fuel injector which will cause a rich code to be thrown. In short with a pressure guage hooked up to the rail, fuel pressure should slowly leak down, if it leaks down too fast, it will point to a faulty injector. I do not have a FSM so I can not tell you the specs.
This test doesnt cost you anything.
Tom

REWARD EXCELLENCE!

Add to tdr1919's Reputation
Rate the quality of this post and help tdr1919 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tdr1919 is offline   Reply With Quote
Old 10-15-2019, 04:19 PM   #7
Rcola1111
New Member
Rcola1111 is on a distinguished road
 
Join Date: Oct 2019
Location: Spring Hill, TN.
Posts: 2
Default Re: 2002 Saturn L100 running rough and trouble starting

Check the EGR valve, make sure a piece of carbon hasn't held the pintle valve open.

REWARD EXCELLENCE!

Add to Rcola1111's Reputation
Rate the quality of this post and help Rcola1111 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Rcola1111 is offline   Reply With Quote
Old 10-20-2019, 02:11 PM   #8
pierrot
Master Member
pierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud of
 
pierrot's Avatar
 
Join Date: Jun 2012
Location: Glendora, CA
Posts: 3,695
 

2000 L-Series 2.2L Sedan
Default Re: 2002 Saturn L100 running rough and trouble starting

Quote:
Originally Posted by Rcola1111 View Post
Check the EGR valve, make sure a piece of carbon hasn't held the pintle valve open.
Welcome to SaturnFans, Rcola1111. It's a good thing to introduce yourself to the forum through the Community Center by placing a post in the Information and Greetings sub-forum.

...
320,000 miles - Holy canolli!
The blessings of liberty erode in my country.
Gov't's grown bigger, but a chance exists that it will be reduced. I'm cautiously hopeful.

REWARD EXCELLENCE!

Add to pierrot's Reputation
Rate the quality of this post and help pierrot reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
pierrot is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 Saturn L100 help please ksamec01 L-Series General 1 01-14-2012 10:40 AM
02 SC2 rough idle and trouble starting jtish S-Series General 7 06-06-2011 09:54 AM
2002 SL 1 sudden on of rough running MBman S-Series Tech 11 07-21-2010 01:06 PM
2002 Saturn L100 problems SaturnL100 L-Series General 4 01-23-2006 05:00 PM
Suddenly running rough and hard starting Alchik General Saturn Discussion 3 04-02-2003 03:27 PM


All times are GMT -4. The time now is 06:30 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.