SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-12-2017, 04:50 PM   #1
GnilradLeahcim
New Member
GnilradLeahcim is on a distinguished road
 
Join Date: Mar 2017
Location: New York
Posts: 6

2002 SL2
Default Help ECTS, rough/fast idle, throttle body, 2002 SL2

I have a 2002 SL2 (which nobody else on the planet seems to have) and ever since I got the thing there's been nothing but problems. Started with car would drive fine, and sometimes when I put the car in park or neutral, engine would race rpm's up to 2000. Several months go by, I replace the TPS (throttle position sensor) fixes the problem completely for two weeks, then back to engine racing. Also, every time I brake for a stop sign/light, as the car is shifting down to (probably) first gear (it's an automatic) the engine revs from 1100 to about 2000 really quick and right back down before the car will stop. When sitting and I let off the gas, the car will go by itself (even uphill) at about 10 mph.

After some research I decided the throttle body had to be cleaned, so I went out, took the main air hose off, played with it a little, put it back the way it was, and for the first time in months I could put the car in park no problem, but in park the rpms would change from 6-900 very randomly. During this time, I felt jerking and random surging when going 50 ish. After about 2 weeks, can't put in park again....

Respected the same process of playing with throttle body, nothing happened. I bought throttle body cleaner, cleaned as best I could without taking it off (had no gasket) nothing changed. I should mention, before me playing with the TB, I could turn the car off and emmidiately back on, and the idle would return to normal (1000). If I stayed under 35, I could put it in park every time. Now when I turn the car on, engine emmidiateoy climbs up 2000 and keeps going unless I shift to drive and hold the brake.(can't even warm the car up).

Service engine soon light randomly goes on and off daily.

Cleaned the egr. Went and bought iac (idle air control) MAP sensor , ECTS (engine coolant temp sensor) thermostat. I can see the ects connector and the wires, but a roughly 2 inch diameter hose connected to the engine is in the way, and a small bracket holding spark plugs are attached it to. I can see virtually no way of reaching my hand in to squeeze the plastic, and no way of getting a ratchet in there. Any help would be appreciated.

I included all the background info in case anybody would think of some magical solution I'm not seeing. Could it possibly be a leak in the gasket of the throttle body?

Regardless what I'm looking for is a solution to replacing the ECTS sensor. He only mechanic in the area that would use a customers parts is completely untrustworthy.

Also, temp. Gauge does not go above 1/4 no matter how long the car is running, but I have no idea how to remove the act compressor to get to the thermostat
Thank you!

(Oil changed frequently, all fluids good, recently replaced fuel injection line)

Last edited by GnilradLeahcim; 03-12-2017 at 04:52 PM.. Reason: Forgot information

REWARD EXCELLENCE!

Add to GnilradLeahcim's Reputation
Rate the quality of this post and help GnilradLeahcim reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
GnilradLeahcim is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast Idle SL2 2002 Manual HELP!!!! donjhunt S-Series Tech 3 07-16-2015 10:14 AM
ECTS, #4 Cylinder, Rough Idle, '95 SL1 SOHC 95SLAJ S-Series Tech 2 06-17-2011 06:14 AM
Accelerator action feels a bit rough after cleaning throttle body magreger S-Series Tech 1 02-16-2011 11:04 AM
Rough Idle when warm - ECTS has been replaced maasdad S-Series Tech 7 09-27-2008 10:26 AM
Engine runs fast while in drive, rough idle pewerner S-Series Tech 2 02-09-2006 12:50 AM


All times are GMT -4. The time now is 09:16 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.