SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 12-23-2009, 06:33 PM   #1
turbodub95
New Member
turbodub95 is on a distinguished road
 
Join Date: Dec 2009
Location: Buffalo NY
Posts: 4

2001 L-Series 3.0L Sedan
Default Speedometer/Odometer stopped working.

Hello, The car is a 2001 l300 3.0 with 94,562 miles. I am new to this forum and new to saturn, for this is not my car but a good friends. He has lost his job and cannot afford to have it serviced as in the past. It is best he does not try to fix it himself, so he has asked me to help.
He explained to me that he noticed the SES light on after he started the car and that the light was not on when he had parked it there the day before. As the car was backed out of the driveway and driven down his street it was noticed that the transmmision(auto) was shifting "roughly" taking longer than usual to shift from gear to gear "a pause before harshly engaging the next gear". Then noticed that the speedo was reading 0, and the odometer has stopped counting.
He is freaked out and does not want the car driven untill he knows more. I looked at it myself.{ O and before i forget he has had to replace the BCM berfore about 2 yrs. ago, and at that time he says it was behaving much differently}. So i turned the key to the on possition and all the gauges work(make there test sweep) except the speedometer, it just moves up to the first hash mark. The car does start up and idle, he says its a little "rougher" than before i cant be certain of this but it could be better. But does not seem like its going to stall. The tach and other gauges work as they should, and he says they were when he was driving but the speedo just stays at the first hash mark. My first thought was it might be some kind of speed sensor/sender/gear in the trans but thought i would ask for some advice first for the car is out side in the cold and i am not about to go crawling around under it for the first time.

Any info about this problem would be great thank you

REWARD EXCELLENCE!

Add to turbodub95's Reputation
Rate the quality of this post and help turbodub95 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
turbodub95 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-23-2009, 07:11 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,451
 

2003 L-Series 3.0L Sedan
Default Re: Speedometer/Odometer stopped working.

The best you can do for your friend or for himself is to have the car scanned for error codes by Autozone or anyplace (AAMCO too?) free and write down the error code(s) for posting here. SES on means the trouble codes can be read by almost any generic OBD II reader/scanner such as the ones used by Autozone as a courtesy for customers in the hopes of promoting parts sales. No one is obligated to buy anything from them but it does allow those states that allow Autozone and other facilities to help customers read their vehicle trouble codes for free and perhaps promote good will (business). California seems to be the only state outlawing this practice. Have the code read, write down the error code and post here for more assistance.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 12-23-2009, 07:28 PM   #3
turbodub95
New Member
turbodub95 is on a distinguished road
 
Join Date: Dec 2009
Location: Buffalo NY
Posts: 4

2001 L-Series 3.0L Sedan
Default Re: Speedometer/Odometer stopped working.

Ok i will do that. I tried to get him to let me drive it to autozone to get this done but he is paranoid it will hurt the car. lol. I told him i would just limp it there but stubborn he is. I know autozone rents out tools mybe they rent out the scan tools, if not then he will just have to use a AAA tow to get it there. I think its a waste but its his car so its up to him i guess.
Thank you for responding and i will get those codes asap.

REWARD EXCELLENCE!

Add to turbodub95's Reputation
Rate the quality of this post and help turbodub95 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
turbodub95 is offline   Reply With Quote
Old 12-23-2009, 07:49 PM   #4
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,451
 

2003 L-Series 3.0L Sedan
Default Re: Speedometer/Odometer stopped working.

Uhh, I think A-z won't loan out their readers lest customers drive away with 'em (NYC). Perhaps in friendlier regions. Unlike loaner tools that are charged to a credit card as collateral until returned, most members including myself simply ask A-z to read our codes. It takes less than a minute to plug-in, turn on the ignition, and read the code(s) in front of you.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 12-23-2009, 08:16 PM   #5
turbodub95
New Member
turbodub95 is on a distinguished road
 
Join Date: Dec 2009
Location: Buffalo NY
Posts: 4

2001 L-Series 3.0L Sedan
Default Re: Speedometer/Odometer stopped working.

O i know i do it all the time for myself. Its great i use Atuozone all the time.The problem is with him not letting me simply drive the car to Autozone. He is making something simple very difficult. Imagine him trying to fix the car himself would take him 2 days just to get it up on jackstands lmao! I just got off the phone with him. Told him what u said, that he needs to get it scanned. Told him drive it, tow it, or buy the scan tool, these are your choices. lol

REWARD EXCELLENCE!

Add to turbodub95's Reputation
Rate the quality of this post and help turbodub95 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
turbodub95 is offline   Reply With Quote
Old 12-23-2009, 08:22 PM   #6
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,451
 

2003 L-Series 3.0L Sedan
Default Re: Speedometer/Odometer stopped working.

Ah, I see now..............................................: clock:

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 12-23-2009, 11:09 PM   #7
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,902
Default Re: Speedometer/Odometer stopped working.

Possibly a bad speed sensor on the transmission or corroded connector at the sensor.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 12-24-2009, 04:29 PM   #8
beensmoked
Senior Member
beensmoked will become famous soon enough
 
Join Date: Sep 2004
Location: Long Island, NY
Posts: 1,340

2001 L-Series 3.0L Sedan
2002 L-Series 2.2L Sedan
Default Re: Speedometer/Odometer stopped working.

most likely the vehicle speed wheel speed sensor. Have you had any exhaust work done? Because the wires that control the speed sensor run very close to the exhaust manifold and are hair thin. Make sure those wires are not crossing or touching and worst burned. The speed sensor is located by the front right wheel. Best way to see it is pop the hood. Look down behind the air box straight down for a little black piece that has to wires connecting and that is thes peed sensor. It's only 20 dollars so it can't hurt to change it

REWARD EXCELLENCE!

Add to beensmoked's Reputation
Rate the quality of this post and help beensmoked reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
beensmoked is offline   Reply With Quote
Old 12-28-2009, 02:09 AM   #9
turbodub95
New Member
turbodub95 is on a distinguished road
 
Join Date: Dec 2009
Location: Buffalo NY
Posts: 4

2001 L-Series 3.0L Sedan
Default Re: Speedometer/Odometer stopped working.

Thank you for the suggestions, i will check it out when i get a chance to get under the car.There has been no work done to the exhaust. My friend did mention that he had just had the oil changed and that the guy in the pit was struggling more than usual and it took longer than other times. Maybe possible he was having a hard time taking off an overtightened oil filter and hit the speed sensor.?
Ok turns out his fathers friend had a code reader and the codes are in order from how the reader gave them: P1780, P0606, P0717, P0751, P0752, P0756, P0757, P1815, P1816, P1817, P1818, P1860.

Last edited by turbodub95; 12-28-2009 at 02:14 AM..

REWARD EXCELLENCE!

Add to turbodub95's Reputation
Rate the quality of this post and help turbodub95 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
turbodub95 is offline   Reply With Quote
Old 12-28-2009, 01:33 PM   #10
beensmoked
Senior Member
beensmoked will become famous soon enough
 
Join Date: Sep 2004
Location: Long Island, NY
Posts: 1,340

2001 L-Series 3.0L Sedan
2002 L-Series 2.2L Sedan
Default Re: Speedometer/Odometer stopped working.

the wheel speed sensor is no where near the oil filter or pan.

REWARD EXCELLENCE!

Add to beensmoked's Reputation
Rate the quality of this post and help beensmoked reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
beensmoked is offline   Reply With Quote
Old 12-28-2009, 01:35 PM   #11
beensmoked
Senior Member
beensmoked will become famous soon enough
 
Join Date: Sep 2004
Location: Long Island, NY
Posts: 1,340

2001 L-Series 3.0L Sedan
2002 L-Series 2.2L Sedan
Default Re: Speedometer/Odometer stopped working.

http://www.engine-light-help.com/sat...ine-light.html

REWARD EXCELLENCE!

Add to beensmoked's Reputation
Rate the quality of this post and help beensmoked reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
beensmoked is offline   Reply With Quote
Old 12-28-2009, 02:48 PM   #12
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,451
 

2003 L-Series 3.0L Sedan
Default Re: Speedometer/Odometer stopped working.

From our How-to library;

DTC P0606 Control Module Internal Performance
DTC P0717 Input Speed Sensor Circuit Low Input
DTC P0751 1-2 Shift Solenoid Valve Performance - No First or Fourth Gear
DTC P0752 1-2 Shift Solenoid Valve Performance - No Second or Third Gear
DTC P0756 2-3 Shift Solenoid Valve Performance - No First or Second Gear
DTC P0757 2-3 Shift Solenoid Valve Performance - No Third or Fourth Gear
DTC P1780 Park/Neutral Position [PNP] Switch Circuit
DTC P1815 Transmission Range Switch - Start In Wrong Range
DTC P1816 TFP Valve Position Sw. - Park/Neu. With Drive Ratio
DTC P1817 TFP Valve Position Sw. - Reverse With Drive Ratio
DTC P1818 TFP Valve Position Sw. - Drive Without Drive Ratio
DTC P1860 TCC PWM Solenoid Circuit Electrical

Whew!? All that? Can't be..................

I should have mentioned resetting these errors since real ones will remain. As it is it seems to be (nonsense) error codes with nothing in common and the only thing that comes to mind is a voltage or ground issue. Check battery and alternator voltage; battery at standstill should be around 12.5v while engine idling voltage should be 13.5v-14.3v. Anything less would mean a faulty alternator or loose belt drive. Our cars depends on good voltage regulation with clean electrical connections. Any poor connections can make the electronics have fits and puke codes attempting to let us know somethings wrong. The P0606 control module error may be the transmission control module; harness connection near the passenger side of the firewall. I'm guessing these errors are red herrings - anomalies that occur when the "sun and the moon are in phase with the coming of the Age of Aquarius" (), or in other words, false errors and should be ignored by resetting memory and starting all over again. You can either pull the main ecm fuse (labeled IGN?) or battery negative for 5-minutes. This should erase all but the important codes at the next turn of the ignition key. Hopefully all will be gone leaving only one or two issues to deal with.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My odometer stopped working. :( 1994Saturn S-Series Tech 5 11-07-2008 07:32 PM
speedometer stopped working LW2 eibbor L-Series Tech 5 01-13-2007 12:55 AM
Odometer stopped working Rapsack S-Series Tech 2 09-07-2006 02:40 PM
Odometer Stopped working! knyks342 S-Series General 4 02-25-2006 10:26 PM
Speedometer stopped working L300Boy L-Series Tech 8 02-24-2006 06:26 PM


All times are GMT -4. The time now is 02:50 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.