SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-09-2009, 04:26 AM   #1
Zappaism
New Member
Zappaism is on a distinguished road
 
Join Date: Oct 2009
Posts: 4
Default 2002 L300 problems

I have a 3.0L that gave me a P0050 code and P0405 code. It runs rough at idle but seems to run ok when you get going. It also said a mifire on cylinder 3. The EGR valve is working fine. Any words of wisdom?

REWARD EXCELLENCE!

Add to Zappaism's Reputation
Rate the quality of this post and help Zappaism reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Zappaism is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-09-2009, 05:07 AM   #2
Zappaism
New Member
Zappaism is on a distinguished road
 
Join Date: Oct 2009
Posts: 4
Default Re: 2002 L300 problems

It also seems to be running rich.

REWARD EXCELLENCE!

Add to Zappaism's Reputation
Rate the quality of this post and help Zappaism reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Zappaism is offline   Reply With Quote
Old 10-10-2009, 04:06 PM   #3
Zappaism
New Member
Zappaism is on a distinguished road
 
Join Date: Oct 2009
Posts: 4
Default Re: 2002 L300 problems

Well I checked the EGR valve and it operated fine. Cleaned it out as shown in the How to library. I also disconnected and reconnected the o2 sensor. Reset the computer and the SES light has gone out and no codes coming up.
Many thanks to FDRYER. I will be back here for all my Saturn needs.

REWARD EXCELLENCE!

Add to Zappaism's Reputation
Rate the quality of this post and help Zappaism reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Zappaism is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 L300 Problems. MikeL L-Series Tech 0 11-05-2005 11:46 PM
Fs: 2002 L300 Urbanrover Classifieds 0 03-15-2005 11:55 AM
power steering problems with 2002 L300 steinerangel L-Series General 5 11-10-2004 09:43 AM
2002 L300 CD Player Problems lubers L-Series General 13 03-12-2003 09:54 PM
Major 2002 L300 problems at 12,000 miles... crawfordna L-Series Tech 17 12-13-2002 07:57 PM


All times are GMT -4. The time now is 11:47 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.