SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-11-2019, 06:47 AM   #1
dlance
New Member
dlance is on a distinguished road
 
Join Date: Oct 2019
Location: Missouri
Posts: 2

2007 ION-2 Sedan
Default 2007 Saturn Ion 2.2L Fuel/Evap System Issue?

I have two separate issues that started on the same day. First off, my car is dying on idle, the rpm jumps a bit, sometimes it powers through for a bit, sometimes it just dies. Either way, if it idles long enough, it will die. Starts right back up no problem, though. I've read enough that it seems like an issue with the fuel injectors, so I've got some being shipped out and then we'll see.

The other issue, which is a little more perplexing, every time I fuel up the car, it doesn't start. If I just turn the key it'll crank indefinitely, but will start if I pump the gas a little. Aside from the dying on idle thing, it runs and starts up just fine after that, never another issue until fueling up again. For this, I tested with the gas cap off, and after taking the cap off and putting it back on, and it does not replicate the issue, so it seems to be specifically from the fuel up.

There is a bit of part swap history leading up to this, starting with a code P0446. For background, the previous owners apparently lived on a gravel road, because everything not sealed was very dusty. When I pulled the evap vent valve solenoid it was caked in dust, so I popped in a new one. Had a code P0442 after this, changed the gas cap. Code persisted, so I changed the evap purge valve solenoid. That's when the issues began, starting with the car not starting after fuel up. Really seemed like a fuel filter issue at first so I changed that to no avail. Instead of clearing the code after I changed the purge valve solenoid, I decided to see if it went away on its own (it didn't), so after changing the fuel filter doesn't help, I check again and it's still P0442 and now P0446 again. I pull the vent valve solenoid, it's all dusty because I had no wherewithal to blow out the plug hole when I changed it before. I blast em both (the solenoid and plug hole) with compressed air, put it back, and clear the codes. I also changed the oil and spark plugs in preparation for asking for advice. The check engine light hasn't come back on (it's only been a week, though) but the other issues persist, and here we are today.

When the code P0446 first came up, I noticed an initial loss of about 3MPG (I have a detailed spreadsheet for miles each time I fuel up) but other than that there was no notable difference in performance from then until the purge valve solenoid was changed. As it is for many, my dad is my mechanic wingman, and he's absolutely perplexed by the situation, which is why I've turned here, so if anyone has any idea, I'd appreciate hearing it!

Thanks all, Dan

REWARD EXCELLENCE!

Add to dlance's Reputation
Rate the quality of this post and help dlance reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dlance is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-11-2019, 04:11 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,150
 

2003 L-Series 3.0L Sedan
Default Re: 2007 Saturn Ion 2.2L Fuel/Evap System Issue?

With the check engine light off and several days of driving, what do you mean by other issues?

Mileage, maintenance done, engine related parts replaced in addition to fuel filter, plugs, purge and vent valve? Was the throttle body cleaned? Is there a maf sensor (between air filter and throttle body) that may need to be cleaned?

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 10-11-2019, 11:47 PM   #3
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,939
Default Re: 2007 Saturn Ion 2.2L Fuel/Evap System Issue?

Try taking the purge valve off the car and see if you can blow air through it, you should not be able to. It should be in a mechanically closed position. It's possible you may have two issues, sometimes the vent solenoids do go bad. Can you apply power and ground to the pins on it to see if it clicks? If it were me, I would check the purge valve first as mentioned though, maybe that is causing the vent issue.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 11-06-2019, 08:15 AM   #4
dlance
New Member
dlance is on a distinguished road
 
Join Date: Oct 2019
Location: Missouri
Posts: 2

2007 ION-2 Sedan
Default Re: 2007 Saturn Ion 2.2L Fuel/Evap System Issue?

Quote:
With the check engine light off and several days of driving, what do you mean by other issues?
The issues I was experiencing at time of posting are the ones outlined in the first and second paragraph. I performed routine maintenance to cover my bases before posting here, but that had no bearing on the problems being experienced.

Quote:
Try taking the purge valve off the car and see if you can blow air through it, you should not be able to. It should be in a mechanically closed position. It's possible you may have two issues, sometimes the vent solenoids do go bad. Can you apply power and ground to the pins on it to see if it clicks? If it were me, I would check the purge valve first as mentioned though, maybe that is causing the vent issue.
So it took me a while to get back here (I may have forgotten about posting here...) but I did check the purge valve. I couldn't blow through either end of it, but I accidentally broke a stem off one side taking the hose off it (still not sure why it was stuck with lock off) so I had to replace it anyways. The one I got from Autozone could be blown through on the end with the connector, but my two major issues totally went away. The engine light came back on with the P0446 code but I'll take that over the car being near undriveable.

It's the holiday season, so money is getting tight (mainly why I was so busy that I forgot about posting here), but I wanted to give a status update for posterity. I plan on trying to get another properly functioning purge valve down the line here and see if I can't figure out what was going wrong.

Quote:
Was the throttle body cleaned? Is there a maf sensor (between air filter and throttle body) that may need to be cleaned?
Planning on checking this out today. If it's dirty and cleaning it makes a marked difference, I'll report back. Otherwise, it'll probably be a couple of months before I have some extra cash for experimenting.

REWARD EXCELLENCE!

Add to dlance's Reputation
Rate the quality of this post and help dlance reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dlance is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 vue 3.5 fuel drop issue slippage Vue Tech 1 09-12-2014 03:47 PM
evap system not available? ddeuces22 S-Series Tech 3 04-18-2013 12:40 AM
2007 Vue EVAP Unready MichaelSmith S-Series General 1 01-03-2013 08:31 PM
2007 Saturn Vue AWD Fuel System Service??? tmillerok Vue Tech 5 10-10-2012 06:35 PM
fuel system related issue? tclausen L-Series Tech 8 12-27-2011 06:04 PM


All times are GMT -4. The time now is 04:17 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.