SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-11-2012, 09:11 PM   #1
kevster0522
Member
kevster0522 has a spectacular aura aboutkevster0522 has a spectacular aura about
 
kevster0522's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 149

1995 SL1
Default HVac Lights not working!

So I just installed a new car radio in my 95 sl1 and noticed that all the lights where the temperature and fan controls are are all burnt out. I checked the fuses that I thought related to those lights and they all were fine! I even put in the old radio to see if that would fix it but it didn't. Can someone please help me?

REWARD EXCELLENCE!

Add to kevster0522's Reputation
Rate the quality of this post and help kevster0522 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
kevster0522 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-11-2012, 09:53 PM   #2
off-track
Master Member
off-track has a spectacular aura aboutoff-track has a spectacular aura aboutoff-track has a spectacular aura about
 
off-track's Avatar
 
Join Date: Dec 2007
Location: Madison, Wi
Posts: 3,093
 

1997 SL2
Default Re: HVac Lights not working!

Did they work before? Pull the HVAC panel and check/replace the bulb.

I can only reference a Gen-II+ but, I'd expect it should be similar?

...
1997 - SL2, barebones, 161k, Auto - Rebuild complete and.. burnt a valve 20k later Arrgh!
Purchased 114k 10/07
Added OEM CC

REWARD EXCELLENCE!

Add to off-track's Reputation
Rate the quality of this post and help off-track reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
off-track is offline   Reply With Quote
Old 03-11-2012, 10:08 PM   #3
kevster0522
Member
kevster0522 has a spectacular aura aboutkevster0522 has a spectacular aura about
 
kevster0522's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 149

1995 SL1
Default Re: HVac Lights not working!

Thanks for the quick reply

They defiantly worked before I installed the radio. I can't remember if they worked right after I installed it or if they stopped working today (I installed the radio yesturday).
Unfortunately I don't have any bulbs to test it with but I did put a volt tester (just two prongs with an led on the end) to the lights leads and I didn't get anything so I think they aren't getting power from somewhere or my volt tester isn't working. I also looked at the bulb and the filament doesn't look broken. I would also assume the 2nd gen would be close to the same.

Last edited by kevster0522; 03-11-2012 at 10:21 PM..

REWARD EXCELLENCE!

Add to kevster0522's Reputation
Rate the quality of this post and help kevster0522 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
kevster0522 is offline   Reply With Quote
Old 03-11-2012, 10:22 PM   #4
off-track
Master Member
off-track has a spectacular aura aboutoff-track has a spectacular aura aboutoff-track has a spectacular aura about
 
off-track's Avatar
 
Join Date: Dec 2007
Location: Madison, Wi
Posts: 3,093
 

1997 SL2
Default Re: HVac Lights not working!

Did you muck with the OEM wiring harness or just get the correct GM adapter for the aftermarket radio?

...
1997 - SL2, barebones, 161k, Auto - Rebuild complete and.. burnt a valve 20k later Arrgh!
Purchased 114k 10/07
Added OEM CC

REWARD EXCELLENCE!

Add to off-track's Reputation
Rate the quality of this post and help off-track reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
off-track is offline   Reply With Quote
Old 03-11-2012, 10:42 PM   #5
kevster0522
Member
kevster0522 has a spectacular aura aboutkevster0522 has a spectacular aura about
 
kevster0522's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 149

1995 SL1
Default Re: HVac Lights not working!

I just got an adapter.

The kit I got was one on ebay. it came with the wiring harness, antenna adapter, and body kit.

REWARD EXCELLENCE!

Add to kevster0522's Reputation
Rate the quality of this post and help kevster0522 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
kevster0522 is offline   Reply With Quote
Old 03-11-2012, 11:19 PM   #6
PurdueGuy
Master Member
PurdueGuy is a jewel in the roughPurdueGuy is a jewel in the roughPurdueGuy is a jewel in the rough
 
PurdueGuy's Avatar
 
Join Date: Feb 2005
Location: Blackfoot, ID
Posts: 6,483

1999 SC2
1999 SC1
Default Re: HVac Lights not working!

Did you completely insulate the ends of the unused wires? It's very common to have a short that blows the fuse (10a under the hood), which will generally leave hvac, cluster, and rear driving lights out.

...
SaturnSeries.net owner

REWARD EXCELLENCE!

Add to PurdueGuy's Reputation
Rate the quality of this post and help PurdueGuy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
PurdueGuy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fog Lights, Dashboard lights, Tail lights are not working dbunch Vue Tech 8 10-10-2015 03:33 PM
A/C (HVAC) not working after BCM/PCM swap x-angel S-Series Tech 2 04-13-2008 08:46 PM
HVAC fan quit working wifes03ion Ion General 0 01-13-2007 01:06 PM
SC1 HVAC lights help!! ExcitedMoose S-Series Tech 0 06-12-2006 05:39 PM
IP, HVAC lights out David 93 SL2m S-Series Tech 21 06-09-2003 05:11 PM


All times are GMT -5. The time now is 11:41 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.