SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-14-2007, 01:13 AM   #1
HiMileSL2
New Member
HiMileSL2 is on a distinguished road
 
Join Date: Jan 2007
Posts: 3
Default SL2 1994 Emissions Failed, hesitates, dies

Failed emissions in Texas 2 weeks ago. Very high mileage. Extremely high NOX and HC. Intermittently hesitated and died at all speeds but quickly restarted. Never happened during warm-up. Intermittently had Service Engine Soon Light on.

I did this for repair:
1. New catalytic converter

2. New EGR Valve and EGR Vacuum Solenoid

3. New O2 sensor

4. New thermostat

5. New spark plugs and spark plug wires

Took car back for re-inspection today - they did not even test it because it ran so badly - rough and probably missing. BUT the service-engine-soon light was not on. After I drove it (after state testing) the service-engine-soon light came back on.

Any ideas on what to do next? Thought about replacing computer (dealer did about 3 years ago w/rebuilt) but not sure that's going to solve it. Baffled.

REWARD EXCELLENCE!

Add to HiMileSL2's Reputation
Rate the quality of this post and help HiMileSL2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
HiMileSL2 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-14-2007, 02:20 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,471
 

2003 L-Series 3.0L Sedan
Default Re: SL2 1994 Emissions Failed, hesitates, dies

Have you replaced the engine coolant temperature sensor (ECTS)? Check the How-To section, old plastic one replaced with a new brass one.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 01-14-2007, 10:07 AM   #3
DonP
Master Member
DonP will become famous soon enoughDonP will become famous soon enough
 
Join Date: Jun 2006
Location: VA
Posts: 3,582
 

1995 SL2
Default Re: SL2 1994 Emissions Failed, hesitates, dies

What codes does the SES give?

Are the posts on the coil clean and corrosion free?

REWARD EXCELLENCE!

Add to DonP's Reputation
Rate the quality of this post and help DonP reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DonP is offline   Reply With Quote
Old 01-14-2007, 06:41 PM   #4
HiMileSL2
New Member
HiMileSL2 is on a distinguished road
 
Join Date: Jan 2007
Posts: 3
Default Re: SL2 1994 Emissions Failed, hesitates, dies

The codes are

19 ignition system fault-intermittent 7X signal or loss of 58X signal or 6X signal

32 barometric pressure (BARO) sensor circuit failure
** exhaust gas recirculation (ERG) valve diagnostic switch closed during engine startup or open when ERG flow requested by the ECM.

** electronic regulator valve (EVRV) error (EVRV controls EGR vacuum)


One symptom I forgot to mention is above 45 or 50 mph the speedometer wobbles or waivers.

Does this reveal anything new? Thanks for the assist.

REWARD EXCELLENCE!

Add to HiMileSL2's Reputation
Rate the quality of this post and help HiMileSL2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
HiMileSL2 is offline   Reply With Quote
Old 01-14-2007, 06:44 PM   #5
HiMileSL2
New Member
HiMileSL2 is on a distinguished road
 
Join Date: Jan 2007
Posts: 3
Default Re: SL2 1994 Emissions Failed, hesitates, dies

Quote:
Originally Posted by fdryer View Post
Have you replaced the engine coolant temperature sensor (ECTS)? Check the How-To section, old plastic one replaced with a new brass one.
Will be checking into that soon. Thanks for suggestion.

Also forgot to mention the spark plug coils are clean

REWARD EXCELLENCE!

Add to HiMileSL2's Reputation
Rate the quality of this post and help HiMileSL2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
HiMileSL2 is offline   Reply With Quote
Old 01-14-2007, 10:42 PM   #6
DonP
Master Member
DonP will become famous soon enoughDonP will become famous soon enough
 
Join Date: Jun 2006
Location: VA
Posts: 3,582
 

1995 SL2
Default Re: SL2 1994 Emissions Failed, hesitates, dies

How about the coil pack-to-engine mounting (under the pack)?

REWARD EXCELLENCE!

Add to DonP's Reputation
Rate the quality of this post and help DonP reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DonP is offline   Reply With Quote
Old 01-15-2007, 07:19 AM   #7
BarnOwl
Super Member
BarnOwl is just really niceBarnOwl is just really niceBarnOwl is just really niceBarnOwl is just really nice
 
BarnOwl's Avatar
 
Join Date: May 2005
Location: Hickory, NC
Posts: 10,029
 

2000 SW2
1998 SL2
Default Re: SL2 1994 Emissions Failed, hesitates, dies

First, clean your EGR valve. There are instructions in the How-To Library. If that doesn't make it run better, disconnect and plug the vacumn hoses to the EGR. If that does make it run better, it's time for an EGR.

...
There is nothing more frightening than ignorance in action.

REWARD EXCELLENCE!

Add to BarnOwl's Reputation
Rate the quality of this post and help BarnOwl reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
BarnOwl is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 SL2 hesitates Keefer S-Series Tech 22 09-26-2007 06:53 PM
1993 SL2 failed emissions MsgtDav(ret) S-Series General 5 03-06-2006 04:57 AM
My 1996 SL2 failed emissions (map sensor problem??) 96saturnguy S-Series General 3 01-25-2006 03:02 PM
My '93 SL2 failed NJ emissions. $1K Special S-Series General 10 07-02-2005 09:34 AM
'00 SL2 Failed NC emissions - p0171 + horn oogy S-Series General 1 06-29-2005 03:38 PM


All times are GMT -4. The time now is 09:35 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.