SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-06-2012, 09:01 PM   #1
texasboy
Junior Member
texasboy is on a distinguished road
 
Join Date: Oct 2012
Posts: 10

1994 SL2
Default Won't start and confused.

I'm sure this may have been asked before. I have a 94 SL2, DOHC, and 267K miles. The engine finally stopped running and can't figure out why it won't start again. The engine was acting like it had been flooding prior to when it stopped all together. Replaced plugs, fuel pressure regulator, and finally fuel pump. Still acting like it wants to start but just sputters at best. In order to get any response for it to start I have to hold the pedal to the floor, but it won't follow-through with starting. This is the first that I've had any major problems since I bought it. Also replaced the entire exhaust system (catalytic converter, pipe, and muffler) a few months ago. Any suggestions for next steps would be appreciated. I also purchased fuel injectors if I need to go that route, but trying to avoid getting into that replacement if not necessary.

REWARD EXCELLENCE!

Add to texasboy's Reputation
Rate the quality of this post and help texasboy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
texasboy is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-06-2012, 09:39 PM   #2
fetchitfido
Super Member
fetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant future
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 14,403
 

2001 SC2
Default Re: Won't start and confused.

No mention of replacing the $12 ECTS that's probably causing the issue.

REWARD EXCELLENCE!

Add to fetchitfido's Reputation
Rate the quality of this post and help fetchitfido reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fetchitfido is offline   Reply With Quote
Old 10-06-2012, 09:45 PM   #3
cleverbot
Member
cleverbot is on a distinguished road
 
cleverbot's Avatar
 
Join Date: Dec 2011
Location: NorthWest Indiana
Posts: 274

1994 SC2
1998 SL2
Default Re: Won't start and confused.

Fet is prob right. Had this same prob with my 94 SC2. Changed the ECTS all fixed.

...
1994 Saturn SC2 (5-speed) with 240k. (RIP Junked 11/16/12)
1993 Toyota Tercel STD (4-speed) (sold)
1998 Saturn SL2 125,000 miles (RUNNING FANTASTIC!!!)
2012 Chevy Sonic 26,000 miles (5-speed)

REWARD EXCELLENCE!

Add to cleverbot's Reputation
Rate the quality of this post and help cleverbot reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
cleverbot is offline   Reply With Quote
Old 10-06-2012, 09:48 PM   #4
texasboy
Junior Member
texasboy is on a distinguished road
 
Join Date: Oct 2012
Posts: 10

1994 SL2
Default Re: Won't start and confused.

That is why I posted on this forum. I don't have the same knowledge as the input from others. Please be clear about the acronym ECTS so that I can get the correct part and replace it properly.

REWARD EXCELLENCE!

Add to texasboy's Reputation
Rate the quality of this post and help texasboy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
texasboy is offline   Reply With Quote
Old 10-06-2012, 09:53 PM   #5
cleverbot
Member
cleverbot is on a distinguished road
 
cleverbot's Avatar
 
Join Date: Dec 2011
Location: NorthWest Indiana
Posts: 274

1994 SC2
1998 SL2
Default Re: Won't start and confused.

Quote:
Originally Posted by texasboy View Post
That is why I posted on this forum. I don't have the same knowledge as the input from others. Please be clear about the acronym ECTS so that I can get the correct part and replace it properly.
Engine Coolant Temperature Sensor (ECTS)

This video should help. http://www.youtube.com/watch?v=cucm7QGlsYs

This should also help.

http://saturnseries.net/DIY%20Guides...eries-ECTS.htm

...
1994 Saturn SC2 (5-speed) with 240k. (RIP Junked 11/16/12)
1993 Toyota Tercel STD (4-speed) (sold)
1998 Saturn SL2 125,000 miles (RUNNING FANTASTIC!!!)
2012 Chevy Sonic 26,000 miles (5-speed)

REWARD EXCELLENCE!

Add to cleverbot's Reputation
Rate the quality of this post and help cleverbot reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
cleverbot is offline   Reply With Quote
Old 10-06-2012, 10:02 PM   #6
texasboy
Junior Member
texasboy is on a distinguished road
 
Join Date: Oct 2012
Posts: 10

1994 SL2
Default Re: Won't start and confused.

I'm very grateful for the suggestion and the video tutorial. I've not had a single problem with my SL2 until this last spring. Extremely grateful for how the car has lasted so well until now. I'll get that sensor replaced tomorrow and report back how it turned out.

REWARD EXCELLENCE!

Add to texasboy's Reputation
Rate the quality of this post and help texasboy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
texasboy is offline   Reply With Quote
Old 10-07-2012, 02:41 PM   #7
texasboy
Junior Member
texasboy is on a distinguished road
 
Join Date: Oct 2012
Posts: 10

1994 SL2
Default Re: Won't start and confused.

Ok, I replaced the ECTS. The engine almost starts but won't stay started. Still acting like it's flooded. I have to keep the pedal to the floor to get it cranked enough to try and start. Once I release the ignition, the engine sputters and dies out. Any further suggestions?

REWARD EXCELLENCE!

Add to texasboy's Reputation
Rate the quality of this post and help texasboy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
texasboy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Very Confused with my 1998 SL... Intermittent No-Start tulsavw S-Series General 7 08-17-2009 06:42 PM
So confused.... JPearce1 S-Series General 8 03-26-2009 12:00 PM
Confused... wallywoo Vue Red Line 4 07-18-2007 08:47 PM
confused LOWDOWN S-Series Tech 3 10-03-2006 09:35 PM
confused..... HookedUpSL2 S-Series Mods 10 04-09-2004 07:43 AM


All times are GMT -4. The time now is 10:01 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.