SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-08-2008, 10:34 PM   #1
ysabeau
New Member
ysabeau is on a distinguished road
 
Join Date: Aug 2008
Posts: 2
Default 1999 Saturn SL horn - new not working

I have a 1999 Saturn SL-2 whose horn quit awhile back using both remote and the steering wheel mount. I changed fuses in the box under the hood and even bought a new horn yesterday as a replacement. However, when I plugged the new horn in (before bolting everything back in place), it still is not working.

I saw on the forum something about checking a green wire and a black one -- could someone explain exactly how to do this (I'm definitely not a mechanic, but I can follow good directions -- including the great video on taking the horn out -- Thanks!). Any other troubleshooting directions/tips that can be done to help me get this fixed would be GREATLY appreciated.

REWARD EXCELLENCE!

Add to ysabeau's Reputation
Rate the quality of this post and help ysabeau reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ysabeau is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-08-2008, 11:58 PM   #2
Dach
Senior Member
Dach is a jewel in the roughDach is a jewel in the roughDach is a jewel in the rough
 
Join Date: Jan 2002
Location: Texas
Posts: 1,033
Default Re: 1999 Saturn SL horn - new not working

The horn uses the frame as a ground so you have to have it mounted or touching the frame to test it.

REWARD EXCELLENCE!

Add to Dach's Reputation
Rate the quality of this post and help Dach reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Dach is offline   Reply With Quote
Old 08-09-2008, 08:33 AM   #3
s3nfo
Senior Member
s3nfo is a jewel in the roughs3nfo is a jewel in the roughs3nfo is a jewel in the rough
 
s3nfo's Avatar
 
Join Date: Oct 2001
Location: San Diego, Ca
Posts: 1,946

2001 L-Series 3.0L Wagon
Default Re: 1999 Saturn SL horn - new not working

This question was pretty easy, but in future if you have a more complicated question you'll get better answers if you post in the correct forum. You have an S series car, this is the L series forum. It's a common newby mistake and welcome to the boards.

...
Jerry N

"Politics is the art of looking for trouble, finding it, misdiagnosing it and then misapplying the wrong remedies."

Groucho Marx

REWARD EXCELLENCE!

Add to s3nfo's Reputation
Rate the quality of this post and help s3nfo reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
s3nfo is offline   Reply With Quote
Old 08-09-2008, 11:53 AM   #4
ysabeau
New Member
ysabeau is on a distinguished road
 
Join Date: Aug 2008
Posts: 2
Default Re: 1999 Saturn SL horn - new not working

Yeah, I just noticed my mistake this morning. Haste makes waste especially when you're so frustrated. I'll post there because I still am not sure what to do. How do I test it and where do I go from there, etc. With gas taking up all my money, can't get things like this looked into by a pro.

REWARD EXCELLENCE!

Add to ysabeau's Reputation
Rate the quality of this post and help ysabeau reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ysabeau is offline   Reply With Quote
Old 09-07-2009, 02:32 PM   #5
lesleybean
New Member
lesleybean is on a distinguished road
 
Join Date: Mar 2006
Posts: 1
Default Re: 1999 Saturn SL horn - new not working

Hi, did you ever get your horn working? Mine is currently not working.
Thanks!

REWARD EXCELLENCE!

Add to lesleybean's Reputation
Rate the quality of this post and help lesleybean reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lesleybean is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Saturn SL speedometer and tachometer stop working (funky electrical) gary80920 S-Series Tech 2 11-19-2009 02:05 PM
1999 Saturn SL1 - power locks clicking, windows not working Kurt321 S-Series General 2 05-28-2007 04:27 PM
How to Replace the Horn 1999 SL1 CORROSIONMAN S-Series Tech 3 06-03-2006 10:03 AM
Horn button not working Lee3333 S-Series Tech 3 06-13-2005 09:47 PM
Horn not working gunny S-Series Tech 10 08-28-2002 01:52 PM


All times are GMT -4. The time now is 06:42 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.