SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-15-2011, 04:17 PM   #1
jacobs
New Member
jacobs is on a distinguished road
 
Join Date: Sep 2011
Posts: 1
Default Engine RPM stay up when clutch is in

So this normally happens after a long trip on the interstate but can happen around town. What usually happens is when I put the clutch in to shift the RPM go to about 2,500 - 3,000 and hold there for 5-10 seconds. I tried replacing both O2 sensors but still the same problem. Any Ideas?

REWARD EXCELLENCE!

Add to jacobs's Reputation
Rate the quality of this post and help jacobs reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jacobs is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 clutch replacement--must engine be removed to access clutch? agingric S-Series Tech 3 11-11-2010 10:30 AM
Clutch AND Engine RScottB S-Series Tech 11 05-28-2008 05:50 PM
Start engine w/o clutch RobertGary1 S-Series General 11 11-16-2005 02:50 PM
So got a new engine and clutch kit... kickarse Mods and Performance 0 10-12-2005 08:52 PM
Light (service engine soon) Stay on Flow S-Series Tech 2 05-01-2000 05:05 PM


All times are GMT -4. The time now is 11:37 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.