SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Outlook > Outlook General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-24-2019, 06:18 PM   #1
Jvermillion
New Member
Jvermillion is on a distinguished road
 
Join Date: Feb 2019
Posts: 1
Default 07 Outlook running issues

2007 Outlook XR 170,000 miles all stock. Last oil change less than 2,000 miles ago. Have put in Lucas injector cleaner and an oil treatment.

It was running fine, drove about 60 miles City driving for 20 then highway up to 80 mph for 30 and then city again for 10. Turned off for 2 hours to go into a doctor appt, it was parked where the front end was on a slight incline. I came back got in and it was a rough start, cranked for about 15 seconds, then 10 sec, then 30 seconds before finally starting. There was a bad vibration through the whole car and very rough idle. Tried to drive it and it would not accelerate even with pedal pressed to floor. After about 5-10 seconds of it revving up it would start to move it was very sluggish but started accelerating it still ran very rough with bad vibration. It would take close to a minute for it to get going faster than 10 mph then it would accelerate better and vibrations calmed down a little. Top speed I got it to was around 30 mph. I’ve had something like this happen before, something to do with the traction control made it run the exact same, it was parked for a couple hours then ran perfect again. So I pulled it into a parking lot to turn it off to maybe reset computers or something. Opened the hood and the whole block was vibrating and smelled like something electrical was burning. The battery ended up dying from trying to crank it so that’s as far as I got

Last edited by Jvermillion; 02-24-2019 at 06:19 PM.. Reason: Misspelled word

REWARD EXCELLENCE!

Add to Jvermillion's Reputation
Rate the quality of this post and help Jvermillion reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Jvermillion is offline   Reply With Quote
SaturnFans.com Sponsored Links
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 outlook electrical issues after trailer hook up RYNDOIT Outlook General 2 05-30-2017 05:39 PM
electrical issues with my 2007 Outlook smoke1439 General Saturn Discussion 1 10-04-2009 10:32 AM
HELP....Outlook XR Battery Issues cehasgr Outlook General 6 09-21-2008 09:12 AM
Any Ideas on Running Boards for the Outlook? wilkman Outlook General 0 01-26-2007 11:42 PM


All times are GMT -4. The time now is 05:11 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.