SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-18-2011, 09:46 PM   #1
tway
Junior Member
tway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the rough
 
Join Date: Jun 2009
Location: nova scotia
Posts: 15

2002 L-Series 3.0L Sedan
Default horn not working, key fob not working

I have a saturn l300 V6 and it has some issues. both my key fobs quit working and i have tried new batteries. at the same time my horn quit working. also now when i open the door the chimes sound like the key is still in the ignition. my door locks work normally f i use the lock bottons on the door. i don't have any fault lights and the security light does come on momentarily when i start the car. any ideas

REWARD EXCELLENCE!

Add to tway's Reputation
Rate the quality of this post and help tway reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tway is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-18-2011, 10:31 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,237
 

2003 L-Series 3.0L Sedan
Default Re: horn not working, key fob not working

Try pressing the Lock and Unlock buttons on each remote near the car until the doorlocks cycle to indicate each remote resynching with the bcm.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 02-21-2011, 11:12 PM   #3
cake
New Member
cake is on a distinguished road
 
Join Date: Feb 2011
Posts: 7
Default Re: horn not working, key fob not working

I wish I could offer you some advise. I actually have a problem with my key fob too. When I lock the doors with the lock button it sets off the car alarm. So I have to lock doors from the button on inside and close the door. However, the unlock, tailgate and car alarm buttons work normal.

REWARD EXCELLENCE!

Add to cake's Reputation
Rate the quality of this post and help cake reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
cake is offline   Reply With Quote
Old 02-22-2011, 04:42 PM   #4
bill buttermore
Member
bill buttermore will become famous soon enough
 
bill buttermore's Avatar
 
Join Date: Sep 2010
Location: Ames, Iowa
Posts: 55

2000 L-Series 3.0L Wagon
Default Re: horn not working, key fob not working

Sometimes, the reason a key fob quits working is because the electrical contacts have become dirty. Over time, oil and dirt accumulates between the contacts and can get so bad that one or all of the buttons fail(s) to function. To clean the contacts, disassemble the key fob, separating the silicone rubber key pad from the printed circuit board. You will see carbon buttons on the back of the key pad. Clean both the carbon buttons and the electrical contacts on the printed circuit board where the buttons touch. Use rubbing alcohol on a q-tip. I have revived several key fobs, mirror switches and television remotes this way.

REWARD EXCELLENCE!

Add to bill buttermore's Reputation
Rate the quality of this post and help bill buttermore reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bill buttermore is offline   Reply With Quote
Old 02-24-2011, 10:09 PM   #5
tway
Junior Member
tway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the rough
 
Join Date: Jun 2009
Location: nova scotia
Posts: 15

2002 L-Series 3.0L Sedan
Default Re: horn not working, key fob not working

tried the key fob reprogram procedure with no luck. I also cleaned the contacts. I assume it must be more than a potential fob issue because the horn also quit at exactly the same time. It doesn't work at all, nor does the key fob functions.

REWARD EXCELLENCE!

Add to tway's Reputation
Rate the quality of this post and help tway reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tway is offline   Reply With Quote
Old 02-24-2011, 11:19 PM   #6
tway
Junior Member
tway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the rough
 
Join Date: Jun 2009
Location: nova scotia
Posts: 15

2002 L-Series 3.0L Sedan
Default Re: horn not working, key fob not working

I did a little research in the manufacturers manuals i have and i think i may have an issue with my ignition sw. Looks like the car thinks the key is in the ignition thus why I'm getting the chimes and the key fob isn't working. Could also affect the horn as it says the BCM controls horn operation for the key less entry. Anyway plan to do some metering at the BCM tomorrow to see if the key in ignition signal (gnd) is set.

REWARD EXCELLENCE!

Add to tway's Reputation
Rate the quality of this post and help tway reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tway is offline   Reply With Quote
Old 03-02-2011, 08:26 PM   #7
tway
Junior Member
tway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the roughtway is a jewel in the rough
 
Join Date: Jun 2009
Location: nova scotia
Posts: 15

2002 L-Series 3.0L Sedan
Default Re: horn not working, key fob not working

confirmed the problem was the key in ignition switch. Actually the ignition cylinder was the culprit as the piece that actuates this part of the ignition switch was jammed up causing it to stay engaged. I ordered a new ignition/key cylinder.
The horn was a seperate issue. Had power at the horn when you pressed the horn switch but no sound. all i did was dig the silicon out of the contact points on the outside of the horn, was three spots. I twisted the bolt heads and removed one screw, cleaned and reinstalled and the horn started working.
my power mirror switch had stopped working so I took that out as well and cleaned contacts with alcohol and got that working again as well.
happy camper by the end of the morning.

REWARD EXCELLENCE!

Add to tway's Reputation
Rate the quality of this post and help tway reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tway is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi....Q on a non-working horn DrEvil S-Series General 10 11-29-2010 05:14 PM
Horn not working tom_94305 S-Series Tech 3 08-27-2010 02:05 PM
'02 VUE Horn NOT Working dpware Vue General 7 04-19-2010 02:27 PM
Horn not working hlp plz! Salsa88 S-Series Tech 12 12-28-2007 12:38 AM
Horn not working gunny S-Series Tech 10 08-28-2002 01:52 PM


All times are GMT -4. The time now is 11:03 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.