SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-19-2019, 02:36 PM   #1
nohairtopullout
New Member
nohairtopullout is on a distinguished road
 
Join Date: Jan 2010
Location: GA
Posts: 6

2001 L-Series 2.2L Wagon
2001 SC2
Default BCM problem I think - need advice

Hello all, here's the story. 2001 LW 200 with approx 170,000 miles. Battery about 1.5 years old. Battery light came on (was noticed) around 5 miles from home. Had to work the next day so it was driven about 10 miles to work and a few miles out to lunch where the car died. (This was not me. My son-in-law). Would not shift out of Park, airbag light on, ABS light on, Service light on (wrench). Manually lifted shift interlock so got it in neutral and car was towed home. I changed the alternator (battery was disconnected during this time) and jumped battery and battery charged and new (rebuilt) alternator was putting out 14.5V. But the airbag light was still on and it still wouldn't shift out of park, also the doors would not lock or unlock with the fob or the door lock button. A few days later everything cleared up except the airbag light. Today I noticed the odometer had rolled back to zero. It only had the miles he drove to get here. Tried the 30 minute reset procedure with no help. Any ideas? Thanks, you guys have saved my skin numerous times in the past.

REWARD EXCELLENCE!

Add to nohairtopullout's Reputation
Rate the quality of this post and help nohairtopullout reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
nohairtopullout is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight problem advice please pcpthepman Support Forum for Canadian Saturn Owners 5 08-28-2013 01:47 PM
Need advice on a very strange problem jsacks Vue General 15 12-17-2010 12:37 PM
Cooling Fan Problem - Need Advice d4rkf1ber S-Series Tech 13 11-17-2006 12:32 PM
Need advice on trans problem, Help please! JCSC2 S-Series Tech 17 11-20-2005 09:44 PM
Valve problem need advice azrun S-Series Tech 4 01-21-2003 04:51 PM


All times are GMT -4. The time now is 02:52 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.