SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-29-2010, 08:02 PM   #1
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Car stalls while idling once it's warm, help!

Some background stuff: car is a 1996 Saturn SL2 1.9L (automatic) with only 92,000 miles on it. I just had the spark plugs, wires, fuel filter, and oil changed. Fluids were topped off, air filter is clean, and I regularly (about every other month) run the strong STP fuel injector/carburetor cleaner through.

I apologize for writing a book here, but if you can help me I'd really appreciate it.

For the past few weeks when I've been driving my car its stalled at stoplights where I have to sit idling for about 45 seconds to a minute or so. It only tends to do this once per day, mainly when the car is at its warmest. It idles at around 700-750 RPM when in drive (or neutral) and stopped. RPM's slowly creep down to around 700 and then it drops below 400-500 and will either stall from here or shoot up to 1300ish and level out (then stall 10 seconds later if I'm not giving it some gas by then). It never stalls when I'm on the gas. No codes showing for fuel pump or injectors and checking the fuel pressure showed it's right where it needs to be, and the voltages from the throttle position sensor are reading right in their correct range too.

As a way to keep from stalling I've been putting it in neutral and giving a little bit of gas every couple seconds and that seems to work fine, but this needs fixed! Exact error codes I'm getting are P0341 (camshaft sensor), P0404 (EGR), and P0405 (EGR).

Now more info: camshaft sensor error has been there for at least a couple years, I've been told s-series don't have one and that it tells the position of the camshaft by how the car fires in it's 4th piston. Someone who said they'd worked on Saturns for 15 years says this is the timing belt throwing this error (which is why my car sometimes won't start, then takes 10 minutes to start after failing, but that's an entirely different problem, I hope. The car has done this for at least a couple years, if not more).

That just leaves the 2 EGR errors. We removed it, cleaned it, and didn't think it was very dirty, put it back on, and now my Service Engine Soon light is always on, as opposed to the random on/off it used to do. Nothing we do has helped, could the timing belt be the problem with the camshaft, and have worn more and caused this now? Or maybe it's only the EGR, or something is messing up the EGR itself. If you have ideas just throw 'em out there.

One more thing, while testing the throttle position sensor the engine was loping at full throttle, even though it was giving the proper voltage, it doesn't lope while idle though. Too many problems!

Thanks,
Josh

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-29-2010, 08:39 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

Replace (if original) the coolant sensor and thermostat (with a 195F one) and thoroughly clean the ignition module and both coils of any corrosion. This should take care of a faulty coolant sensor running the engine rich. If the stalling continues, move on to trying the egr valve block off.

Use either a soda can gasket or two coins to block off the egr valve ports completely; cleaning doesn't prove anything if the pintle valve erratically sticks and still allows exhaust gases into the intake manifold at the wrong time, like idling. Now drive and if engine power returns, either clean the egr valve some more or replace it.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 03-29-2010, 08:58 PM   #3
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Good idea with the coolant, I forgot to mention that I've had that high coolant temp/low coolant/low automatic trans-axle fluid light on and off lately even though the fluid and coolant are both filled to full. I'll get back to my mechanic and try this right away, thanks!

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 03-30-2010, 11:37 AM   #4
DonP
Master Member
DonP will become famous soon enoughDonP will become famous soon enough
 
Join Date: Jun 2006
Location: VA
Posts: 3,582
 

1995 SL2
Default Re: Car stalls while idling once it's warm, help!

A bad or failing ECTS can cause all sorts of driveability issues. Once you have confirmed that the ECTS (replae if the old type) and the connctor are in good condition you can move on to other diagnostics.

REWARD EXCELLENCE!

Add to DonP's Reputation
Rate the quality of this post and help DonP reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DonP is offline   Reply With Quote
Old 04-02-2010, 11:10 PM   #5
adventureoflink
Master Member
adventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura about
 
adventureoflink's Avatar
 
Join Date: Apr 2009
Location: 255.255.255.255
Posts: 6,853

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Quote:
Originally Posted by joshjames023 View Post
Now more info: camshaft sensor error has been there for at least a couple years, I've been told s-series don't have one and that it tells the position of the camshaft by how the car fires in it's 4th piston. Someone who said they'd worked on Saturns for 15 years says this is the timing belt throwing this error (which is why my car sometimes won't start, then takes 10 minutes to start after failing, but that's an entirely different problem, I hope. The car has done this for at least a couple years, if not more).
Buddy, I'd RUN and NOT walk from that mechanic, and here's why:

1) Our Saturns use Timing CHAINS and NOT belts (thank goodness ). you'd think he'd learn this in the whole 15 years he's been "working on" them.
and 2) did you ever change your spark plugs and wires (using NGK copper/decent mid-price wire set)? generally when P0341 hits, it's time for a plug/wire replacement.

Having said that, you get a flashing temp light with the reservior full? then it's time to drain the coolant, unbolt the reservior, and clean it out. Richpin has a video on it.

http://www.youtube.com/user/richpin06a

...
97 SL2
DOB: 3/19/97
Date Obtained: 5/30/07
Status: Alive, 1/2 exhaust

2004 Merc G.Marquis GS
DOB: 2/4/04
Date Obtained: 7/6/12
Status: Alive, no heat

REWARD EXCELLENCE!

Add to adventureoflink's Reputation
Rate the quality of this post and help adventureoflink reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
adventureoflink is offline   Reply With Quote
Old 04-03-2010, 11:08 AM   #6
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Haha ok, well he said chain, I just said belt for some reason, that was just a guy on yahoo answers before I posted the question on here. But yeah I replaced the plugs and wires with a decent set and made sure they're all plugged in the appropriate spot so that's good for now. The temp light isn't the only problem though, I think the first guy may have a point with the thermostat and coolant temp sensor because I reset the codes yesterday and on my way to work (10 miles just about) the service engine soon light stayed off, but the coolant temp reached half. On the way home the light came back on, but the temp barely hit above a quarter. To me that sounds like it's reading the temp as too high and then flooding in too much coolant like he said. I'm willing to try anything to fix this at this point though so thanks for the link, that guy has a lot of useful videos!

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 04-03-2010, 11:45 AM   #7
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

Being new around here until more familiar with the wealth of information, please reply whether or not the ects and thermostat were replaced as these are the two most outstanding issues with older S-series engines having these original parts that fail/wear out. Speculating does nothing and these two parts are the least costly items to replace. Both will improve starting performance and overal engine running immediately. The next would be a general cleaning of the throttle body (if it hasn't been done) to degrease any sticking tendencies from built up crud.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 04-03-2010, 02:12 PM   #8
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Alright well the thermostat and coolant temp sensor were just replaced today. We drove around for a while and no codes have come up yet and the idling is fine, I will update you on whether or not it starts acting up again. One thing though, after we had everything back in order and started the car we let it sit in park idling for about 15 minutes and it just shut off on its own, but started right back up. Can I ask what exactly is the ECTS, and where can I find it on the car? I didn't see it listed for parts when I searched for it.

Thanks guys,
Josh

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 04-03-2010, 03:49 PM   #9
macbox
Senior Member
macbox will become famous soon enough
 
macbox's Avatar
 
Join Date: Jul 2006
Location: Minneapolis, MN
Posts: 1,133
 

1995 SC2
1997 SC2
Default Re: Car stalls while idling once it's warm, help!

Quote:
Originally Posted by joshjames023 View Post
Can I ask what exactly is the ECTS, and where can I find it on the car?
The coolant temp sensor and the ECTS are the same thing, ECTS means Engine Coolant Temperature Sensor. Make sure you use _Brass_ type when replacing the old one.

...
#4, 1995 SC2m, 163K, 400 Miles per quart. Garage queen. Currently in 1000 pieces for a rebuild.
#5, 1998 SW2m, rebuilt at 126K, Totaled at 205K miles.
#7 1995 SC2, 121K, daily driver.

REWARD EXCELLENCE!

Add to macbox's Reputation
Rate the quality of this post and help macbox reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
macbox is offline   Reply With Quote
Old 04-06-2010, 01:12 AM   #10
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Ah ok thanks, we did replace that with the brass type so that's fine.
Here's the rundown of what I've got so far:
- Throttle Position Sensor voltages in right range
- Fuel pressure in right range
Replaced:
- fuel filter
- spark plugs
- wires
- ects (with brass one)
- thermostat (195 degree one)

The car is now running smoother and the idle is normally right around 700 RPM's which is where it runs when the codes are clear. I've still been revving a little in neutral at lights just to make sure I don't stall in heavy traffic, but every time I get where I'm going I sit in drive on the break for a while to see if it'll quit on me. So far in about 5 times doing that it has stalled once. The only thing different about that time is that I came into my parking spot pretty fast and braked hard instead of slow and smooth, it stalled in only a few seconds with no warning. Other than that it's better. The light came back on and I haven't checked codes, but my money is still on the EGR. Next things I'll do are cleaning the throttle body and drain the coolant, clean the reservoir, and put fresh coolant in.

While driving today the car surged while I was decelerating, I think that was another sign of an EGR problem in the Haynes manual along with the rough idling and stalling. You guys think it's probably coming down to me buying a new EGR?

Thanks,
Josh

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 04-06-2010, 01:19 AM   #11
adventureoflink
Master Member
adventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura about
 
adventureoflink's Avatar
 
Join Date: Apr 2009
Location: 255.255.255.255
Posts: 6,853

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Quote:
Originally Posted by joshjames023 View Post
While driving today the car surged while I was decelerating, I think that was another sign of an EGR problem in the Haynes manual along with the rough idling and stalling. You guys think it's probably coming down to me buying a new EGR?
Either that or clean it out, yes. Just be sure to beforehand warm up the engine with the EGR still on, shut down the engine, remove EGR, then run engine for 5 seconds so it can blow out any remaining carbon out of the exhaust, then clean the current EGR (use carb cleaner) or install new one.

...
97 SL2
DOB: 3/19/97
Date Obtained: 5/30/07
Status: Alive, 1/2 exhaust

2004 Merc G.Marquis GS
DOB: 2/4/04
Date Obtained: 7/6/12
Status: Alive, no heat

REWARD EXCELLENCE!

Add to adventureoflink's Reputation
Rate the quality of this post and help adventureoflink reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
adventureoflink is offline   Reply With Quote
Old 04-06-2010, 10:25 AM   #12
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

Surging isn't caused by the egr valve but may be from a dirty throttle body and the idle air control valve within. A general cleaning just may clear this up. If the egr valve were to cause problems some of them would be; uneven idling, hesitation, stumbling, and stalling tendencies. A true test of the egr valve causing problems would be to block off the ports underneath it - cleaning it doesn't eliminate a slightly stiff valve that won't seat into home position.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 04-06-2010, 08:57 PM   #13
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Went to auto zone today and got codes pulled, it's that P0404 EGR again. So I just cleaned the throttle body, idle air control valve, and the EGR (second time cleaning the EGR, a lot better cleaning this time) and took it for a spin around my allotment after clearing the codes and when I sat in drive on the brake the RPM's would dip and it would almost shut off, but not quite, it did this a couple times and then I shifted from reverse and back to drive and that got it to stall.

First of all, is it possible the sensor in the coolant reservoir is telling the computer to shut the car down because low coolant = overheating? When I sit in park or idle the temp gage goes up pretty quickly, 3-4 minutes takes it up a quarter or so (I am slightly low on coolant at the moment, but not that much, that light was on before I was low so I still need to clean the reservoir). So basically would cleaning that out, flushing the coolant, and putting new in work towards fixing this?

Second, is it possible I just need to drive the car for a few hours as is and it'll magically work again? That would be nice!

And third, if those can't be the case then here's all that's been done:

Checked:
- Throttle Position Sensor voltages in right range
- Fuel pressure in right range
Cleaned:
- Throttle Body
- Idle Air Control Valve
- EGR
Replaced:
- fuel filter
- spark plugs
- wires
- ects (with brass one)
- thermostat (195 degree one)

Anything else to test or is it time for a new EGR? I want to do the soda can gasket test...but I'm kind of afraid to, I read on these forums somewhere that a guy made one and it shattered somehow and now there's little aluminum shrapnel all inside of his engine.

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 04-06-2010, 09:26 PM   #14
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

The coolant reservoir sensor does nothing but turn on the indicator. It will not kill the engine. The egr valve most likely is killing the engine by allowing the pintle valve to stay open at idle and stalling the engine.

This new old wives tale of aluminum soda can shrapnel is just that, a new tale. Read some more posts of successfully finding egr valve faults using the blocking technique. If you're concerned about melting aluminum, use steel sheet metal or two coins.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 04-09-2010, 11:35 AM   #15
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

CRAP!

It won't let me post URL's and I can't figure out how to post pictures so just remove the three spaces after http: to see it

http: //s295.photobucket.com/albums/mm129/joshjames023/?action=view&current=0409001119.jpg

That little piece won't hurt my engine will it?!

Hmm...anyway while doing that test, which I'm never doing again, my car seemed to accelerate better, smoother transitioning between gears, just ran really smooth. No stalling, until I pulled into my spot at home where it almost stalled, but at that point there was a hole or that hole already formed. I think I'll go order in a new EGR either today or tomorrow, sound like a plan? Also, is it better to get a normal gasket or one of the ones that has a filter over the one hole? And when I install it does it just sit on there or have some adhesive, and should the old one just peel off then?

Thanks,
Josh

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 04-09-2010, 12:04 PM   #16
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

For anyone who doesn't click the link in my above post it is a small piece that came out of the soda can gasket on the larger hole side. If I'm correct that's the exhaust side and I shouldn't have to worry about it...

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 04-09-2010, 02:11 PM   #17
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

For some reason, I can't seem to decrypt anything that's posted no matter how much I try or stand on my head.

If you tried the soda can, its most likely the aluminum melted and balled up. Exhaust heat will melt aluminum as thin as soda can gauge. At least you were able to see the difference when the ports were blocked off.

If you can buy the gasket with a screen, use it as some swear it helps. Nothing but gasket material. No adhesive, glue, RTV, whatever.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 04-12-2010, 08:37 PM   #18
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

New EGR has been on since Saturday morning and I've put over 100 miles on the car and so far no codes being thrown and the car is running really smooth. But, today when I got off the highway and was waiting at the light on the ramp my car shut off with no warning. I really don't know at this point, MAP sensor maybe? I know how to check that from Richpin's videos. The idle is pretty smooth, right around 700 consistently. The car had a couple "hiccups" over the course of the 100+ miles where it felt like it was stalling, but didn't.

My other problem with the car is one that it's had for as long as I know of, where it sometimes won't start and if it fails to start it takes about 10 minutes of sitting until it will start properly. Every time before I start the car I wait until the pump runs and the fuel gauge rises to decrease the chance of a failure. Mostly it fails when it hasn't been sitting off for at least10 minutes, like if I shut it off, run into Circle K for a drink, then come back out and try to start it. When it won't start it tries to turn over as long as I hold the key, but never catches, and trying to give a little gas doesn't coax it at all. If the car didn't do this the stalling wouldn't be as much of a problem, but I've been stuck in rush hour traffic around the mall before and it's not fun.

Thanks,
Josh

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Old 04-12-2010, 10:12 PM   #19
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

There may be excess carbon deposits that can loosen up, break off and lodge in the new egr valve, propping it open just enough to stall the engine. The recommended cure would be to remove the egr valve and start the engine; the open exhaust hole and open intake hole will peg the rpm's at the limit, 4k rpm. Just a few seconds of this should blow out any carbon deposits. Shut the engine down and replace the egr valve. Whether this helps or not depends on how much deposits accumulated and if the high revving helped blow out any build up that can break off and prop open the egr valve.

Has the throttle body been cleaned?

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 04-12-2010, 10:19 PM   #20
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

I did start the car up with the old EGR off before I got the new one, for about 5 seconds or so, but the car wasn't that warm, adventureoflink said to have it warm but it was already apart so I did it anyway. That was when I cleaned the throttle body and the idle air control valve. I will try taking the EGR off and starting it again the next chance I get (I'll make sure the car is warm this time).

REWARD EXCELLENCE!

Add to joshjames023's Reputation
Rate the quality of this post and help joshjames023 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshjames023 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stalls when idling warm mannsjp S-Series Tech 3 03-28-2010 07:52 PM
AC blows warm when idling turbobuick33 S-Series Tech 16 07-31-2008 08:44 PM
93 SL2 AC works but warm when idling 2003MercMaraude S-Series Tech 11 05-28-2008 03:54 PM
saturn stalls after it gets warm? creepyrat S-Series General 26 05-31-2006 06:25 PM
93 sw2- stalls at stop once warm ndsaturn S-Series General 2 09-14-2004 03:45 AM


All times are GMT -4. The time now is 03:02 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.