SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-16-2016, 04:21 AM   #21
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

Being unfamiliar with EFI systems and differentiating between a fuel pump operating at ignition ON time (engine off) or during starting can only be checked one way; as soon as ignition is turned on and pressure is seen, relieve fuel pressure by unscrewing the pressure gauge fitting slowly and have a rag soak up fuel bleeding off until pressure drops to zero then screw on the fitting for starting pressure tests. You may have to remove the gauge fitting and depress the valve stem to relieve pressure since the schrader valve is designed to self seal as soon as a fitting is unscrewed (safety design). Unless pressure is relieved before testing for pump operation during starting, no one can tell the difference between residual pressures or when the pump runs during starting. Relieving pressure while leaving ignition ON sets up the second pump test without cycling ignition off. Simply relieving pressure while leaving ignition on allows starting to test for pump operation and observing pressures build up again.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-16-2016, 12:20 PM   #22
billr
Master Member
billr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to all
 
Join Date: Jul 2013
Posts: 5,013
Default Re: 02 SL2 Injectors not pulsing

I dissent... I don't care what the pressure is, or if the pump is even in the car. I just want to know if the PCM is detecting a proper CKP signal and commanding the pump back on; to eliminate the CKP circuit as a problem. That can be done by just checking voltage at the pump, or pump relay coil. Or listening for the pump. If you hear it start running again, it has been "commanded on"!

REWARD EXCELLENCE!

Add to billr's Reputation
Rate the quality of this post and help billr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billr is offline   Reply With Quote
Old 07-16-2016, 01:25 PM   #23
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

Maybe this can help clarify how fuel pumps operate. The pcm commands a 12v signal to (pin 87?) on the pump relay coil with coil already grounded. The pump command signal is the same signal whether with ignition ON or during starting/engine running. When starting or running, the crank sensor supplies timing signals 'waking up' the pcm to begin EFI management; turn on fuel pump, provide spark and pulse injectors.
Attached Images
File Type: jpg fuel pump.jpg (212.5 KB, 6 views)

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-17-2016, 09:47 PM   #24
RB56
Junior Member
RB56 has a spectacular aura aboutRB56 has a spectacular aura aboutRB56 has a spectacular aura about
 
Join Date: Jun 2016
Posts: 28
Default Re: 02 SL2 Injectors not pulsing

Test results:
1. Fuel pump doesn't come back on after initial 2 second pressure up.
To eliminate wiring as possibility:
2. Continuity confirmed between CKP Sensor and PCM.
3. CKP Sensor measures 930 ohms resistance at PCM connection.
4. Continuity confirmed between injectors and PCM.
5. 12v Confirmed at injectors when key is on.
6. 12v Confirmed at ignition module when key is on.
7. PCM ground confirmed good.

One other thing... the dash Service Engine light stays on though my OBD II shows no codes.

Is there any sensor or condition that could exist that would signal the PCM to not let the car run by not signaling the injectors or the ignition module?

REWARD EXCELLENCE!

Add to RB56's Reputation
Rate the quality of this post and help RB56 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RB56 is offline   Reply With Quote
Old 07-17-2016, 10:16 PM   #25
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

Did you turn the ignition key to START? The pump will not run again until starting attempts are made (trying to startup).

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-18-2016, 08:41 AM   #26
RB56
Junior Member
RB56 has a spectacular aura aboutRB56 has a spectacular aura aboutRB56 has a spectacular aura about
 
Join Date: Jun 2016
Posts: 28
Default Re: 02 SL2 Injectors not pulsing

Yes, I tried it a couple of ways:
1. Turned Key to "on" and waited for volts to FP to drop off.
2. Then tried to start...got no additional volts to FP.

Next:
1. Turned key to "on" and waited.
2. Bled pressure off at Schrader valve.
3. Then tried to start...got no additional volts to the FP.

Finally:
1. Turned key to "on" and waited.
2. Bled pressure off at Schrader valve, and kept it open.
3. Tried to start...still got no additional volts to the FP.

REWARD EXCELLENCE!

Add to RB56's Reputation
Rate the quality of this post and help RB56 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RB56 is offline   Reply With Quote
Old 07-18-2016, 08:43 AM   #27
RB56
Junior Member
RB56 has a spectacular aura aboutRB56 has a spectacular aura aboutRB56 has a spectacular aura about
 
Join Date: Jun 2016
Posts: 28
Default Re: 02 SL2 Injectors not pulsing

Also,
Did you see my question about:

Is there any sensor or condition that could exist that would signal the PCM to not let the car run by not signaling the injectors or the ignition module?

REWARD EXCELLENCE!

Add to RB56's Reputation
Rate the quality of this post and help RB56 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RB56 is offline   Reply With Quote
Old 07-18-2016, 10:06 AM   #28
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

After you turned on ignition and saw fuel pressure, bled pressure off while leaving ignition ON, did you try starting see if fuel pressure comes back up? The same signal that turns on pump operation at ignition ON time is used again during starting and running.

Passlock, when enabled and activated (flashing security light), disables injector operation. Service manuals generalize in this area by stating something along the lines of "Passlock security determines from sensors to send or not send a fuel password." Whether disabling injector operation or fuel pump, Passlock disables the engine from running. The only indicator to tell anyone is the flashing security light during starting.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-18-2016, 03:25 PM   #29
RB56
Junior Member
RB56 has a spectacular aura aboutRB56 has a spectacular aura aboutRB56 has a spectacular aura about
 
Join Date: Jun 2016
Posts: 28
Default Re: 02 SL2 Injectors not pulsing

It appears that unless the key is turned off and back on, the rail doesn't pressure up again.

The security light comes on with all the other dash lights when the key is turned on, but goes out in a few seconds with no flashing at all.


One more piece of info just in case it means something to someone else:
A few days before she quit running, I changed the headlight wiring harness. There as a 240 milliamp battery drain on my headlamp circuit with everything turned off. When I couldn't locate the problem, I got another from the junk yard. After changing it, no immediate problem starting or running.

REWARD EXCELLENCE!

Add to RB56's Reputation
Rate the quality of this post and help RB56 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RB56 is offline   Reply With Quote
Old 07-18-2016, 05:25 PM   #30
billr
Master Member
billr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to all
 
Join Date: Jul 2013
Posts: 5,013
Default Re: 02 SL2 Injectors not pulsing

I simply don't know how the security system disables fueling, but the lack of all three functions dependent on the CKP circuit (spark, injectors, and pump) is a pretty strong hint that this is still a CKP circuit problem. You have replaced the sensor, but there is still wiring and the ICM that could be bad. Do you have an electrical multimeter?

REWARD EXCELLENCE!

Add to billr's Reputation
Rate the quality of this post and help billr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billr is offline   Reply With Quote
Old 07-18-2016, 06:20 PM   #31
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

A partial reprint from service manuals;

The CKP sensor is located in the back of the engine block near the starter motor. It produces an AC voltage of different amplitude, as high as 125 volts, and frequency depending on the velocity of the crankshaft. The crankshaft has 7 machined notches, 6 of which are spaced 60 degrees apart. The remaining notch is 10 degrees before the #4 cylinder top dead center (TDC) notch. The extra notch is used by the PCM to determine the position of the #4 cylinder and is necessary to synchronize engine position. The CKP sensor is used for fuel delivery, spark timing, misfire diagnostics and tachometer display.

The fuel injection system on both SOHC and DOHC engines utilize sequential fuel injection. The PCM independently controls each fuel injector. The PCM grounds each fuel injector circuit for a certain length of time based on engine operating parameters. The fuel control system is designed to maintain a 14.7:1 air/fuel ratio under all engine running conditions except power enrichment, heavy acceleration/heavy engine load, and deceleration modes. The PCM can turn fuel injectors OFF during deceleration, misfire diagnostics and traction control.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-18-2016, 06:24 PM   #32
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

RB56, in a nutshell, if you do not see spark and injectors aren't operating (no fuel smell or wet spark plugs), problems are narrowed down to the crank sensor, wiring between crank sensor and pcm.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-18-2016, 08:14 PM   #33
RB56
Junior Member
RB56 has a spectacular aura aboutRB56 has a spectacular aura aboutRB56 has a spectacular aura about
 
Join Date: Jun 2016
Posts: 28
Default Re: 02 SL2 Injectors not pulsing

As I said, I just verified continuity between the PCM connector and the CKP sensor, both wires.

I don't have an oscilloscope, but my multimeter shows voltage changes from the CKP Sensor when turning the engine over.

Specifically what else do you suggest I test.

REWARD EXCELLENCE!

Add to RB56's Reputation
Rate the quality of this post and help RB56 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RB56 is offline   Reply With Quote
Old 07-18-2016, 08:39 PM   #34
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

I honestly don't know what else to check (sight unseen). The crank sensor is the only generator of electronic pulses, the electronic heart beat of the pcm in to operate the EFI system (fuel pump. injectors and spark). NO fuel injectors spitting fuel into each cylinder (wet plugs), no fuel pressure during engine starting and no spark simply means failure of a crank sensor, wiring between crank sensor and pcm or pcm failure. Pcm failures are rare but do occur as the S-series gets older for no rhyme or reason. All other troubleshooting is performed as the majority of problems are associated with sensors feeding signals to the pcm and the pcm failing to operate correctly without every sensor outputting needed signals. The fact that Saturn died as a company six years ago leaves an aging fleet of cars and suvs with more and more parts available, cheaply. Pcm's are one of them, used, from junk yards, ebay and craigslist.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-19-2016, 09:15 AM   #35
RB56
Junior Member
RB56 has a spectacular aura aboutRB56 has a spectacular aura aboutRB56 has a spectacular aura about
 
Join Date: Jun 2016
Posts: 28
Default Re: 02 SL2 Injectors not pulsing

I guess I'm down to the PCM.

Will I be able to just swap PCMs or is there vehicle specific programming that must be done?

REWARD EXCELLENCE!

Add to RB56's Reputation
Rate the quality of this post and help RB56 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RB56 is offline   Reply With Quote
Old 07-19-2016, 09:52 AM   #36
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,902
 

2003 L-Series 3.0L Sedan
Default Re: 02 SL2 Injectors not pulsing

It's not plug n' play. GM's Passlock security program is embedded in the pcm and bcm to work together. All you need to do is disconnect battery negative, wait for a minute, replace the pcm, reconnect battery negative and perform a relearn procedure taking 30 minutes so the pcm and bcm marry. Search for the procedures within this forum. Dealers using equipment only need ten minutes. Without GM equipment, thirty minutes.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-19-2016, 11:11 AM   #37
billr
Master Member
billr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to all
 
Join Date: Jul 2013
Posts: 5,013
Default Re: 02 SL2 Injectors not pulsing

I don't have schematics for the gen3, so have to ask:

Does the CKP in that year not feed into an ICM for decoding, like the gen1 and gen2?

When you check for output from the CKP sensor, are you leaving the harness fully connected? And, are you checking for that signal where the harness wires end (PCM or ICM)?

REWARD EXCELLENCE!

Add to billr's Reputation
Rate the quality of this post and help billr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billr is offline   Reply With Quote
Old 07-19-2016, 12:44 PM   #38
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,634
 

1998 SC2
Default Re: 02 SL2 Injectors not pulsing

CKP feeds directly into ICM in GEN-1 only. Gen 2 and 3 are to the ECU. To initiate repeated prime cycles requires a minimum key off time of >20 seconds. If you have a fuel pump run while cranking then the PCM is seeing the CKP pulse train. This is the easy way to check for CKP pulses and you test a CKP by checking resistance, 900-1100ohms is good. On the gen 3 DOHC car there is a 2 pin connector in the CKP wiring close to the firewall so actual testing is rather easy by disconnecting at this connector and checking resistance.

Last edited by OldNuc; 07-19-2016 at 12:54 PM..

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 07-19-2016, 01:03 PM   #39
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,634
 

1998 SC2
Default Re: 02 SL2 Injectors not pulsing

Match the wire colors to find this connector, shown lower right corner of this drawing.
Attached Images
File Type: jpg Screen-2016-07-19_11-59-27.jpg (70.9 KB, 4 views)

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 07-19-2016, 05:05 PM   #40
billr
Master Member
billr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to allbillr is a name known to all
 
Join Date: Jul 2013
Posts: 5,013
Default Re: 02 SL2 Injectors not pulsing

Yep, my mistake; my schematic does show the gen2 CKP connecting directly to the PCM. I still feel that the CKP signal should be checked at the PCM connector, and with the harness fully connected.

REWARD EXCELLENCE!

Add to billr's Reputation
Rate the quality of this post and help billr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billr is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
97 SL1 Brake Pulsing xfriendsonfirex S-Series Tech 7 01-06-2014 12:44 AM
Pulsing Lights hummrH2o L-Series General 18 12-26-2012 06:36 PM
Pulsing lights marko16 S-Series Tech 4 07-18-2012 10:32 PM
fuel injectors not pulsing dboman521 S-Series Tech 9 11-18-2011 08:57 PM
P0340: Do 01 injectors have same voltage as 97 injectors for L24? c5f8 S-Series Tech 0 10-02-2005 07:16 PM


All times are GMT -4. The time now is 11:56 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.