SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 05-07-2014, 08:57 PM   #1
WVUDave
Member
WVUDave is on a distinguished road
 
Join Date: Jun 2013
Posts: 77

2002 SL1
Default Poor Gas Mileage/Running Rich?

I do almost exclusively city driving, and I'm only getting about 225 miles before the low fuel light turns on. I'm not certain, but I do believe I used to do much better. I also have a fuel gauge that doesn't always work. In addition, service engine soon light is on for code P0137. Should I be concerned?

No exhaust leak as far as I can tell.
Engine also intermittently stutters (like a hiccup) when idling, except when I have the air conditioning on. The hiccup feels similar to when an engine stalls, but is only for a second and resumes to normal.
Could it be the carburetor?

I am open to any ideas and suggestions. Thank you kindly.

REWARD EXCELLENCE!

Add to WVUDave's Reputation
Rate the quality of this post and help WVUDave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
WVUDave is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-07-2014, 09:11 PM   #2
SaturnAndBeyond
Member
SaturnAndBeyond is on a distinguished road
 
SaturnAndBeyond's Avatar
 
Join Date: Jan 2014
Location: Tucson, AZ
Posts: 53
 

1992 SL2
Default Re: Poor Gas Mileage/Running Rich?

There's not really a "Carb," per se: All air/fuel ratios are controlled by the computer. If you think the engine might be running rich, I'd suggest replacing the O2 sensor. I'm not sure where that might be on your particular car, but there are probably a few people on here who know.

...
1992 Saturn SL1 "Sally"(Scrapped, 10Jul16)
1992 Saturn SL2 "Baby Blue"
2000 Subaru Forester S "Eileen"
2010 Subaru Impreza WRX "Sophie"
2014 Suzuki Boulevard M50 "Suzie"

REWARD EXCELLENCE!

Add to SaturnAndBeyond's Reputation
Rate the quality of this post and help SaturnAndBeyond reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SaturnAndBeyond is offline   Reply With Quote
Old 05-08-2014, 01:50 PM   #3
WVUDave
Member
WVUDave is on a distinguished road
 
Join Date: Jun 2013
Posts: 77

2002 SL1
Default Re: Poor Gas Mileage/Running Rich?

Any other suggestions besides o2 sensor?

REWARD EXCELLENCE!

Add to WVUDave's Reputation
Rate the quality of this post and help WVUDave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
WVUDave is offline   Reply With Quote
Old 05-08-2014, 02:03 PM   #4
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,624
 

1998 SC2
Default Re: Poor Gas Mileage/Running Rich?

Clean the PCM and sensor grounds on the left rear corner of the block just under the #4 intake runner. They are 4 wires bolted to the block, don't drop the bolt.

Check the exhaust for any leaks between the head and CAT inlet.

Exhaust leak check.
--Locate a low pressure high volume air source, reversible vacuum cleaner, large fan, leaf blower or what ever you can find.
--Loosely couple to cold exhaust at the tail pipe, or direct fan at tail pipe.
--Spray every inch of the exhaust between the head and CAT inlet with a mixture of 2 or 3 drops of dish soap and water in a spray bottle.
--Pay close attention to the lower flange, lower support clamp, and flex connector.
--The flex connector is under the protective braid so it requires quite a bit of solution to show any leaks.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 05-08-2014, 02:06 PM   #5
GeekOnTheHill
Member
GeekOnTheHill is a jewel in the roughGeekOnTheHill is a jewel in the roughGeekOnTheHill is a jewel in the roughGeekOnTheHill is a jewel in the rough
 
GeekOnTheHill's Avatar
 
Join Date: Aug 2013
Location: Rural New York
Posts: 333
Default Re: Poor Gas Mileage/Running Rich?

Well, P0137 does in fact relate to the O2 sensor, so that's the logical place to start.

In addition, I'd start looking at simple possibilities like:

Dirty air filter
Worn or fouled spark Plugs
Old spark Plug Wires
Dirty throttle Body

You know. Those sorts of things. Also, obtaining an actual MPG reading wouldn't be a bad starting point.

-Richard

REWARD EXCELLENCE!

Add to GeekOnTheHill's Reputation
Rate the quality of this post and help GeekOnTheHill reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
GeekOnTheHill is offline   Reply With Quote
Old 05-08-2014, 03:12 PM   #6
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,624
 

1998 SC2
Default Re: Poor Gas Mileage/Running Rich?

It is the rear sensor though so I does nothing to mixture. Low voltage is usually dirty grounds.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 05-08-2014, 04:48 PM   #7
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,889
 

2003 L-Series 3.0L Sedan
Default Re: Poor Gas Mileage/Running Rich?

Mileage, maintenance done, parts replaced? Worn, damaged catalytic converter ever considered? While there are as many suggestions as members, troubleshooting some problems requires some careful steps to narrow a mystery problem, starting with simple wiring checks for looseness, corrosion, abrasion (chafing) on long wire lengths not tied out of the way, etc.. Since this error code is for the rear O2 sensor, this can mean either the sensor or the catcon. At worst, a problem further up or downstream is causing the error code - tied to poor fuel economy.

Last edited by fdryer; 05-08-2014 at 04:55 PM..

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 05-08-2014, 10:55 PM   #8
WVUDave
Member
WVUDave is on a distinguished road
 
Join Date: Jun 2013
Posts: 77

2002 SL1
Default Re: Poor Gas Mileage/Running Rich?

I'm getting 25 MPG.
New wires, plugs, cleaned throttle body.

REWARD EXCELLENCE!

Add to WVUDave's Reputation
Rate the quality of this post and help WVUDave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
WVUDave is offline   Reply With Quote
Old 05-08-2014, 10:58 PM   #9
WVUDave
Member
WVUDave is on a distinguished road
 
Join Date: Jun 2013
Posts: 77

2002 SL1
Default Re: Poor Gas Mileage/Running Rich?

Haven't found leaks.
Thinking my converter may be clogged/bad.

REWARD EXCELLENCE!

Add to WVUDave's Reputation
Rate the quality of this post and help WVUDave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
WVUDave is offline   Reply With Quote
Old 05-08-2014, 11:01 PM   #10
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,624
 

1998 SC2
Default Re: Poor Gas Mileage/Running Rich?

Clean the sensor grounds.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 05-09-2014, 07:12 AM   #11
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,889
 

2003 L-Series 3.0L Sedan
Default Re: Poor Gas Mileage/Running Rich?

Quote:
Originally Posted by WVUDave View Post
I'm getting 25 MPG.
New wires, plugs, cleaned throttle body.
Sorry, I meant odometer mileage as catcon wear and tear may be a consideration with high mileage cars.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 05-09-2014, 08:59 AM   #12
WVUDave
Member
WVUDave is on a distinguished road
 
Join Date: Jun 2013
Posts: 77

2002 SL1
Default Re: Poor Gas Mileage/Running Rich?

Just under 110,000 miles.
I'll try cleaning the ground sensors.

REWARD EXCELLENCE!

Add to WVUDave's Reputation
Rate the quality of this post and help WVUDave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
WVUDave is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running very rich. Black Bear S-Series General 12 01-24-2013 10:35 AM
Running rich sunnfish S-Series Tech 1 02-26-2011 03:39 PM
SL2 gas mileage (RICH EXHAUST MAKES ME POOR) rudedog23 S-Series General 13 12-10-2007 04:56 PM
Running pig rich! Steedo S-Series Tech 6 11-16-2005 10:56 AM
Poor MPG, Running rich w/ Rotten Egg Smell Visseroth S-Series General 34 10-22-2005 01:46 PM


All times are GMT -4. The time now is 04:05 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.