SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-22-2007, 03:28 PM   #1
SBlack
Junior Member
SBlack is on a distinguished road
 
Join Date: Feb 2007
Posts: 10
Default 1997 SW2 throttle lurching when engine is warm

I recently relpaced my CPS, plugs, and wires. I developed the following problem after the parts were replaced.

My car now starts and runs well. However, once the temp reads 25% on the display gauge, the engine lurches when going from no throttle to a little throttle. Sometimes it stalls, unless I lightly tap, tap, tap the accelerator to get it past the initial throttle engagement.

It ONLY does this once the engine is warm. When the engine is cold, it accelerates perfectly.

It lurches when going from no gas to a little gas whether I am driving 65 mph or 5 mph.

It stalls when I am at a stop and going into initial acceleration, unless I tap the pedal.

Does anyone have an idea of what I messed up here?

Thanks.

Stan

REWARD EXCELLENCE!

Add to SBlack's Reputation
Rate the quality of this post and help SBlack reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SBlack is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-22-2007, 03:31 PM   #2
richpin06
Senior Member
richpin06 is a jewel in the roughrichpin06 is a jewel in the roughrichpin06 is a jewel in the roughrichpin06 is a jewel in the rough
 
richpin06's Avatar
 
Join Date: Nov 2006
Location: MA
Posts: 1,848
 

1998 SL2
Default Re: 1997 SW2 throttle lurching when engine is warm

stalls when I am at a stop.....sounds like a egr problem

...
http://www.youtube.com/richpin06a

REWARD EXCELLENCE!

Add to richpin06's Reputation
Rate the quality of this post and help richpin06 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
richpin06 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 SW2 engine swap with 1997 SL-2 bluzdoctor S-Series Tech 5 11-02-2009 09:44 AM
1997 SW2...Engine Code Question 2NDSOUT S-Series Tech 43 07-30-2008 08:36 AM
1997 sl1 rough idle when warm alan1990 S-Series Tech 7 07-13-2008 10:46 PM
96' SW2 Tough Start When Warm jenf S-Series Tech 6 05-03-2007 12:38 AM
93 sw2- stalls at stop once warm ndsaturn S-Series General 2 09-14-2004 02:45 AM


All times are GMT -5. The time now is 06:58 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.