SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-15-2018, 07:31 PM   #1
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Engine Lacks Power HELP!

I drove 20 miles today and went to multiple places but now I am having issues with my engine. I have a 95 SL2 Automatic. Heres what happens: I start the engine, it starts and idles normally. I put it in drive and still idles normal but when I step on gas it does nothing, I floor the pedal even and it takes almost 10 seconds until the engine responds and gains power. Once I am at speed it can stay at speed, but when I need to go from a stop or if I remove foot from gas then apply it again to gain speed it takes several seconds for engine to respond. I did not find any vacuum leaks or lose connections, and the battery and alternator voltage is within normal limit.

What could be the problem?

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-15-2018, 07:56 PM   #2
billr
Master Member
billr is a glorious beacon of lightbillr is a glorious beacon of lightbillr is a glorious beacon of lightbillr is a glorious beacon of lightbillr is a glorious beacon of light
 
Join Date: Jul 2013
Posts: 4,450
Default Re: Engine Lacks Power HELP!

"...when I step on gas it does nothing,..."

Literally "nothing"? No change in sound or rpm, no misfire vibration, not spitting into the intake or farting into the exhaust? Have you tried opening the throttle by hand out at the TB?

Take compression readings, it is so easy to do and can be very telling. Put a vacuum gauge on it and verify vac goes towards zero when you open the throttle fully. Take the O2 sensor out and see if relieving back-pressure even that much makes a noticeable difference.

REWARD EXCELLENCE!

Add to billr's Reputation
Rate the quality of this post and help billr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billr is offline   Reply With Quote
Old 09-15-2018, 08:25 PM   #3
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Re: Engine Lacks Power HELP!

Well now it is having an issue with idle, it sounds a little rough. When I apply gas in PARK the engine RPM goes higher like normal but sounds a bit off. But when in drive, I step on gas and push pedal half way down from a stop and the car moves slow as if my foot is not even on the pedal but after several seconds it responds to pedal and I get up to speed.

I think it may be the TPS, I have tested it months ago by unplugging while idling and every time I did the engine would start idling very rough. But now when I unplug it while it idles there is no change at all. Can anyone comment on this?

When I open throttle at the TB the engine shows it loses power for a fraction of a second and when I release the engine shows a struggle for a second.

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
Old 09-15-2018, 08:44 PM   #4
toggenburg
Master Member
toggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to behold
 
toggenburg's Avatar
 
Join Date: Apr 2010
Location: Beautiful Blue Ridge Mountains of Bedford, Virginia. Born once? Die twice. ------ Born twice? Die once.
Posts: 2,729

2001 SL1
Default Re: Engine Lacks Power HELP!

So, how many miles on the 95?
Taking the O2 sensor out as billr suggested is a very good idea, you may find that the problem is a plugged catalytic converter.

REWARD EXCELLENCE!

Add to toggenburg's Reputation
Rate the quality of this post and help toggenburg reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
toggenburg is offline   Reply With Quote
Old 09-15-2018, 09:05 PM   #5
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Re: Engine Lacks Power HELP!

Quote:
Originally Posted by toggenburg View Post
So, how many miles on the 95?
Taking the O2 sensor out as billr suggested is a very good idea, you may find that the problem is a plugged catalytic converter.
Car has 192,000 miles, the current catalytic converter has about 43,000 miles on it MAX.

Can the O2 sensor be removed and installed with manifold hot? Also what size socket do I need for it since I'll have to pick one up?

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
Old 09-16-2018, 05:03 PM   #6
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Re: Engine Lacks Power HELP!

Quote:
Originally Posted by billr View Post
"...when I step on gas it does nothing,..."

Literally "nothing"? No change in sound or rpm, no misfire vibration, not spitting into the intake or farting into the exhaust? Have you tried opening the throttle by hand out at the TB?

Take compression readings, it is so easy to do and can be very telling. Put a vacuum gauge on it and verify vac goes towards zero when you open the throttle fully. Take the O2 sensor out and see if relieving back-pressure even that much makes a noticeable difference.
I took a compression reading of each cylinder 35 days/1,200 miles ago and the results were: 1: 205PSI, 2: 210PSI, 3: 205PSI, 4: 210PSI. Should I take another compression test?

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
Old 09-16-2018, 05:05 PM   #7
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Re: Engine Lacks Power HELP!

Update: Today I wanted to see if it still has problem, and when I started engine it shut off right away. I cranked again and it started and was slow to gain RPM but then the RPM was bouncing and it is struggling hard to stay running.

Today I got a socket for the sensor, so I will try that test when able.

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
Old 09-16-2018, 05:45 PM   #8
billr
Master Member
billr is a glorious beacon of lightbillr is a glorious beacon of lightbillr is a glorious beacon of lightbillr is a glorious beacon of lightbillr is a glorious beacon of light
 
Join Date: Jul 2013
Posts: 4,450
Default Re: Engine Lacks Power HELP!

Has the engine performance changed since 35 days/1200 miles ago? If so, then "yes", check compression again.

REWARD EXCELLENCE!

Add to billr's Reputation
Rate the quality of this post and help billr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billr is offline   Reply With Quote
Old 09-16-2018, 07:39 PM   #9
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Re: Engine Lacks Power HELP!

Quote:
Originally Posted by billr View Post
Has the engine performance changed since 35 days/1200 miles ago? If so, then "yes", check compression again.
Engine performance has not changed one bit and neither has the fuel usage. I keep close track to fuel usage and since I got the car about almost 3 months ago and 2,100 miles ago I am always getting about 20.5MPG which is 100% city mileage.

Everything has remained the same until yesterday, I drove car to a friends home, shut off engine for about 10 minutes. When I was going to leave I started the engine started fine as usual, but when I put in drive and stepped on gas nothing happened. I first thought maybe my wheels were against the curb but saw i was 1 foot away. I shutoff engine and started again and it started again fine but still the same problem.

Again, from a stop I stepped on gas and would even press pedal half way and the engine speed would be only 100RPM above idle speed for several seconds until after the few seconds in which it responded so I would get normal engine speed and would get up to speed. Even when driving if I released gas fully and then when I tried to go faster while still moving (such as go from 30MPH to 40MPH) I press pedal and for several seconds the engine would not respond, but after the few seconds it responded and I was able to increase speed.

Now with engine cold, it does not want to run, if it doesn't shut off it struggles to keep running while in park.

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
Old 09-16-2018, 09:28 PM   #10
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,068
 

2003 L-Series 3.0L Sedan
Default Re: Engine Lacks Power HELP!

1-Do you know how to test the map sensor? You can remove it for inspection for any carbon deposits blocking the small port on the sensor.

2-Was fuel filter ever replaced (every 100k miles)?

3-What's fuel pressure? A f/p gauge may be borrowed from Autozone or Advance Auto.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 09-16-2018, 10:47 PM   #11
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Re: Engine Lacks Power HELP!

Quote:
Originally Posted by fdryer View Post
1-Do you know how to test the map sensor? You can remove it for inspection for any carbon deposits blocking the small port on the sensor.

2-Was fuel filter ever replaced (every 100k miles)?

3-What's fuel pressure? A f/p gauge may be borrowed from Autozone or Advance Auto.
1: Yes, that is on my list to test.

2: I believe so since the current filter does not look original

3: I do not know yet but it is on my list to test.

I am very busy every weekday so testing may be a while and I need to rent every tool. Right now I have the oxygen sensor socket so I can test the converter. If that passes I move onto next test.

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
Old 09-19-2018, 05:13 PM   #12
StrnWolf
Member
StrnWolf is on a distinguished road
 
Join Date: Jul 2016
Location: Solano County, CA
Posts: 69
 

1995 SL2
1994 SL1
Default Re: Engine Lacks Power HELP!

And so I believe the fuel pressure regulator is working on the count of engine idling changes when hose is removed. Now as for fuel pressure, at idle with vacuum hose attached I am getting 18.4 PSI, with it removed I am getting 19 PSI. After five minutes with engine off the pressure drops about 0.4 PSI.

After another look my fuel filter may be original to the car. Sadly right now I have no way to test pressure at the pump so all I can do is buy a new filter and cross my fingers it's problem solved.

It is hit and miss when my engine does not shut off right away, but anytime it does keep running, it always shuts off when I put it in gear.

...
07/2018-PRESENT 1995 SL2
12/2009-PRESENT (Soon to die) 1994 SL1

REWARD EXCELLENCE!

Add to StrnWolf's Reputation
Rate the quality of this post and help StrnWolf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
StrnWolf is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 L300 Saturn Lacks or lose Power bobbycarmon L-Series Tech 5 11-07-2014 08:01 AM
99 SC2 1.9 middrange lacks power gmoncrief S-Series Tech 4 11-12-2010 08:51 AM
1998 SC2 lacks power gmoncrief General Saturn Discussion 2 07-10-2010 10:38 PM
Re: Car lacks power cool_jr256 S-Series General 0 01-08-2006 10:31 PM
My car lacks power cool_jr256 S-Series General 12 11-29-2005 11:05 PM


All times are GMT -5. The time now is 10:44 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.