SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General

Closed Thread
 
Thread Tools Display Modes
Old 08-28-2004, 01:35 AM   #1
jpfrog
Junior Member
jpfrog is on a distinguished road
 
Join Date: Aug 2004
Location: Dallas, TX
Posts: 11
 
Default Finally installed AEM CAI!!!

Well I finally did it...what started a week ago as a trip to purchase an AEM CAI from the dealer and ended up as an out of control potential car trading extravaganza is now over. The CAI is on and sounding good.

I have one problem though. Now that the CAI is on, so is the "Service Engine" light. I'm sure I did something wrong even though I followed the directions exactly.

Has anyone else had this problem? How do I fix it? Did I do anything wrong? I did have a little difficulty with the whole gromet installation, but I thought I had it on right.
jpfrog is offline  
SaturnFans.com Sponsored Links
Old 08-28-2004, 02:51 AM   #2
s-seriesguy
Senior Member
s-seriesguy will become famous soon enough
 
Join Date: Aug 2004
Posts: 1,844
Default

Just you plug your air temperature sensor in? Have you tried disconnecting the negative battery terminal for 15 minutes?
s-seriesguy is offline  
Old 08-28-2004, 09:32 AM   #3
jpfrog
Junior Member
jpfrog is on a distinguished road
 
Join Date: Aug 2004
Location: Dallas, TX
Posts: 11
 
Default

I haven't tried that....what's the theory behind it though? You'll have to forgive me...I'm new to car mods.
jpfrog is offline  
Old 08-28-2004, 11:18 AM   #4
TXRLU
Advanced Member
TXRLU is on a distinguished road
 
TXRLU's Avatar
 
Join Date: Apr 2004
Location: TX
Posts: 610
 
Default

You unplug the battery to let the on board computer reset itself. If you've increased air-flow significantly the computer probably thinks there's an intake leak and the air/fuel mixture is not optimal. If the computer is reset it tends to reset the air fuel mixture. I'm curious as to what kind of fuel economy the CAI will generate. Keep us posted will ya?
...
LPE CAI
Ported TB
160* Thermostat
Diablo-Sport Tune
353HP@5800RPM & 348lb-ft tq@4500RPM Dynojet run 01/23/07
TXRLU is offline  
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AEM CAI installed, now having problems bc3tech Ion General 6 04-07-2005 09:04 PM
AEM CAI is on... saturnd00d Ion General 10 08-18-2004 02:25 PM
Aem Cai Esca Ion General 8 05-27-2004 08:21 PM
Just installed my AEM CAI soccer69er Ion General 29 02-18-2004 09:34 AM
Aem Cai $80.00 BlackBirdRacing Classifieds 5 09-17-2003 03:40 PM


All times are GMT -4. The time now is 07:12 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.