SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Astra > Astra General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-01-2013, 12:33 PM   #1
emg77
Advanced Member
emg77 has a spectacular aura aboutemg77 has a spectacular aura aboutemg77 has a spectacular aura about
 
emg77's Avatar
 
Join Date: May 2005
Location: Michigan
Posts: 905
 

2008 Astra XR
Default Ac not working. AC, recirc, and defrost lights not working

As I was driving today, my AC stopped working and my the leds on the buttons of my hvac controls aren't working anymore. The fan controls are working. I'm guessing I blew a fuse or something. Does anyone have a fuse chart and have any ideas which one it might be? Any other ideas? I'm hoping it's something simple like a fuse.

...
Drives: 2014 Volt, 2017 Acadia
Past Cars: 08 Astra, 15 Acadia, 12 Enclave, 09 Traverse, 05 Vue, 04 Grand Prix, 00 Alero, 97 LeSabre, 72 Cutlass S

REWARD EXCELLENCE!

Add to emg77's Reputation
Rate the quality of this post and help emg77 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
emg77 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-01-2013, 03:56 PM   #2
emg77
Advanced Member
emg77 has a spectacular aura aboutemg77 has a spectacular aura aboutemg77 has a spectacular aura about
 
emg77's Avatar
 
Join Date: May 2005
Location: Michigan
Posts: 905
 

2008 Astra XR
Default Re: Ac not working. AC, recirc, and defrost lights not working

Seems to be fixed. Fuse #14 in the rear fuse block was blown. It's a 7.5 amp. I put a 10 amp in to test it out, and it worked. I'll run to the store shortly to get the proper 7.5 amp fuse. I'm glad it was something simple. I don't use the ac a lot, but I want it working for those times that I do need it.

...
Drives: 2014 Volt, 2017 Acadia
Past Cars: 08 Astra, 15 Acadia, 12 Enclave, 09 Traverse, 05 Vue, 04 Grand Prix, 00 Alero, 97 LeSabre, 72 Cutlass S

REWARD EXCELLENCE!

Add to emg77's Reputation
Rate the quality of this post and help emg77 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
emg77 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 L200 defrost not working. fixxer L-Series Tech 7 09-27-2016 08:15 AM
CD Player/Defrost not working. coincidence??? knottyvr6jetta S-Series General 2 01-06-2012 06:48 PM
Service Wrench Light on, ABS light on, Rear Defrost stopped working lg540 S-Series Tech 10 10-30-2011 01:47 PM
Blower, heated seats, rear defrost not working mygreenforest L-Series Tech 5 01-22-2011 01:50 PM
Recirc button not working btrautman L-Series Tech 21 07-03-2008 12:26 PM


All times are GMT -4. The time now is 08:13 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.