SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-15-2019, 12:23 PM   #1
wastedpotential
New Member
wastedpotential is on a distinguished road
 
Join Date: Jun 2019
Posts: 1
Default Trans issue

A little over a year ago the transmission on my 06 Ion with the 2.2 and 4T45E started staying stuck in 1st gear, then it would bang into 2nd. Once it started doing it I learned to be easy on the throttle and it still wouldn't shift right every time but at least wouldn't bang into second. I had GM flash the TCM because of the TSB on for the 1-2 shift. That didn't fix it and I kept driving it that way for awhile, then I lost overdrive on the highway on the way back from a 100 mile round trip. Still kept driving it around town.

Then it developed a fuel line leak and I got fed up with it between the trans issue, needing tires and then the fuel leak I left it sit for about a year. About a month ago I finally fixed the fuel leak and have been driving it around. The 1-2 shift issue has disappeared completely but it still won't go into overdrive. I took it back to GM and told them to diagnose it this time. They called and said the TCM is bad well replace it for $400. Which is what I was hoping for so told them to go ahead with it. Sadly they called back and said it didn't fix it that they would need $900 to drop and explore the trans. Before they did the TCM they told me the tech found low voltage going to the trans computer which I thought was odd. Since if the trans computer had low voltage going to it its not the trans computer obviously. Figuring the guy misspoke but now wondering and don't have much confidence in these guys.

I haven't had my buddy back to pull trans codes since before the OD issue. When it was just the 1-2 shift issue we got

P0752 1-2 shift solenoid valve performance

P1818 TFP indicates drive without drive. (if I remember right this is the code that prompted the TSB)

My code reader won't pull trans code. I'll have to see if I can get my buddy back here with his. He was saying with the first set of codes that I would have to hook a pressure tester up and the computer then look for certain things. He said its beyond him as anytime his shop gets trans problem like this they send it off to a specialist and he doesn't know how to interpret the readings.

REWARD EXCELLENCE!

Add to wastedpotential's Reputation
Rate the quality of this post and help wastedpotential reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wastedpotential is offline   Reply With Quote
SaturnFans.com Sponsored Links
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
trans issue need help sc2 saturn S-Series Tech 5 07-11-2017 01:09 AM
98 SL2 Trans Issue ghal79 S-Series Tech 3 02-10-2016 07:50 PM
Trans issue Mkrown Introductions & Greetings 0 03-23-2013 01:22 AM
2rd trans same issue moms-car S-Series Tech 10 10-04-2012 08:09 PM
Trans issue? Or something else? Help please! eightofus4him S-Series Tech 17 05-29-2007 10:41 PM


All times are GMT -4. The time now is 01:12 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.