SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 02-21-2014, 09:57 PM   #1
Herbivore
Junior Member
Herbivore is on a distinguished road
 
Join Date: Feb 2014
Posts: 13
Default SL2 park fuse keeps blowing, and blowing

Hello, first post, admittedly not a good one haha.
So my car (99 sl2, 5spd) hasn't had any problems untill yesterday my dash lights/tail lights went out and i checked the fuse and sure enough it was blown so i replaced it and it blew, so i replaced it with a 15 fuse (its supposed to be a 10) and it blew that.

SO I unplugged all my tail lights to try to isolate the problem, still blew a fuse, unplugged all tail lights AND my dimmer switch, still blew. I am now fresh out of ideas.. any thoughts anyone?
Herbivore is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-21-2014, 10:14 PM   #2
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: SL2 park fuse keeps blowing, and blowing

One of the side marker lamps is full of water and salt. It is better to check each bulb socket instead of smoke testing by popping fuses. The owners manual has a list of every bulb circuit on that fuse. Do you have the owners manual? If not I can probably post it for you.
OldNuc is offline   Reply With Quote
Old 02-21-2014, 10:16 PM   #3
billr
Master Member
billr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to behold
 
Join Date: Jul 2013
Posts: 7,440
Default Re: SL2 park fuse keeps blowing, and blowing

Well I haven't looked at a schematic yet, but stop just replacing fuses... especially with higher amperage ones!

Edit: Just so we aren't guessing, exactly which fuse is it you are blowing? (Label on the fuse cover).
billr is offline   Reply With Quote
Old 02-21-2014, 10:39 PM   #4
Herbivore
Junior Member
Herbivore is on a distinguished road
 
Join Date: Feb 2014
Posts: 13
Default Re: SL2 park fuse keeps blowing, and blowing

Update, Its the "Park" fuse, it runs the tail lights, dash lights and dimmer switch from what i'm aware.. I only replaced it with a 15 cuz it was the only one i had handy, i didn't plan on just upping it haha.
i just took out the radio cuz i was told that it runs off the park fuse for some reason as protection and still blew a fuse...
I do not have the manual unfortunately, used car

I have about 20 fuses so i'm not terribly worried about smoke testing as you put it haha. I'll go check my side markers right now. thank you for the tip! its very possible that they got filled with crap (minnesota blizzard for the past few days)

SO I just checked the side markers in the front and the passenger side is perfectly fine, however the drivers side marker is missing. not the bulb but the whole wire for it and everything, like it was never there... I tried to find out where the wire would have come from but I can not find it...

Last edited by Herbivore; 02-21-2014 at 10:47 PM. Reason: new info
Herbivore is offline   Reply With Quote
Old 02-21-2014, 11:12 PM   #5
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: SL2 park fuse keeps blowing, and blowing

Well, that might be the problem. The fog lamp and side marker come from a single branch off of the lighting harness. Probably hiding behind the fender liner.
OldNuc is offline   Reply With Quote
Old 02-21-2014, 11:15 PM   #6
Herbivore
Junior Member
Herbivore is on a distinguished road
 
Join Date: Feb 2014
Posts: 13
Default Re: SL2 park fuse keeps blowing, and blowing

So I have my checked every bulb and connection on my car except the license plate illumination bulbs and they're all fine,
all my tail lights are unplugged,
my radio is unplugged,
my running lights are unplugged
and it keeps blowing as soon as twist the stick to running lights
Is there anything that I'm missing that could cause that? I'm out of my league here, electrical is not my strong point. I'm still used to engine repair, sorry for being so clueless here
Herbivore is offline   Reply With Quote
Old 02-21-2014, 11:16 PM   #7
Herbivore
Junior Member
Herbivore is on a distinguished road
 
Join Date: Feb 2014
Posts: 13
Default Re: SL2 park fuse keeps blowing, and blowing

Quote:
Originally Posted by OldNuc View Post
Well, that might be the problem. The fog lamp and side marker come from a single branch off of the lighting harness. Probably hiding behind the fender liner.
I'll try to poke around and find it but I don't know how long it's been missing for, it's quite possible it was missing the entire time. Would i be best able to see it from under the car or looking down under the hood/maybe in the fender.. I'll poke about for a few and see what I can dig up

Also, not sure if relevant but I have no fog lights *Shrug*
Herbivore is offline   Reply With Quote
Old 02-21-2014, 11:24 PM   #8
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: SL2 park fuse keeps blowing, and blowing

Drawings.... Disconnect all bulbs and clean sockets. See if that fixes it. Could be any one of these.
Attached Images
File Type: jpg Screen-2014-02-21_21-23.jpg (87.9 KB, 19 views)
File Type: jpg Screen-2014-02-21_21-21.jpg (57.2 KB, 19 views)
OldNuc is offline   Reply With Quote
Old 02-21-2014, 11:27 PM   #9
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: SL2 park fuse keeps blowing, and blowing

Quote:
Originally Posted by Herbivore View Post
I'll try to poke around and find it but I don't know how long it's been missing for, it's quite possible it was missing the entire time. Would i be best able to see it from under the car or looking down under the hood/maybe in the fender.. I'll poke about for a few and see what I can dig up

Also, not sure if relevant but I have no fog lights *Shrug*
Fog light wiring is usually present and it all forks off the main harness just behind the light. The lights are on the forward lighting harness, follow the bundle backwards.
OldNuc is offline   Reply With Quote
Old 02-21-2014, 11:32 PM   #10
Herbivore
Junior Member
Herbivore is on a distinguished road
 
Join Date: Feb 2014
Posts: 13
Default Re: SL2 park fuse keeps blowing, and blowing

Quote:
Originally Posted by OldNuc View Post
Fog light wiring is usually present and it all forks off the main harness just behind the light. The lights are on the forward lighting harness, follow the bundle backwards.
Thank you! I'll go trace some wires for a while.. extremely helpful!
I'm worried that it might be the fuse box itself or possibly something in my dash ( I do not want to take my dashboard apart, its effing cold and I work 12 hours the next 3 days)
Herbivore is offline   Reply With Quote
Old 02-21-2014, 11:48 PM   #11
Madness10
Advanced Member
Madness10 will become famous soon enough
 
Join Date: Aug 2012
Location: Fontana,Calif
Posts: 954
 

2001 SC2
Default Re: SL2 park fuse keeps blowing, and blowing

Could it be the multi switch causing the problem?
Madness10 is offline   Reply With Quote
Old 02-21-2014, 11:50 PM   #12
Herbivore
Junior Member
Herbivore is on a distinguished road
 
Join Date: Feb 2014
Posts: 13
Default Re: SL2 park fuse keeps blowing, and blowing

Quote:
Originally Posted by Madness10 View Post
Could it be the multi switch causing the problem?
The multi-switch? you mean the actual stick that turns the lights on/off?
Herbivore is offline   Reply With Quote
Old 02-21-2014, 11:55 PM   #13
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: SL2 park fuse keeps blowing, and blowing

Yes, that is what he meant. Bulbs first and then go from there all of these parts can be individually isolated. This could be nothing more than a failed park-turn bulb that has shorted internally to find them you disconnect all of them. Inspect bulb and clean out sockets.
OldNuc is offline   Reply With Quote
Old 02-23-2015, 12:52 PM   #14
Farnuckel
New Member
Farnuckel is on a distinguished road
 
Join Date: Feb 2015
Posts: 1
Default Re: SL2 park fuse keeps blowing, and blowing

Did you ever figure it out? I'm having the same problem with the same fuse in my 06 Ion2; except when I replaced the fuse, the car did fine for a 10 minute drive, then blew again. I haven't started the process of unplugging everything, but I suspect it's the light switch itself in your case, and possibly mine.
Farnuckel is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Park fuse blowing Speedrc99 S-Series Tech 2 03-21-2013 09:26 PM
2004 3.5l vue - PARK fuse blowing jonolsonroll200 Vue Tech 1 05-28-2012 06:42 PM
Park Lamp mini fuse keeps blowing ar04 L-Series Tech 2 08-07-2009 10:59 AM
Park Fuse keeps blowing Whiteshadow651 S-Series General 7 02-13-2009 12:28 PM
"Park" (instrument panel) fuse keeps blowing OhioSaturnGuy S-Series Tech 3 07-15-2006 03:42 PM


All times are GMT -4. The time now is 06:44 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.