SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn Aura > Aura General

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-18-2023, 02:12 AM   #1
Ravenhide
New Member
Ravenhide is on a distinguished road
 
Join Date: Oct 2021
Posts: 8
Default TCM Fuse Repeatedly Blowing

So, I'm stuck at work right now, 45 minutes away from home at 1 in the morning. Got off work at 11 pm, started my Aura, and got an illuminated MIL and a Power Steering warning on my dash. No biggie, I'll just add some fluid. Quick Google search and I discovered the Aura XR doesn't have a hydraulic system, it's electrical. Well, frick. Battery connections are solid, battery seems to be fully charged. Well technically according to my meter the battery is at like 17.5. Seemed a little high, but car started and ran just fine. Decided to check my fuses with my meter, and bingo! Fuse 42, the 10 amp for the TCM is blown. This matched my OBD II, which told me that the MIL was illuminated due to communication loss with the TCM. So cool. Found the issue. Car has 128k miles on it, I've never replaced any of the fuses since I got it via a buy here pay here program at like 108k miles. Since every place is closed and my workplace doesn't sell fuses, I scavenged a 10 amp from my heated seats so I could attempt to get home. Except as soon as I turned the ignition the damn fuse blew again.

So, now what? I have no idea how to check my wiring, grounds, or the TCM itself to try and pinpoint what's causing it. I don't even know where my TCM is. Google suggested it was at the base of my steering column but I haven't tried to look because I have no idea what I'm even looking for. I'm open to any suggestions at this point, although it's likely I'm going to be spending the night in my work's parking lot. I dont get paid till early Wednesday morning so I can't even tow it to a shop and have them take a look tomorrow. Any help would be appreciated at this point.
Ravenhide is offline   Reply With Quote
SaturnFans.com Sponsored Links
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 SL2 repeatedly blows fuse but only at >60 mph..... hmbldtsatrn S-Series General 12 07-01-2020 12:16 AM
2002 SL1 1.9 SOHC repeatedly blows emissions fuse ringfinger6 S-Series Tech 11 08-02-2018 06:09 PM
SL2 park fuse keeps blowing, and blowing Herbivore S-Series Tech 13 02-23-2015 12:52 PM
hi and need help. blowing fuse allen57 S-Series Tech 1 04-15-2007 10:42 PM
Window Fuse Blown Repeatedly 2003_ION3 Ion General 2 06-19-2005 09:36 AM


All times are GMT -4. The time now is 06:56 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.