SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-30-2011, 02:40 PM   #1
mashley
New Member
mashley is on a distinguished road
 
Join Date: Nov 2011
Location: Cheyenne, WY
Posts: 5

1994 SL2
Default 94 SL2 wont start - no spark - Replaced CPS

alright everyone, being a new member here I want to first say thank you to everyone for all of the great information posted here. It has been very helpful.

Here is my situation. I have a '94 SL2 with 127K miles. throughout the last year I have replaced the fuel pump, fuel filter, thermostat, water pump and radiator.

Most recently I was having issues with hard starts, having to floor it to start and sometimes not starting at all. I replaced the ECTS and it solved the problem, running like a new car.

Sunday I climbed in to go to work and it started fine, ran fine. Stopped and got gas and it would not start at all. It would crank but seemed to not have any fire. Pulled it home and then it started on Tuesday so I could drive it into the garage. Reading the threads here I was led to replace the CPS.

Replaced CPS this morning and unfortunately it still is not starting. Currently have the battery charger on it to make sure battery is fully charged.

Now, as I am by myself for awhile, I cannot pull plugs or wires off of the coils to make sure I'm getting spark. I will have to wait until after my 17yr old son gets home from school to check that.

Any additional items to be looking for? I don't have a a scanner to pull codes.

Now what? any input is greatly appreciated.

REWARD EXCELLENCE!

Add to mashley's Reputation
Rate the quality of this post and help mashley reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mashley is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-30-2011, 02:51 PM   #2
LabRat
Advanced Member
LabRat is on a distinguished road
 
Join Date: Oct 2011
Location: Des Moines, WA (Seattle)
Posts: 580

1998 SL2
1999 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

Does the fuel pump audibly run when you first turn the key on? Are you getting fuel to the fuel rail?

-LR

REWARD EXCELLENCE!

Add to LabRat's Reputation
Rate the quality of this post and help LabRat reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
LabRat is offline   Reply With Quote
Old 11-30-2011, 02:56 PM   #3
LabRat
Advanced Member
LabRat is on a distinguished road
 
Join Date: Oct 2011
Location: Des Moines, WA (Seattle)
Posts: 580

1998 SL2
1999 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

and one other thing, is the CPS fully seated?
-LR

REWARD EXCELLENCE!

Add to LabRat's Reputation
Rate the quality of this post and help LabRat reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
LabRat is offline   Reply With Quote
Old 11-30-2011, 02:59 PM   #4
mashley
New Member
mashley is on a distinguished road
 
Join Date: Nov 2011
Location: Cheyenne, WY
Posts: 5

1994 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

yes, the fuel pump is audible when the key is turned on.

REWARD EXCELLENCE!

Add to mashley's Reputation
Rate the quality of this post and help mashley reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mashley is offline   Reply With Quote
Old 11-30-2011, 03:01 PM   #5
mashley
New Member
mashley is on a distinguished road
 
Join Date: Nov 2011
Location: Cheyenne, WY
Posts: 5

1994 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

Thanks LabRat, yes I just double checked the CPS, and it is fully seated and secure.

REWARD EXCELLENCE!

Add to mashley's Reputation
Rate the quality of this post and help mashley reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mashley is offline   Reply With Quote
Old 11-30-2011, 03:06 PM   #6
LabRat
Advanced Member
LabRat is on a distinguished road
 
Join Date: Oct 2011
Location: Des Moines, WA (Seattle)
Posts: 580

1998 SL2
1999 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

check for fuel spray from schrader valve on the fuel rail, if there's good spray then spark is likely the problem. No or low fuel pressure at the fuel rail then restriction is likely between pump and rail, most likely the fuel filter/regulator assembly.

-LR

REWARD EXCELLENCE!

Add to LabRat's Reputation
Rate the quality of this post and help LabRat reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
LabRat is offline   Reply With Quote
Old 12-02-2011, 09:07 PM   #7
mashley
New Member
mashley is on a distinguished road
 
Join Date: Nov 2011
Location: Cheyenne, WY
Posts: 5

1994 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

Ok...so here is a new twist to my starting/running issue.

I have good fuel to the injectors, but intermittent spark. If the car is cold or has sat for several hours, it will start up just fine, running smooth and ideling well. If I let it sit idleing for about 3-4 minutes to get warm, it will die.

After it dies, it will not fire again. Pulling the plug wires from the 1-4 coil bank and cranking the motor shows that there is no spark. If I wait a few hours and try it again it starts just fine.

As I stated in my original post, I have replaced the water pump, thermostat, fuel pump and filter within the last year and within the last couple weeks I have replaced the radiator, the ECTS and CPS.

Any thoughts on what I should be looking for next??

Thanks for all the input.

REWARD EXCELLENCE!

Add to mashley's Reputation
Rate the quality of this post and help mashley reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mashley is offline   Reply With Quote
Old 12-02-2011, 09:48 PM   #8
rollin_96
Member
rollin_96 is on a distinguished road
 
Join Date: Jul 2009
Posts: 177

1996 SL1
1994 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

If you got no spark at both coil packs, it's mostly likely the Ignition control module. If you got spark on one, it's the coil pack.

...
Tweaked FSM http://www.mediafire.com/?ofliygqpep460un

REWARD EXCELLENCE!

Add to rollin_96's Reputation
Rate the quality of this post and help rollin_96 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
rollin_96 is offline   Reply With Quote
Old 12-02-2011, 10:36 PM   #9
mashley
New Member
mashley is on a distinguished road
 
Join Date: Nov 2011
Location: Cheyenne, WY
Posts: 5

1994 SL2
Default Re: 94 SL2 wont start - no spark - Replaced CPS

Thanks....I'll check both coil packs momentarily.

What would cause the coil packs to stop working as the engine warms up?

REWARD EXCELLENCE!

Add to mashley's Reputation
Rate the quality of this post and help mashley reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mashley is offline   Reply With Quote
Old 12-03-2011, 05:16 AM   #10
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,523
 

2003 L-Series 3.0L Sedan
Default Re: 94 SL2 wont start - no spark - Replaced CPS

The ignition coils are plugged on to the ignition control module. The icm controls when to turn on the coils for spark. Check spark to all four plugs after the engine warms up and dies - if all four plugs lose spark on a warm engine the icm is faulty. Junk yard icm's and coil packs are good replacements and cheaper than new parts.

99% of engines losing spark mysteriously are due to faulty cps'. The other 1% are from faulty icm's. You're in the 1% with a faulty icm. Replace the ignition control module.

...
VCX NANO

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced timing belt...now motor wont start 2000 LS2 stokesdead L-Series Tech 9 03-20-2012 12:19 AM
03 vue replaced transmission, now wont start vue2.2 Vue Tech 10 10-04-2011 01:09 PM
96 saturn no spark wont start jonathanhadix S-Series Tech 6 11-21-2010 02:23 AM
car wont start, no spark. lor3nzo S-Series Tech 44 11-01-2009 03:11 PM
has spark, air and fuel but wont start kre8ive_kustomz S-Series Tech 28 06-23-2006 11:06 PM


All times are GMT -4. The time now is 10:47 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.