SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Outlook > Outlook General

Reply
 
Thread Tools Display Modes
Old 11-30-2007, 08:41 PM   #1
monte70z20
Junior Member
monte70z20 is on a distinguished road
 
Join Date: Nov 2007
Posts: 15
Default Driver Information Center not working

New to the forum. Saturn 2007 Outlook XR. I had an aftermarket Auto starter, and reversing camera with sensors installed and the shop disconnected the battery to do the work. When everything put back together the first 3 buttons of the DIC are no longer working. The buttons illuminate and the fourth button closest to the passenger side cycles through the Odometer and Trip A and B odometer but other 3 are toast. The stem still cycles through its functions as well. Is there something that needs to be reset for these buttons to work again? Any way to troubleshoot the buttons versus the wiring harness? Any ideas appreciated.
monte70z20 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-01-2007, 03:03 PM   #2
djhhjd
Member
djhhjd is on a distinguished road
 
djhhjd's Avatar
 
Join Date: Nov 2007
Posts: 202
 

2009 Outlook XR
2005 VUE 3.5L
Default Re: Driver Information Center not working

I wonder if they needed a space for one of your new componants in the fuse block and took one out or something. Maybe a trip to the dealer is in order.
djhhjd is offline   Reply With Quote
Old 12-01-2007, 03:26 PM   #3
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,915
 

2003 L-Series 3.0L Sedan
Default Re: Driver Information Center not working

I would call or bring the Outlook back to the place that did the aftermarket installation since the DIC was working before it partially failed. They may have an answer or at least be informed of a possible problem they may have caused and can follow up with some checks going over the installation. Give them the opportunity to know about the problem so they can assess whether their installation caused this or if it just occurred and is the result of a Saturn fault before bringing it to Saturn. Assuming the factory warranty is good for any possible fault to the DIC not caused by the aftermarket work. Just my 2-cents.
...
VCX NANO
fdryer is offline   Reply With Quote
Old 12-02-2007, 05:09 PM   #4
monte70z20
Junior Member
monte70z20 is on a distinguished road
 
Join Date: Nov 2007
Posts: 15
Dizzy Re: Driver Information Center not working

Thanks for the responses so far. I plan on bringing back to the installers early this coming week. I just would like to get some ideas of what can possibly be going wrong with it from people like yourselves who may have the answers to what could be a simple or complex resolution. However it's sounding more and more like a more complex one. Once sorted out, I plan on posting what the issue was so that others may benefit. In the meantime if there are any other ideas, please keep them coming. Many Thanks
monte70z20 is offline   Reply With Quote
Old 12-09-2007, 01:46 PM   #5
MaxPower
Junior Member
MaxPower is on a distinguished road
 
Join Date: Jul 2005
Location: STL
Posts: 19

1999 SL
2007 Outlook XE
Default Re: Driver Information Center not working

Quote:
Originally Posted by monte70z20 View Post
Thanks for the responses so far. I plan on bringing back to the installers early this coming week. I just would like to get some ideas of what can possibly be going wrong with it from people like yourselves who may have the answers to what could be a simple or complex resolution. However it's sounding more and more like a more complex one. Once sorted out, I plan on posting what the issue was so that others may benefit. In the meantime if there are any other ideas, please keep them coming. Many Thanks
Let us know what the exact fix was! I've got a DIC button set on order to install in my 2007 XE. I'll post up a How-To once I get it all in.

You can order the trim piece that already has the cutout for the DIC buttons - but it's $81!! I am going to try a Dremel + some hard setting epoxy or JB weld, see how that does
...
1999 SLm (Daily Driver) 36mpg
2007 Outlook XE - Adv. Audio + DVD. Remote Start and DIC buttons coming!
2001 440+RWHP Lightning (Garage Queen) , 12.1 sec ET's
2005 5spd VUE (SOLD)
1991 SLa (SOLD)
MaxPower is offline   Reply With Quote
Old 12-09-2007, 09:49 PM   #6
SaturnSdn
Master Member
SaturnSdn will become famous soon enoughSaturnSdn will become famous soon enough
 
SaturnSdn's Avatar
 
Join Date: Dec 2001
Location: Az
Posts: 3,214
 

2007 ION-3 Sedan
2007 ION-3 Sedan
Default Re: Driver Information Center not working

Quote:
Originally Posted by monte70z20 View Post
New to the forum. Saturn 2007 Outlook XR. I had an aftermarket Auto starter, and reversing camera with sensors installed and the shop disconnected the battery to do the work. When everything put back together the first 3 buttons of the DIC are no longer working. The buttons illuminate and the fourth button closest to the passenger side cycles through the Odometer and Trip A and B odometer but other 3 are toast. The stem still cycles through its functions as well. Is there something that needs to be reset for these buttons to work again? Any way to troubleshoot the buttons versus the wiring harness? Any ideas appreciated.

Yes make the people that messed it up fix it, then do not return to them for anything other then to warranty upcoming problems.
SaturnSdn is offline   Reply With Quote
Old 12-09-2007, 09:58 PM   #7
monte70z20
Junior Member
monte70z20 is on a distinguished road
 
Join Date: Nov 2007
Posts: 15
Thumbs Up Re: Driver Information Center not working

Thanks for all the helpful tips. I took it back earlier this week and they played around with it for a while. They did fix it and when I asked them what it was, I was told that they were able to get to relearn the tire positions and once they reprogrammed the tire positions (tire pressure), all returned to normal. Not sure if there is truth to this or not. Just glad it's fixed and everything seems to finally be working. I was given a good reference for this shop to do the work I was looking for but next time will definitely be different. I only hope there is no warranty work on the components I purchased, that will need me to go back.
monte70z20 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Driver Information Center displays billwill Aura General 2 01-28-2009 12:27 PM
Driver Information Center readout billwill Aura General 11 12-17-2008 06:12 PM
Driver Information Center?? JimmyP 2008 Vue 6 03-21-2008 12:34 AM
Driver Information Center? dvam Aura General 8 08-15-2007 08:26 PM
Driver Information Center NDH 66 Aura General 9 05-24-2007 03:57 PM


All times are GMT -4. The time now is 02:33 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.