SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 01-05-2014, 05:55 PM   #1
jchu210
Member
jchu210 is a jewel in the roughjchu210 is a jewel in the roughjchu210 is a jewel in the roughjchu210 is a jewel in the rough
 
jchu210's Avatar
 
Join Date: Dec 2010
Location: Binghamton, NY
Posts: 147

1999 SC2
Default p0420 code

on a 99 sc2 dohc auto 108K miles.

recently replaced:
front o2 sensor (denso)
entire exhaust system below the exhaust manifold
spark plugs (ngk) and ects with brass at 85K, wires 100K
egr ports cleared with compressed air 100K

random tidbits:
1. when engine is warm, after performing a complete stop, rpms dip momentarily and rises back to normal idle.
2. pulling the fuse for pcm-b does not work. ses light appears after car is started.
3. no egg smell
4. mpg has dropped from about 30mpg to about 24mpg

any advice is appreciated. I hope its nothing with the cat again, wouldn't be able to afford it. thank you.
...
....
auto 99 SC2, 110K miles
jchu210 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-05-2014, 07:04 PM   #2
SL19302
Master Member
SL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to all
 
SL19302's Avatar
 
Join Date: Jan 2011
Location: Drums, PA
Posts: 3,350

2000 SW2
2002 SL1
Default Re: p0420 code

Check for any exhaust leaks from the exhaust manifold to the Converter, Any leaks on the front pipe will cause that code, A shop vac with the hose attached to the blow setting works well in detecting leaks, Put the hose into the tailpipe to pressurize the exhaust system and spray down the front exhaust pipe with soap and water, The flex pipe and around the Transmission clamp are common places for the pipe to crack and rott and leak.
...
2015 Subaru Forester Limited "Prinny"
2000 SW2 Still Running Strong- 160K Traded In
2002 SL1 Still has Its Training Wheels on at 88K Traded In


CHECK YOUR OIL!

Last edited by SL19302; 01-05-2014 at 07:12 PM.
SL19302 is offline   Reply With Quote
Old 01-15-2014, 02:19 PM   #3
jchu210
Member
jchu210 is a jewel in the roughjchu210 is a jewel in the roughjchu210 is a jewel in the roughjchu210 is a jewel in the rough
 
jchu210's Avatar
 
Join Date: Dec 2010
Location: Binghamton, NY
Posts: 147

1999 SC2
Default Re: p0420 code

this code was resolved today after i floored the pedal to WOT.
previously i try to keep it at 3000rpm or lower because of the oil burning, and i hadnt gone over 3500rpms for awhile.

seems like a little WOT every now and then is good for the car, for reasons i'd love to hear the explanation for.

also seems like the o2 sensor rear would have been the culprit in this case.
...
....
auto 99 SC2, 110K miles
jchu210 is offline   Reply With Quote
Old 01-15-2014, 02:26 PM   #4
TXSaturn02
Master Member
TXSaturn02 has a spectacular aura aboutTXSaturn02 has a spectacular aura aboutTXSaturn02 has a spectacular aura about
 
TXSaturn02's Avatar
 
Join Date: Dec 2006
Location: Houston
Posts: 4,091
 

2002 SL2
Default Re: p0420 code

Quote:
Originally Posted by jchu210 View Post
seems like a little WOT every now and then is good for the car, for reasons i'd love to hear the explanation for.
I've heard it called an italian tune up.

Some swear by it. Like a good sneeze maybe?
...
2002 SL2 Manual - new in November, 2001
As of 09/30/17: 223,751 Miles - SOLD
New owner report of 08/08/19: 234,408 Miles

2013 Mazda 3 HB - new in October 2012
As of 11/12/20: 78,895 Miles
TXSaturn02 is offline   Reply With Quote
Old 01-15-2014, 10:05 PM   #5
jhonky
Senior Member
jhonky is on a distinguished road
 
Join Date: Jul 2010
Location: North Texas
Posts: 1,108
 

1998 SL2
Default Re: p0420 code

how recently did you do the exhaust? i just had the code but it was like 4 months after doing the exhaust so not exactly correlated. 108k seems awfully low for it to be a bad o2 sensor. my car had 202k before the rear o2 went bad
...
98 SL2
5th gear swap- .643 gear
245,000 miles
215/45 17"
I burn about a quart about every 1500 miles.

If it ain't broke, fix it some more.
jhonky is offline   Reply With Quote
Old 01-17-2014, 02:41 AM   #6
CND_SC1
Advanced Member
CND_SC1 is on a distinguished road
 
Join Date: May 2006
Location: Toronto, Canada
Posts: 545

1994 SC1
Default Re: p0420 code

Quote:
Originally Posted by jchu210 View Post
this code was resolved today after i floored the pedal to WOT.
previously i try to keep it at 3000rpm or lower because of the oil burning, and i hadnt gone over 3500rpms for awhile.

seems like a little WOT every now and then is good for the car, for reasons i'd love to hear the explanation for.
.
I hoped this gets rid of your problem. But wait a couple more days before closing the book.

My current car (02 Altima 2.5) has had a persistent p0420 since about ten days after I got it. Once in 2012 a passenger accidentally bumped the shifter in to N just as I was launching from a green light in the middle of a hill - the Tach needle spiked to 6500 for a moment and the SES light went out 2 seconds later, but it returned the next day after about 25 miles of driving.
CND_SC1 is offline   Reply With Quote
Old 02-13-2015, 07:37 PM   #7
jchu210
Member
jchu210 is a jewel in the roughjchu210 is a jewel in the roughjchu210 is a jewel in the roughjchu210 is a jewel in the rough
 
jchu210's Avatar
 
Join Date: Dec 2010
Location: Binghamton, NY
Posts: 147

1999 SC2
Default Re: p0420 code

problem resolved,

it was the downstream O2 that caused this p0420.

light went away without manual reset within minutes.....

and the old downstream O2 sensor, at only 115K old, was pretty carboned up...

i probably won't see any mpg gains, but at least that light is off
...
....
auto 99 SC2, 110K miles
jchu210 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P0420 DickG S-Series Tech 7 06-17-2013 03:34 AM
code P0420 ericfragola Vue Tech 18 01-23-2013 02:16 PM
'98 SL2 P0420 Code jhart S-Series Tech 52 12-17-2012 01:56 PM
help i got a code that is P0420 butters122706 L-Series Tech 0 06-13-2009 11:00 AM
Code P0420? DeMAN Miscellaneous Tech 3 08-09-2004 11:33 PM


All times are GMT -4. The time now is 07:32 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.