SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-16-2018, 09:17 AM   #1
dub-nub
New Member
dub-nub is on a distinguished road
 
Join Date: Jul 2018
Posts: 2
Default '06 Ion 2.2L needing HELP P0107, P0651

Hello all, i am needing to fix a saturn ion for my daughters friend. I was called to say that the car began to jerk and sputter then died in the middle of the road.

Drove up their and made sure gas was good, and battery was good.

Upon reading the codes, i received 12 codes, cleared them and then only 3 stuck

P0107
P0651
P2432 (not concerned about this as it wouldnt make the car run like a turd)

MAP sensor code for low voltage P107 is what i need help troubleshooting. I checked the voltage and am seeing 1.4v at grey wire (based on diagram on map sensor) and 1.4V at the PCM pin also. Battery is fully charged at 12v.

I do not have a Haynes manual as this is not my vehicle, so having a hard time locating the correct information.

Can someone assist me in knowing where the grounds/power are for the ECU?

Anyone able to provide a full pinout for 2006 saturn ion 2.2l FWD?

PLease confirm the following 5v reference sensor: TPS, Crank, MAP. I need to unplug each one and see if the 5v comes back to the MAP wire.

Thanks in advance.

REWARD EXCELLENCE!

Add to dub-nub's Reputation
Rate the quality of this post and help dub-nub reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dub-nub is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-17-2018, 12:39 AM   #2
dub-nub
New Member
dub-nub is on a distinguished road
 
Join Date: Jul 2018
Posts: 2
Default Re: '06 Ion 2.2L needing HELP P0107, P0651

I resolved the issue.

Upon looking further into p2432, this was actually a low circuit fault also. I decided to verify some 5v sources and had 5v at tps, crank, and secondary air valve.

For test I unplugged rhe connector at secondary air valve af BOOM 5v at map sensor. Car cranked up and idled perfect. All gears work.

Going to leave it disconnected and have owners determine the fix path.

Looks like a he secondary air valve shorted itself out and dmade map sensor read 1.4v. Strange.

REWARD EXCELLENCE!

Add to dub-nub's Reputation
Rate the quality of this post and help dub-nub reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dub-nub is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Saturn Sl2 Dtc code P0107 Guidosan S-Series General 1 11-29-2017 06:05 PM
P0107 map bbender S-Series Tech 2 02-28-2017 10:14 AM
P0107 and P0171 bldzrr S-Series Tech 1 08-24-2016 09:48 PM
p0107 DTC Wallyb87 Ion General 2 03-19-2015 05:44 PM
PLEASE HELP!!! Code p0107!!! Acrite3404 S-Series Tech 5 07-12-2014 11:38 AM


All times are GMT -5. The time now is 01:55 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.