SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-28-2016, 06:01 PM   #1
Zakaplaka
New Member
Zakaplaka is on a distinguished road
 
Join Date: Feb 2016
Posts: 1
Attention Really need sime help

When I start my 2000 saturn sl the cars revs to a rediculously high level, and no it's not cold, then continues to rise. Ive juat put a new air idle control sensor in and nothing changed. Also the rediculously high rev levels are when the car starts it automatically ends up around 3000rpm and still continues to rise. Please help me.

REWARD EXCELLENCE!

Add to Zakaplaka's Reputation
Rate the quality of this post and help Zakaplaka reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Zakaplaka is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-28-2016, 06:56 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: Really need sime help

Other than a new iacv, what other maintenance was done, parts replaced and mileage?

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 02-28-2016, 06:59 PM   #3
hoosierrun
Member
hoosierrun is just really nicehoosierrun is just really nicehoosierrun is just really nicehoosierrun is just really nice
 
Join Date: Nov 2015
Location: Seminole, Florida
Posts: 161

2006 VUE 2.2L
Default Re: Really need sime help

That is often caused by a vacuum leak. Check for any hoses disconnected (breather, power brake booster, or any others that go into the intake).

Also, make sure the gasket under the throttle body is good and that the throttle body bolts are not loose.

Any codes?

...
John.... 2006 Saturn Vue, 2.2, 186,000 miles Recently junked out - (threw a rod)

REWARD EXCELLENCE!

Add to hoosierrun's Reputation
Rate the quality of this post and help hoosierrun reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
hoosierrun is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:06 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.