SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 02-05-2009, 06:01 PM   #1
SaturnJon
Junior Member
SaturnJon is on a distinguished road
 
SaturnJon's Avatar
 
Join Date: Aug 2008
Location: Rice Lake, Wisconsin
Posts: 20

2000 SL
Default Fixed "Camshaft Position Sensor" Engine Light

I am posting this in a new thread so that it may help others who have the "Camshaft Position Sensor" code come up.

I am not an expert by any means, and have heard here that the car doesn't have a camshaft position sensor. After some research here and by using the search function, some posited that it may be dirty ignition system/coil contacts, plugs, or wires.

Well, I took apart the coil packs and the ignition module (a 10 minute job) and cleaned every single inch of the contacts and the little round brass looking holes the screws go in to. I took a little sandpaper and lightly sanded off any light corrosion and used some QD Electrical Contact Cleaner and put it all back together. I threw on some new cheapo wires and NKG 7755 copper plugs as well.

Fired her up, the code didn't come back, and 200 miles later, still no code. Car is running smoothly, great MPG, and fires right up.

Give it a shot if you have this problem. It took me a total of 30 minutes and cost 29.95 for the plugs and wires.

I love it when a vehicle problem turns out to be an easy fix!
SaturnJon is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-05-2009, 08:19 PM   #2
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: Fixed "Camshaft Position Sensor" Engine Light

The P0341 is usually an easy fix. New plugs and wires, and clean the coil pack usually makes it go away.
OldNuc is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Camshaft position sensor DTC fixed now the car pings! TunasTwins S-Series Tech 13 09-09-2009 11:57 PM
Code says "Camshaft Position Sensor" is bad SaturnJon S-Series Tech 15 02-05-2009 01:34 PM
SES light, "clutch pedal position 2 sensor" saturrn Ion General 4 02-08-2007 11:53 PM
Camshaft position sensor SES light ThePassenger S-Series Tech 4 05-05-2006 12:01 PM
DTC Code 341 "Camshaft Position Sensor"? staffordgt S-Series General 1 09-29-2005 07:46 PM


All times are GMT -4. The time now is 07:10 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.