SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 06-22-2008, 11:27 PM   #1
3500srw
Member
3500srw is on a distinguished road
 
3500srw's Avatar
 
Join Date: Mar 2008
Location: Southern, WI
Posts: 84

1999 SL
Default P0304 has me confused?

First a little background: I bought the car in March this year. It had 4 DTCs EGR and mis-firing #4 cylinder codes. I tried to clean the Egr but ended up buying a new one. I put on new plug wires and new plugs. I carefully cleaned the Ignition module and coil packs used corrosion preventive dressing and all. All codes were gone and all has been well for the past 2 months. I've even used a couple bottles of Chevron Techron fuel cleaner in that time and have logged 7000 miles. The last bottle was about 3 tanks ago. The car has been getting 40-42 mpg highway. All was fine until today!!

I started the car and immediately noticed unusual vibs coming from the engine. I got out the drive way and drove a little bit and turned around and parked it. P0304 is the only code present which is "mis-firing of #4 cylinder" I took the ignition coil packs apart from the ign. module again and cleaned it again. I have lightly cleaned the throttle body(sprayed a 1/8 of a can while it was running). I switched the coil packs to see if the location of the mis-fire would change, nada! I check for spark and it has spark. Anyone have any ideas?

Thanks in advance
...
1999 Saturn SL SOHC, 5 speed, 272,500 miles....
3500srw is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-23-2008, 05:53 AM   #2
tech360
Junior Member
tech360 is on a distinguished road
 
Join Date: Nov 2004
Posts: 21
Default Re: P0304 has me confused?

Try swapping the #4 injector with another one and see if the misfire follows it. Otherwise, you need to take a compression test.
tech360 is offline   Reply With Quote
Old 06-23-2008, 08:19 AM   #3
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,945
 

2003 L-Series 3.0L Sedan
Default Re: P0304 has me confused?

Have you done the campaign for the infamous engine coolant temperature sensor (ECTS) replacement? The original fails and leaves the engine running rich all the time; fouling plugs, wasting gas, creating odd running problems, messing up the EGR valve with excess carbon, misfiring, etc.. Look in the How-to library's first two posts about the coolant sensor and its two-wire connector. Its a must read!
...
VCX NANO
fdryer is offline   Reply With Quote
Old 06-23-2008, 10:21 AM   #4
3500srw
Member
3500srw is on a distinguished road
 
3500srw's Avatar
 
Join Date: Mar 2008
Location: Southern, WI
Posts: 84

1999 SL
Default Re: P0304 has me confused?

I swapped #3 and #4 spark plugs to see if it was a bad plug. It runs a little better but still has mis-fire on #4. The #3 plug looked perfectly normal but the #4 plug looked fouled. Problem stayed on #4 cylinder. I will try swapping injectors now.

Coolant temp sensor seems to read correctly according to my scan tool. The dash gauge is reading normal as well.
...
1999 Saturn SL SOHC, 5 speed, 272,500 miles....
3500srw is offline   Reply With Quote
Old 06-23-2008, 01:26 PM   #5
3500srw
Member
3500srw is on a distinguished road
 
3500srw's Avatar
 
Join Date: Mar 2008
Location: Southern, WI
Posts: 84

1999 SL
Default Re: P0304 has me confused?

After removing the fuel rail, it was very clear why # 4 was mis-firing.... about an 1/8" of white crud covering the orfices in the injector. I cleaned it but only one orfice appeared to be clear. I put it back together hoping it would clean it self out the rest of the way(wishful think), it ran a little better but still not normal. The other 3 injectors were very clean and clear. I ordered a new injector and fuel filter today.
Thanks all, I'll let you know what happens next.
...
1999 Saturn SL SOHC, 5 speed, 272,500 miles....
3500srw is offline   Reply With Quote
Old 06-23-2008, 08:48 PM   #6
nivlem7
Advanced Member
nivlem7 is on a distinguished road
 
Join Date: Sep 2007
Posts: 582
Default Re: P0304 has me confused?

Quote:
Originally Posted by 3500srw View Post
Coolant temp sensor seems to read correctly according to my scan tool. The dash gauge is reading normal as well.
If it hasn't been replaced, it needs a new brass-tipped one that will last for the rest of the life of the car. Less than $15 at Advance or Autozone.

It may be working o.k. NOW, but when it leaks, it could ruin the ECTS connector as well. It's time well spent (about 10 minutes - you sound like the handy type) to replace it now.
nivlem7 is offline   Reply With Quote
Old 06-23-2008, 10:35 PM   #7
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: P0304 has me confused?

Quote:
Originally Posted by 3500srw View Post
After removing the fuel rail, it was very clear why # 4 was mis-firing.... about an 1/8" of white crud covering the orfices in the injector. I cleaned it but only one orfice appeared to be clear. I put it back together hoping it would clean it self out the rest of the way(wishful think), it ran a little better but still not normal. The other 3 injectors were very clean and clear. I ordered a new injector and fuel filter today.
Thanks all, I'll let you know what happens next.
You might want to consider spending the $75.00 + shipping to get them cleaned and rebuilt. Growing mushrooms on the ends is not a good sign that all is OK inside.
OldNuc is offline   Reply With Quote
Old 06-23-2008, 11:13 PM   #8
rc1488
Master Member
rc1488 has a spectacular aura aboutrc1488 has a spectacular aura about
 
Join Date: Jun 2007
Location: Carmel, NY
Posts: 5,661
 

1997 SL2
1995 SC2
Default Re: P0304 has me confused?

First: Post your vitals!!! Having this in the beginning of your thread is unbelievably important!

According to your profile you have a '99 SL. Im going to assume this is the car your thread is about.

Check your intake manifold gasket. Tho its more common on 3rd gen SOHC cars, it hasnt been limited to those years and i would suspect you have the issues especially if you have a late '99. Spray some carb cleaner around the gasket at each cylinder and see if the idle changes. If it does...you found your issue. Good luck!
rc1488 is offline   Reply With Quote
Old 06-24-2008, 03:37 AM   #9
3500srw
Member
3500srw is on a distinguished road
 
3500srw's Avatar
 
Join Date: Mar 2008
Location: Southern, WI
Posts: 84

1999 SL
Default Re: P0304 has me confused?

Quote:
Originally Posted by nivlem7 View Post
If it hasn't been replaced, it needs a new brass-tipped one that will last for the rest of the life of the car. Less than $15 at Advance or Autozone.

It may be working o.k. NOW, but when it leaks, it could ruin the ECTS connector as well. It's time well spent (about 10 minutes - you sound like the handy type) to replace it now.
It has a brass tipped one now. I doubt it has ever been changed, nothing else has been on this car I will get a new one! Thanks for the tip.

Quote:
Originally Posted by OldNuc View Post
You might want to consider spending the $75.00 + shipping to get them cleaned and rebuilt. Growing mushrooms on the ends is not a good sign that all is OK inside.
Where can I get them cleaned and rebuilt?

Quote:
Originally Posted by rc1488 View Post
First: Post your vitals!!! Having this in the beginning of your thread is unbelievably important!

According to your profile you have a '99 SL. Im going to assume this is the car your thread is about.

Check your intake manifold gasket. Tho its more common on 3rd gen SOHC cars, it hasnt been limited to those years and i would suspect you have the issues especially if you have a late '99. Spray some carb cleaner around the gasket at each cylinder and see if the idle changes. If it does...you found your issue. Good luck!
Your assumption is correct. The problem car is a 1999 Saturn SL 1.9L SOHC 5 Speed. I will check the intake gasket in the AM. Thanks

My BIGGEST problem now is getting to work...My truck is in the body shop getting fixed from a deer running into the drivers side front and rear door. I have no wheels, relying on friends now. What a time to break down
...
1999 Saturn SL SOHC, 5 speed, 272,500 miles....

Last edited by 3500srw; 06-24-2008 at 03:51 AM.
3500srw is offline   Reply With Quote
Old 06-24-2008, 09:33 AM   #10
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,694
 

1998 SC2
Default Re: P0304 has me confused?

No matter how large the personal motor pool they will all quit working at the same time.


Injectors. These are the sources for both new and clean and flowtest/refurbish service.
Brand new BOSH injectors.
http://www.fiveomotorsport.com/Injector_SetsSATURN.asp

Clean and flow test.
http://www.witchhunter.com/
OldNuc is offline   Reply With Quote
Old 06-24-2008, 11:45 AM   #11
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,714
 

1996 SW2
Default Re: P0304 has me confused?

Quote:
Originally Posted by 3500srw View Post
It has a brass tipped one now. I doubt it has ever been changed, nothing else has been on this car I will get a new one! Thanks for the tip.
If it has a brass-tipped one now, it has, by definition, been changed. Your 1999 Saturn came from the factory with a resin-tipped ECTS. Brass-tipped replacement should last the life of the car; no need to go out and get another one.
madpogue is offline   Reply With Quote
Old 06-24-2008, 12:01 PM   #12
3500srw
Member
3500srw is on a distinguished road
 
3500srw's Avatar
 
Join Date: Mar 2008
Location: Southern, WI
Posts: 84

1999 SL
Default Re: P0304 has me confused?

I removed the fuel rail again today and tried to clean the injector again, This time I soaked the injector in carb cleaner for an hour. Only fuel in/out were immersed, not the electrical part. When I put it back together I switched #1 and #4 injectors...now #1 cylinder is mis-firing. So now, I positively know it is the injector.

OldNuc,
I need to get it up and running asap. I like the cleaning/testing injector service, but don't have the time now. I am still going to replace just the one injector for now. If I have injector problems again I will be sending them to be cleaned. Should I keep the bad oem injector in case(so I have a matched set) or turn it in for the core($25) on the replacement I'm getting? (reman. 1 year warranty $55)

I did spray carb cleaner around the intake gasket, while I had it running, there are no leaks there.

madpogue,
Thanks for the info.
...
1999 Saturn SL SOHC, 5 speed, 272,500 miles....

Last edited by 3500srw; 06-24-2008 at 12:10 PM.
3500srw is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to Diagnose a P0304 Problem saturn rings S-Series Tech 61 12-12-2009 07:02 AM
codes po171,p0304,p0446 what could it all mean chevotass Ion Tech 5 03-28-2009 11:28 PM
Trouble Code P0304 & P0420 thaiwebb S-Series Tech 0 07-07-2008 10:11 AM
P0304, P0341, P0410 codes all at once nitsua y zarc S-Series Tech 2 03-17-2008 07:23 PM
P0304 Code (out of ideas) mike_245 S-Series Tech 13 03-13-2008 03:28 AM


All times are GMT -4. The time now is 07:08 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.