SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-16-2012, 04:53 PM   #1
bobbyegan
New Member
bobbyegan is on a distinguished road
 
Join Date: Mar 2012
Posts: 1
Default 2002 sl2 stutter/stall

I have a 2002 saturn sl2. I just changed the plugs and wires, changed the fuel filter, put a new ects in it, and a new egr valve. The car now stutters when i push the gas! It idles fine, but when i push the gas to take off, it stutters like it's not getting gas and sometimes stalls. It only happens after it warms up. Even when i'm cruising at 60mph, and i press on the gass it will studder.
trying to locate the map sensor so i can clean the port, but i can't locate. there is a tps and something that looks like it right next to it on the throttle body, and there is kind of a rectangle thing below both these units with a plug, but i do not see any bolts to disconnect.

any help would be great, it's definately wearing on the car, and me.

REWARD EXCELLENCE!

Add to bobbyegan's Reputation
Rate the quality of this post and help bobbyegan reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bobbyegan is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-16-2012, 05:13 PM   #2
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,899
Default Re: 2002 sl2 stutter/stall

Check to make sure your plug wires are on the coils correctly, specifically #1 and #4 wires.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 SL2 with hesitation and stall problem Flint S-Series Tech 9 03-09-2012 11:08 AM
1992 SL1, occasional stutter and stall at idle captsam S-Series Tech 1 01-30-2012 01:39 AM
2002 Vue Low Idle, Hard Start, Stall Naloomi Vue Tech 8 06-21-2010 12:51 PM
2002 SL1 Sputtering Idle / Stall Issues SkippyThorson S-Series Tech 4 04-17-2010 03:11 PM
1994 SC2 Stutter/Bog/Stall vip3r87 S-Series Tech 10 06-30-2008 08:17 PM


All times are GMT -5. The time now is 05:20 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.