SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-10-2009, 01:00 AM   #1
bikercub
New Member
bikercub is on a distinguished road
 
Join Date: Sep 2009
Posts: 8

1998 SL2
Default Car starts rough when cold

I have had a problem with starting my car after it sits for any length of time (over night, after working all day, etc.) Once it is warmed up, it starts fine. I bought the car new in April 1998 and it has 67,275 miles on it. I have to give it quite a bit of gas for several seconds or it dies, then it takes awhile before I can start it again! And boy does that smell up the garage.

I have had "backyard" mechanics as well as mechanics in shops look at my car and several things have been replaced but the problem still exists. Everyone says the car runs fine...which it does once warmed up, they aren't around when I start it in the morning or after getting off work! Also, it has "cut out" on me lately at times when trying to pull out quickly in front of someone, so I have to make sure I have LOTS of space and time to do that.

I've had the crankshaft position sensor replaced in Nov. 08 and this year I've had the EGR valve, fuel filter, O2 sensor, IAC Valve, throttle body, and plugs replaced. I have had problems in the past with clogged fuel injectors, but they are fine now and I only use Chevron gas nowadays.

I read a thread that suggested ECTS be replaced, so I bought that today and will have that put in on Saturday, but the guy who is going to do it says he doesn't understand how that will fix the problem and neither do I but I am just going off some of the threads I've read out here. I also will replace my battery on Saturday.

Does anyone have any other suggestions or ideas????? I've spent way too much money on this issue and can't afford too much more!

Thanks.

REWARD EXCELLENCE!

Add to bikercub's Reputation
Rate the quality of this post and help bikercub reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bikercub is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-10-2009, 10:09 AM   #2
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 11,966
 

2002 SC2
1998 SL2
Default Re: Car starts rough when cold

Quote:
Originally Posted by bikercub View Post
I read a thread that suggested ECTS be replaced, so I bought that today and will have that put in on Saturday, but the guy who is going to do it says he doesn't understand how that will fix the problem and neither do
The ECTS feeds a signal to the PCM (Power Control Module, engine computer), which controls many things including the amount of fuel fed to the engine.

Garbage in, garbage out How did your plugs look when you removed them?

It may or may not fix your problem, but it needs to be done to have a good baseline. Check the connector, too, for corrosion.

...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 124k DD
7/2010 Craigslist white 1997 SC2 project
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles

REWARD EXCELLENCE!

Add to alordofchaos's Reputation
Rate the quality of this post and help alordofchaos reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
alordofchaos is offline   Reply With Quote
Old 10-14-2009, 11:05 PM   #3
bikercub
New Member
bikercub is on a distinguished road
 
Join Date: Sep 2009
Posts: 8

1998 SL2
Default Re: Car starts rough when cold

Wow, I can't believe that the ECTS fixed the car! I've been waiting to reply until I gave the car a chance to "screw up" and it hasn't! Now whenever I have car problems, I will come out to this site first!

REWARD EXCELLENCE!

Add to bikercub's Reputation
Rate the quality of this post and help bikercub reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bikercub is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car idles rough when cold start saturn95 S-Series General 13 10-14-2010 04:58 PM
1997 SL2 Rough Starts KingRex S-Series Tech 3 05-24-2009 06:33 PM
96 SL1 car starts rough hawaiipens S-Series Tech 9 03-05-2006 10:57 PM
97 SL1 Cold Starts vs. Hot Starts and ECT edk S-Series General 7 02-23-2005 01:33 AM
Starts in cold then dies, then starts again ??? Scyan S-Series Tech 10 02-16-2003 10:16 PM


All times are GMT -4. The time now is 06:45 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.