SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-14-2006, 08:45 PM   #1
Bluesideup
Junior Member
Bluesideup is on a distinguished road
 
Join Date: Oct 2005
Posts: 49
Default New PS Pump Whining! Please help!

Our '00 SL1 with 110K on it has developed a whining noise over the past 15K or so. I pulled off the belt and verified it was something with the accessory drive. It is fairly subtle, sounds like the supercharger on a Mini.

I started by replacing the tensioner which did not solve it.

Then the alternator started to go (charging problems) and I replaced that, still have the whining.

So now I have replaced the power steering pump and still have the noise. The reason I went with the pump vs. the idler pulley is because it felt loose. Well in hindsight I should have left the stupid pump on the car.

Now I've replaced the power steering pump and it has a new whining noise. I'm sure you all have heard the noise a dying power steering pump makes, well that's what the car sounds like now in addition the original noise.

When I replaced the pump I left the return hose off and plugged the fitting on the reservoir. I started the car briefly and kept adding fluid until clear fluid came out of the return.

Then I reconnected the return and topped off the reservoir. With the car off I turned the wheel back and forth a bunch of times to get any residual air out. I started the car and turned left and right a couple times. I topped off the reservoir and it is still whining but not quite as bad.

Do you think I got a bad pump? Is there anything else I can do to bleed the system? Do you think the original whining noise is from the idler pulley?
Bluesideup is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whining on acceleration Saturngirl4ever Vue Tech 20 10-20-2009 08:19 AM
whining noise soontobespeed S-Series Tech 5 06-13-2009 08:12 PM
Power Steering Pump and Alternator Problems - Whining noise and Burning Smell batmobile S-Series Tech 14 08-03-2006 12:29 PM
Whining noise from power steering pump/reservior andybot2000 S-Series Tech 4 09-27-2004 04:36 PM
Whining SL2Dreams S-Series General 7 12-24-2003 04:46 PM


All times are GMT -4. The time now is 09:51 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.