SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-21-2012, 10:25 PM   #1
PlasticCarsRock
Master Member
PlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the rough
 
PlasticCarsRock's Avatar
 
Join Date: Dec 2005
Location: Brookline, MA
Posts: 4,317
 

1995 SL2
Default a/c compressor whine

I have another unusual Saturn a/c problem. This is a second generation S-Series (not sure the year--it's not my car). The owner replaced the compressor and condenser trying to fix a poor performance issue. I think he tried a junkyard compressor and then a parts store rebuilt, with no improvement. I replaced the original compressor, the receiver dryer, and the TXV, which was the cause of the original complaint. I added the correct amount of oil to the receiver, but left the compressor alone (he had not drained it). He claims he flushed the system and added the correct amount of oil, but the only thing I'm sure of is that he's fairly incompetent, when it comes to a/c work. I suggested that I re-flush the system and re-add the oil, but he declined.

The a/c works fine now: I did a full performance test on a warm night and a hot day, and it performs exactly to spec (vent temperatures at various ambients are all at the low end of the provided ranges, etc).

However, apparently now the compressor makes a whining noise when accelerating, only "at night". The noise goes away as soon as the button is pressed to turn off the a/c, so that should rule out an alternator noise (the fan is still running for a little while, and the clutch draw is not significant).

I assume the reason for the noise only taking place at night when accelerating is that the compressor is exceeding its normal displacement for the conditions. When it's cool at night, the compressor is at or near its minimum displacement, at higher rpms. When you slow down, displacement increases to compensate for the slower speed, and as you then accelerate, the displacement is a bit excessive for a moment, until it can re-adjust to a lower displacement. It does not whine at constant speed, so I believe the variable displacement feature of the compressor is functioning normally. Could the system be low on oil, and only causing a noise when the low side pressure is dropping too low to carry any oil?

I haven't heard the noise myself, but I hope to put a set of gauges on it soon.

The system is charged correctly and does not leak.

Any ideas?

Thanks!
...
High compression build: .033" shaved/ported head, flat-faced valves; gen3 rods, pistons, tie-plate; OE header, custom CAI, SDA street cams with adjustable sprockets, WBO2, SAFCII, LSD. ASE A1-A8+L1
PlasticCarsRock is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Compressor Question: Is my compressor bad? TIMSPEED S-Series Tech 8 04-18-2009 12:03 AM
Whine ocatrina L-Series Tech 2 08-05-2008 03:22 PM
Whine DHOOP S-Series Tech 6 04-17-2007 05:42 PM
vti whine fix walt Vue General 1 10-18-2003 06:43 PM
My car has a odd whine at low rpm's Mongoose159 Mods and Performance 16 12-10-2002 01:59 AM


All times are GMT -4. The time now is 12:48 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.