SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 06-20-2009, 12:09 PM   #1
ralfie
New Member
ralfie is on a distinguished road
 
Join Date: Jun 2009
Posts: 4
Default AC - 95 SL2 Not functioning

I have a 95 SL2, that has been running great. The AC just quit running, had it serviced last summer and it ran fine.

This spring I turned it on and no cold air.

Checked the fuses, and even rotated the relays (all 3 the same on this model) no change. I jumped the clutch from the battry and it ran...I'm thinking the only thing left is a short in the wire someplace and I'm not looking forward to tracing the wire bundle and taking the front end apart...anyone have this problem and got it resolved?
ralfie is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-20-2009, 12:24 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 44,014
 

2003 L-Series 3.0L Sedan
Default Re: AC - 95 SL2 Not functioning

Quote:
Originally Posted by ralfie View Post
I have a 95 SL2...the AC just quit running, had it serviced last summer and it ran fine. This spring I turned it on and no cold air....
No need to check any wiring issue as you're looking in all the wrong places. You have a LEAK that won't get fixed by annual recharges. Find the source of the leak and decide if you can do the mechanical repairs and/or leave this to a pro. To fond the source of the leak; http://www.saturnfans.com/forums/showthread.php?t=80107
...
VCX NANO
fdryer is offline   Reply With Quote
Old 06-23-2009, 11:38 AM   #3
ralfie
New Member
ralfie is on a distinguished road
 
Join Date: Jun 2009
Posts: 4
Default Re: AC - 95 SL2 Not functioning

Hey thanks bro, I looked in the Haynes manual and it suggested that it was more than just a wiring problem, but I got tired of troubleshooting...
ralfie is offline   Reply With Quote
Old 06-23-2009, 12:51 PM   #4
Col.FUBAR
Advanced Member
Col.FUBAR is on a distinguished road
 
Col.FUBAR's Avatar
 
Join Date: Jun 2009
Location: Kalamazoo, MI
Posts: 531
 

1994 SC2
1995 SL2
Default Re: AC - 95 SL2 Not functioning

Yes as fdryer said you most likely have a leak. The compressor has a built in safety switch that will not allow the A/C clutch to engage if it detects too low a pressure otherwise the compressor could be damaged.
Col.FUBAR is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
speedo not functioning molbly S-Series Tech 9 06-18-2008 09:44 PM
OnStar Not Functioning Bluealien Aura General 9 04-01-2008 01:43 PM
Odometer/ Tripometer not functioning leskiss S-Series Tech 1 11-27-2005 08:29 PM
instrument panel non functioning brotherhay S-Series General 6 10-30-2003 03:02 AM
instrument panel non functioning brotherhay S-Series Tech 2 10-25-2003 09:19 PM


All times are GMT -4. The time now is 03:48 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.