SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-19-2013, 08:49 PM   #1
mc9391
New Member
mc9391 is on a distinguished road
 
Join Date: Nov 2013
Posts: 2
Default back turn signal/ brake light wont work.

Hello all, new user here. I drive a 2002 Saturn L300, recently my back turn signal and back brake light quit working. The bulbs are good, i tested em out. Now, the front left turn signal is working, its just flashing really fast. I dont think its the fuse since the front turn signal is fine, i cant seem to figure out the problem though. I got a new bulb and changed it, so i figure it has something to do with the connection or something. Has anyone encountered this problem before? How did you fix it? Please help.

REWARD EXCELLENCE!

Add to mc9391's Reputation
Rate the quality of this post and help mc9391 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mc9391 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-23-2013, 12:42 AM   #2
abanerus
Member
abanerus has a spectacular aura aboutabanerus has a spectacular aura about
 
Join Date: Dec 2012
Location: North NJ
Posts: 107

2002 L-Series 2.2L Wagon
Default Re: back turn signal/ brake light wont work.

Quote:
Originally Posted by mc9391 View Post
Hello all, new user here. I drive a 2002 Saturn L300,

1. recently my back turn signal and back brake light quit working.
2. The bulbs are good, i tested em out.
3. Now, the front left turn signal is working, its just flashing really fast. I dont think its the fuse since the front turn signal is fine, i cant seem to figure out the problem though.
4. I got a new bulb and changed it, so i figure it has something to do with the connection or something. Has anyone encountered this problem before? How did you fix it? Please help.
1. Okay first off check all bulbs & sockets, clean all connections & pry up any depressed connection surfaces on the impacted lights. The brake lights have double filaments.
2. Good job.
3. This happens if your rear left turn signal light is disconnected /fused.
4. Changing the front left turn signal bulb will not help.

REWARD EXCELLENCE!

Add to abanerus's Reputation
Rate the quality of this post and help abanerus reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
abanerus is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sc turn signals and hazards wont work faf112 S-Series Tech 4 03-20-2016 07:07 PM
Turn signal doesn't work, but bulb is good d_rock Ion Tech 1 08-17-2013 05:42 AM
help!! ac wont work and fans don't turn on tinybubbles46 L-Series Tech 2 09-01-2012 04:46 PM
Rear left turn signal doesn't work Saturn2003wagon L-Series Tech 6 08-18-2012 02:32 PM
My turn signal wont work! Help please? justandgirl Ion Tech 13 10-04-2010 11:09 AM


All times are GMT -4. The time now is 10:39 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.