SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General

Reply
 
Thread Tools Display Modes
Old 03-29-2010, 08:02 PM   #1
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Car stalls while idling once it's warm, help!

Some background stuff: car is a 1996 Saturn SL2 1.9L (automatic) with only 92,000 miles on it. I just had the spark plugs, wires, fuel filter, and oil changed. Fluids were topped off, air filter is clean, and I regularly (about every other month) run the strong STP fuel injector/carburetor cleaner through.

I apologize for writing a book here, but if you can help me I'd really appreciate it.

For the past few weeks when I've been driving my car its stalled at stoplights where I have to sit idling for about 45 seconds to a minute or so. It only tends to do this once per day, mainly when the car is at its warmest. It idles at around 700-750 RPM when in drive (or neutral) and stopped. RPM's slowly creep down to around 700 and then it drops below 400-500 and will either stall from here or shoot up to 1300ish and level out (then stall 10 seconds later if I'm not giving it some gas by then). It never stalls when I'm on the gas. No codes showing for fuel pump or injectors and checking the fuel pressure showed it's right where it needs to be, and the voltages from the throttle position sensor are reading right in their correct range too.

As a way to keep from stalling I've been putting it in neutral and giving a little bit of gas every couple seconds and that seems to work fine, but this needs fixed! Exact error codes I'm getting are P0341 (camshaft sensor), P0404 (EGR), and P0405 (EGR).

Now more info: camshaft sensor error has been there for at least a couple years, I've been told s-series don't have one and that it tells the position of the camshaft by how the car fires in it's 4th piston. Someone who said they'd worked on Saturns for 15 years says this is the timing belt throwing this error (which is why my car sometimes won't start, then takes 10 minutes to start after failing, but that's an entirely different problem, I hope. The car has done this for at least a couple years, if not more).

That just leaves the 2 EGR errors. We removed it, cleaned it, and didn't think it was very dirty, put it back on, and now my Service Engine Soon light is always on, as opposed to the random on/off it used to do. Nothing we do has helped, could the timing belt be the problem with the camshaft, and have worn more and caused this now? Or maybe it's only the EGR, or something is messing up the EGR itself. If you have ideas just throw 'em out there.

One more thing, while testing the throttle position sensor the engine was loping at full throttle, even though it was giving the proper voltage, it doesn't lope while idle though. Too many problems!

Thanks,
Josh
joshjames023 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-29-2010, 08:39 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,945
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

Replace (if original) the coolant sensor and thermostat (with a 195F one) and thoroughly clean the ignition module and both coils of any corrosion. This should take care of a faulty coolant sensor running the engine rich. If the stalling continues, move on to trying the egr valve block off.

Use either a soda can gasket or two coins to block off the egr valve ports completely; cleaning doesn't prove anything if the pintle valve erratically sticks and still allows exhaust gases into the intake manifold at the wrong time, like idling. Now drive and if engine power returns, either clean the egr valve some more or replace it.
...
VCX NANO
fdryer is offline   Reply With Quote
Old 03-29-2010, 08:58 PM   #3
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Good idea with the coolant, I forgot to mention that I've had that high coolant temp/low coolant/low automatic trans-axle fluid light on and off lately even though the fluid and coolant are both filled to full. I'll get back to my mechanic and try this right away, thanks!
joshjames023 is offline   Reply With Quote
Old 03-30-2010, 11:37 AM   #4
DonP
Master Member
DonP will become famous soon enoughDonP will become famous soon enough
 
Join Date: Jun 2006
Location: VA
Posts: 3,582
 

1995 SL2
Default Re: Car stalls while idling once it's warm, help!

A bad or failing ECTS can cause all sorts of driveability issues. Once you have confirmed that the ECTS (replae if the old type) and the connctor are in good condition you can move on to other diagnostics.
DonP is offline   Reply With Quote
Old 04-02-2010, 11:10 PM   #5
adventureoflink
Master Member
adventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura about
 
adventureoflink's Avatar
 
Join Date: Apr 2009
Location: 255.255.255.255
Posts: 6,853

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Quote:
Originally Posted by joshjames023 View Post
Now more info: camshaft sensor error has been there for at least a couple years, I've been told s-series don't have one and that it tells the position of the camshaft by how the car fires in it's 4th piston. Someone who said they'd worked on Saturns for 15 years says this is the timing belt throwing this error (which is why my car sometimes won't start, then takes 10 minutes to start after failing, but that's an entirely different problem, I hope. The car has done this for at least a couple years, if not more).
Buddy, I'd RUN and NOT walk from that mechanic, and here's why:

1) Our Saturns use Timing CHAINS and NOT belts (thank goodness ). you'd think he'd learn this in the whole 15 years he's been "working on" them.
and 2) did you ever change your spark plugs and wires (using NGK copper/decent mid-price wire set)? generally when P0341 hits, it's time for a plug/wire replacement.

Having said that, you get a flashing temp light with the reservior full? then it's time to drain the coolant, unbolt the reservior, and clean it out. Richpin has a video on it.

http://www.youtube.com/user/richpin06a
...
97 SL2
DOB: 3/19/97
Date Obtained: 5/30/07
Status: Alive, 1/2 exhaust

2004 Merc G.Marquis GS
DOB: 2/4/04
Date Obtained: 7/6/12
Status: Alive, no heat
adventureoflink is offline   Reply With Quote
Old 04-03-2010, 11:08 AM   #6
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Haha ok, well he said chain, I just said belt for some reason, that was just a guy on yahoo answers before I posted the question on here. But yeah I replaced the plugs and wires with a decent set and made sure they're all plugged in the appropriate spot so that's good for now. The temp light isn't the only problem though, I think the first guy may have a point with the thermostat and coolant temp sensor because I reset the codes yesterday and on my way to work (10 miles just about) the service engine soon light stayed off, but the coolant temp reached half. On the way home the light came back on, but the temp barely hit above a quarter. To me that sounds like it's reading the temp as too high and then flooding in too much coolant like he said. I'm willing to try anything to fix this at this point though so thanks for the link, that guy has a lot of useful videos!
joshjames023 is offline   Reply With Quote
Old 04-03-2010, 11:45 AM   #7
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,945
 

2003 L-Series 3.0L Sedan
Default Re: Car stalls while idling once it's warm, help!

Being new around here until more familiar with the wealth of information, please reply whether or not the ects and thermostat were replaced as these are the two most outstanding issues with older S-series engines having these original parts that fail/wear out. Speculating does nothing and these two parts are the least costly items to replace. Both will improve starting performance and overal engine running immediately. The next would be a general cleaning of the throttle body (if it hasn't been done) to degrease any sticking tendencies from built up crud.
...
VCX NANO
fdryer is offline   Reply With Quote
Old 04-03-2010, 02:12 PM   #8
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Alright well the thermostat and coolant temp sensor were just replaced today. We drove around for a while and no codes have come up yet and the idling is fine, I will update you on whether or not it starts acting up again. One thing though, after we had everything back in order and started the car we let it sit in park idling for about 15 minutes and it just shut off on its own, but started right back up. Can I ask what exactly is the ECTS, and where can I find it on the car? I didn't see it listed for parts when I searched for it.

Thanks guys,
Josh
joshjames023 is offline   Reply With Quote
Old 04-03-2010, 03:49 PM   #9
macbox
Senior Member
macbox will become famous soon enough
 
macbox's Avatar
 
Join Date: Jul 2006
Location: Minneapolis, MN
Posts: 1,226
 

1995 SC2
1995 SC2
Default Re: Car stalls while idling once it's warm, help!

Quote:
Originally Posted by joshjames023 View Post
Can I ask what exactly is the ECTS, and where can I find it on the car?
The coolant temp sensor and the ECTS are the same thing, ECTS means Engine Coolant Temperature Sensor. Make sure you use _Brass_ type when replacing the old one.
...
#4, "Betty" 1995 SC2m, 167K, rebuilt engine, Garage Queen. Still squeaks and rattles but goes like hell.
macbox is offline   Reply With Quote
Old 05-25-2010, 08:12 PM   #10
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Well my car has been in my family since new and it's had this problem for at least a few years, when it won't start it's not that you have to leave the key in for 10 minutes, the car just has to sit for 10 minutes. It doesn't matter how many times you turn the key to on and let the pump run, it just won't start until you let it sit. I'm just trusting this guy because he guarantees his work and warranties it for 18 months or 18000 miles...I have pretty much eliminated everything except a fuel issue at this point...I really don't know much about cars but I've done everything these guys have suggested. I'm pretty sure it's just a really inconsistent pump that occasionally acts up. It's in his hands now and it should be back tomorrow so I'll post again with the results, hopefully they're good!
joshjames023 is offline   Reply With Quote
Old 05-30-2010, 08:59 PM   #11
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Well so far so good, no stalling and the car starts right up now with no waiting, problem now is my coolant leak. Replaced the hose that runs from the top of the reservior and that helped but then found the infamous driver-side tank crack in the radiator...

I bought some silicon sealing stuff and covered the crack and I have to say the stuff works really well but I'm told the pressure will eventually just blow it out of the way and continue to leak. Most likely going to order a new radiator tomorrow and just put it in myself, I'm not dropping another $500 like I just did on a mechanic. Only thing is that on these forums people say the Auto Zone Spectra brand tends to fail and the Delphi and Silla (I think it's those 2 brands) are the best. Anyone know who sells these? Or is the Spectra thing nothing to worry about?

Thanks,
Josh
joshjames023 is offline   Reply With Quote
Old 05-31-2010, 04:03 PM   #12
adventureoflink
Master Member
adventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura aboutadventureoflink has a spectacular aura about
 
adventureoflink's Avatar
 
Join Date: Apr 2009
Location: 255.255.255.255
Posts: 6,853

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

I remember someone here posting a link to the Delphi radiator on Amazon..
...
97 SL2
DOB: 3/19/97
Date Obtained: 5/30/07
Status: Alive, 1/2 exhaust

2004 Merc G.Marquis GS
DOB: 2/4/04
Date Obtained: 7/6/12
Status: Alive, no heat
adventureoflink is offline   Reply With Quote
Old 06-01-2010, 05:09 PM   #13
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Ok I got the new radiator, but on the old one the lower transmission line is really rusted and the top one is in pretty bad shape too, can't get either of them to budge and I nearly destroyed the top one trying to turn it. Can I just pop the upper and lower hoses at the tranny end and remove them still attached to the radiator, then just buy new ones? I found these on the forums: http://www.trademotion.com/partlocat...layCatalogid=0

Then I could just throw those on with the new radiator and refill the trans fluid? They need replaced anyway...just wondering before I pop them out if that's all there is to it, a little pinch clip at the tranny side to remove that entire hose. Any other things to account for? I'd change the fluid while I'm at it, but it's still red and doesn't smell burnt so for now it'd be great just to have my car in one (working) piece.

Last edited by joshjames023; 06-01-2010 at 05:10 PM. Reason: Link Broken
joshjames023 is offline   Reply With Quote
Old 06-01-2010, 05:11 PM   #14
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

Link still doesn't work, but that site sells both the upper and lower trans cooler lines...
joshjames023 is offline   Reply With Quote
Old 11-14-2018, 02:25 PM   #15
MghtySaturn
New Member
MghtySaturn is on a distinguished road
 
Join Date: Sep 2017
Posts: 4
Default Re: Car stalls while idling once it's warm, help!

I am having the same issue with my 1999 Saturn SL1. The car will start fine and idle ok. Once the car gets up to normal operating temperature it stalls. Then will not restart for at least 20 minutes. I have a new egr, catalytic converter, clean throttle body, and new fuel filter/fuel pressure regulator. I do not know what to inspect next. Any hope would be greatly appreciated.
MghtySaturn is offline   Reply With Quote
Old 11-14-2018, 02:28 PM   #16
cgg17
Senior Member
cgg17 is just really nicecgg17 is just really nicecgg17 is just really nicecgg17 is just really nicecgg17 is just really nice
 
cgg17's Avatar
 
Join Date: Mar 2017
Location: Eastern Pennsylvania
Posts: 1,067

1995 SL2
1995 SW2
Default Re: Car stalls while idling once it's warm, help!

Quote:
Originally Posted by MghtySaturn View Post
I am having the same issue with my 1999 Saturn SL1. The car will start fine and idle ok. Once the car gets up to normal operating temperature it stalls. Then will not restart for at least 20 minutes. I have a new egr, catalytic converter, clean throttle body, and new fuel filter/fuel pressure regulator. I do not know what to inspect next. Any hope would be greatly appreciated.
I suggest starting a new thread, as this is 8 years old.
...
1994 Sl2 5spd: First Car, Stock: 56,576 (Totaled 1/10/2018)
1994 Sl1 5spd: Inherited, Stock: 495,000
1995 Sl2 5spd: Retired Daily, Not Stock: 198,000
1995 Sw2 5spd: Daily, Stock: 110,000
cgg17 is offline   Reply With Quote
Old 11-14-2018, 02:33 PM   #17
joshjames023
Junior Member
joshjames023 is on a distinguished road
 
Join Date: Mar 2010
Location: Ohio
Posts: 27

1997 SL2
Default Re: Car stalls while idling once it's warm, help!

I've not had my Saturn in years, but I can say the issues I had with stalling were remedied by replacing the crankshaft position sensor. My car often threw "camshaft" position sensor warnings, but ultimately the crankshaft position sensor replacement stopped my stalling. It's hard to get to, but my dad and I were able to replace it using ramps, $15 for the sensor, and taking about 15 minutes.

As cgg suggested, a new thread is probably a good idea, but I wanted to share my solution. Apologies for not returning to the thread back then. This forum saved me quite a few times with that '97 SL2.
joshjames023 is offline   Reply With Quote
Reply

Tags
egr, idle, sl2, stalls, timing belt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stalls when idling warm mannsjp S-Series Tech 3 03-28-2010 07:52 PM
AC blows warm when idling turbobuick33 S-Series Tech 16 07-31-2008 08:44 PM
93 SL2 AC works but warm when idling 2003MercMaraude S-Series Tech 11 05-28-2008 03:54 PM
saturn stalls after it gets warm? creepyrat S-Series General 26 05-31-2006 06:25 PM
93 sw2- stalls at stop once warm ndsaturn S-Series General 2 09-14-2004 03:45 AM


All times are GMT -4. The time now is 12:47 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.