SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-04-2018, 07:51 PM   #1
Glaciata
New Member
Glaciata is on a distinguished road
 
Join Date: Feb 2018
Posts: 1
Default 2001 Saturn L300 Temp Gauge Issues + Blower Issues Help?

Hello all. New here, trying to see if y'all could assist me with this. I have just recently purchased a 2001 Saturn L300. While for the most part, everything runs great, there are 2 noticeable issues, that occur one after the other. The first issue is that, a little after the engine gets up to temperature (between 1/4 & 1/2) the needle starts jumping all over the place. And while it's doing that, the cabin blower (which is current cranked all the way to heat, because it is winter in Wisconsin, and I need my defrost and heat) will cut off at random intervals, stopping for up to 30 seconds or more, before randomly coming back on. It's most noticeable after longer periods of driving. So my main question is, what gives? Anyone have the same issue, and if so, any solution? Any help would be appreciated.

EDIT: Should mention, it has a 3.0L V6. If that helps at all.

Last edited by Glaciata; 02-04-2018 at 07:58 PM.. Reason: Adding additional info.

REWARD EXCELLENCE!

Add to Glaciata's Reputation
Rate the quality of this post and help Glaciata reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Glaciata is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-04-2018, 09:27 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,293
 

2003 L-Series 3.0L Sedan
Default Re: 2001 Saturn L300 Temp Gauge Issues + Blower Issues Help?

1-The coolant temperature display is driven by the body control module (BCM). The coolant sensor sends signals to the ecm.

2-Remove and check for corroded fuses; left instrument panel fuse block (driver's side footwell) 20A HVAC, underhood fuse block HVAC Blower Motor 40A.

You may be describing two separate problems. The temperature display gets its information from bcm - the ecm receiving sensor signals sends info to the bcm to drive the display. One way to differentiate between ecm and bcm handling the coolant sensor signals is how the engine runs from cold startup all the way to full operating temperature regardless of what the temperature gauge is showing. A normal cold engine startup always starts out with rich fuel mixtures based on all sensors but mainly from the coolant sensor as it has a large effect on the ecm adjusting for fuel mixtures. On cold startup, idle should be around 1200 rpm, gradually lowering back to normal (650 rpm) after a few minutes of driving (without referring to the temperature gauge). This presumes the thermostat isn't faulty and regulating operating temps to around 195F.

Check for an intermittent coolant sensor connection, corrosion on connections, etc.. No one has ever reported sensor failure. An intermittent sensor connection or faulty sensor may create oddball engine running symptoms since the ecm relies on continuous signals to adjust fuel mixtures. In addition, check the intake air temperature sensor, mounted behind the front grille on the driver's side. Although its main role is to display outside temps on the hvac panel (auto climate control), it may affect hvac operation.

Its difficult to determine if the hvac panel or bcm is faulty. The bcm is sitting on top of the glove box and has many programs to run almost all the electronics not associated with the engine (ecm) control module.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 Saturn Vue ECTS/PMS/Temp gauge issues? Lonnie Vue Tech 19 08-02-2016 01:39 AM
2001 Saturn L300 - Steering issues L300v6 L-Series Tech 8 12-17-2014 12:24 AM
2001 SC2 issues - Gas mileage, temperature gauge, and RPM gauge. HawkeyeCB S-Series General 12 01-30-2014 12:39 PM
2001 Saturn L300 - Having Issues, please help... TDFDiesel L-Series Tech 3 10-28-2012 04:05 PM
Temp Gauge & Rear Defroster Issues Mike1969 S-Series Tech 1 08-14-2009 08:08 PM


All times are GMT -4. The time now is 08:37 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.