SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion Tech

Reply
 
Thread Tools Display Modes
Old 08-09-2016, 06:12 AM   #1
VentureForth
Member
VentureForth has a spectacular aura aboutVentureForth has a spectacular aura aboutVentureForth has a spectacular aura about
 
VentureForth's Avatar
 
Join Date: May 2002
Location: Savannah, GA
Posts: 225

2006 ION-3 Sedan
Dizzy 2006 Transmission (?) Issue

Out of the blue, my transmission began shifting hard on my '06 Ion-3. Concurrently, my engine started running rough, and I shouted get a TRAC OFF message. I also got a P507 code. I noticed a leaky gasket, but not too bad. Added 1/2 quart and it ran fine for a day. Next day, rinse and repeat. Finally, I knew I wasn't leaking add much as I was putting in. I have a new gasket on order, but I'm thinking that isn't the issue. Without adding fluid, it started and shifted fine again. I'm not ready to take it on the road until I fix the issue.

Of note, I recently removed and cleaned the throttle body. The wiring harness protective coil was brittle and busted. Maybe I didn't close off the system adequately from ambient air. Maybe the harness is in a bad way. I know this doesn't sound intuitive, but I read where another guy had similar issues when his cam position sensor went out.

Any ideas?
VentureForth is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-09-2016, 08:18 AM   #2
2006 ion2
Master Member
2006 ion2 has a spectacular aura about2006 ion2 has a spectacular aura about2006 ion2 has a spectacular aura about
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,863
 

2007 ION-2 Sedan
Default Re: 2006 Transmission (?) Issue

First, fix the leak. Then double check everything you touched for the tb.
...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.
2006 ion2 is offline   Reply With Quote
Old 08-13-2016, 02:06 PM   #3
VentureForth
Member
VentureForth has a spectacular aura aboutVentureForth has a spectacular aura aboutVentureForth has a spectacular aura about
 
VentureForth's Avatar
 
Join Date: May 2002
Location: Savannah, GA
Posts: 225

2006 ION-3 Sedan
Default Re: 2006 Transmission (?) Issue

Okay, so the answer may surprise those who are not familiar with fly-by-wire vehicles. It turns out that whenever I removed the air and lit from the throttle body to clean the throttle body I opened the butterfly valve with my fingers. The throttle bodies are pretty sensitive. Buy adjusting it manually, I messed up the calibration. Here are the steps to recalibrate your throttle body if it isn't messed up. Turn the key to the on position without starting it. Do not press the accelerator, do not start the engine for at least 30 seconds. That's all I needed to do, and it's working fine now.
VentureForth is offline   Reply With Quote
Old 08-13-2016, 03:58 PM   #4
billysvue
Master Member
billysvue is a jewel in the roughbillysvue is a jewel in the roughbillysvue is a jewel in the rough
 
Join Date: Aug 2012
Location: san diego
Posts: 4,355

2005 VUE 2.2L
Default Re: 2006 Transmission (?) Issue

Quote:
Originally Posted by VentureForth View Post
Turn the key to the on position without starting it. Do not press the accelerator, do not start the engine for at least 30 seconds. That's all I needed to do, and it's working fine now.
I thought the "relearn" procedure is a minute?
...
'05 ,2.2L, FWD,5-speed stick with transaxle death rattle is history,,,
'17 Suby Forester

245216 mi. VUe is off to the dealer auction
I'm a secondhand vegetarian.
Cows eat grass, I eat cows.
billysvue is offline   Reply With Quote
Old 08-13-2016, 04:05 PM   #5
VentureForth
Member
VentureForth has a spectacular aura aboutVentureForth has a spectacular aura aboutVentureForth has a spectacular aura about
 
VentureForth's Avatar
 
Join Date: May 2002
Location: Savannah, GA
Posts: 225

2006 ION-3 Sedan
Default Re: 2006 Transmission (?) Issue

I read 29 seconds. I waited a full minute...
VentureForth is offline   Reply With Quote
Old 08-14-2016, 06:25 AM   #6
VentureForth
Member
VentureForth has a spectacular aura aboutVentureForth has a spectacular aura aboutVentureForth has a spectacular aura about
 
VentureForth's Avatar
 
Join Date: May 2002
Location: Savannah, GA
Posts: 225

2006 ION-3 Sedan
Default Re: 2006 Transmission (?) Issue

It's is still acting up. The key reset keeps working, but I'm sure I screwed up my TPS.
VentureForth is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Repair issue 2006 Vue Rvasaturn Vue General 6 02-19-2016 03:51 PM
2006 3.5L Misfire Issue infinitewisdumb Vue Tech 9 08-18-2015 11:28 AM
2006 Saturn Vue ECM issue APDwife Vue Tech 3 10-05-2012 12:54 PM
2006 ion wiper issue krull1755 Ion Tech 1 12-13-2011 12:33 PM
2006 Starting Issue, HELP Taz GTO Vue General 2 01-11-2010 11:29 PM


All times are GMT -4. The time now is 02:49 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.