SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-28-2019, 04:41 AM   #1
454cid
Member
454cid is a jewel in the rough454cid is a jewel in the rough454cid is a jewel in the rough
 
Join Date: May 2019
Posts: 324
Default idle is low for first second at startup?

2000 SL2 automatic 17X,XXX miles

I've noticed recently that my idle will be low for the first second, or split second, at startup. It makes me think the engine is trying to die, but the PCM quickly makes an adjustment to keep that from happening.

It will often high idle, which I'm assuming is the TPS. Is this momentary low idle at startup also the TPS?

I haven't tried to pull codes recently, and I can do that, but the light isn't on.

...
2000 SL2 Automatic (back on the road) 17X,XXX miles.
1999 Chevy K3500

REWARD EXCELLENCE!

Add to 454cid's Reputation
Rate the quality of this post and help 454cid reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
454cid is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-29-2019, 05:09 PM   #2
454cid
Member
454cid is a jewel in the rough454cid is a jewel in the rough454cid is a jewel in the rough
 
Join Date: May 2019
Posts: 324
Default Re: idle is low for first second at startup?

No one? Well, I guess I'm going to order the TPS, as I'm pretty sure I need it for the high idle issue any way. Rockauto has it pretty cheap.

...
2000 SL2 Automatic (back on the road) 17X,XXX miles.
1999 Chevy K3500

REWARD EXCELLENCE!

Add to 454cid's Reputation
Rate the quality of this post and help 454cid reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
454cid is offline   Reply With Quote
Old 11-30-2019, 01:19 AM   #3
TomM96
Senior Member
TomM96 will become famous soon enoughTomM96 will become famous soon enough
 
Join Date: May 2004
Location: Long Island, NY
Posts: 1,701
Default Re: idle is low for first second at startup?

maybe TPS; IAC Valve; fuel pressure Regulator (which in filter) ..?

REWARD EXCELLENCE!

Add to TomM96's Reputation
Rate the quality of this post and help TomM96 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
TomM96 is offline   Reply With Quote
Old 11-30-2019, 05:42 PM   #4
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,524
 

2003 L-Series 3.0L Sedan
Default Re: idle is low for first second at startup?

I agree, tps or iacv for an initial guess. With startup rpm initially lower than normal idle, this suggests an iacv issue because the lower idle jumping up to idle rpm is the pcm commanding the iacv to retract (initially extended) to allow more airflow thru the bypass air port in front of the throttle plate (supplemental bypass air). The mechanically fixed throttle plate is set for 500-600 rpm with bypass air port blocked. Unblocked, ported air is fed into the intake manifold to raise rpm to programmed values (cold idle around 1200-1500 rpm, warm idle around 650-800 rpm). The pcm commands the idle air control valve to choke/lower or open/raise idle rpm for varying loads and temperatures. It may be sticking and need cleaning or is announcing its demise. The tps has its own unusual characteristics when its wears down.

Under normal conditions, when ignition is turned on, the pcm uses the initial tps signal as 'zero' as a reference to all other tps positions. When the flat carbon resistor wears out from years of wiper action, the resistor value becomes compromised. This gives distinct symptoms of random high idling, corrected when the engine is shut off and restarted, the zero reference was lost leading to random idle fluctuations. Once diagnosed as a worn out tps, its replaced.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 11-30-2019, 07:08 PM   #5
454cid
Member
454cid is a jewel in the rough454cid is a jewel in the rough454cid is a jewel in the rough
 
Join Date: May 2019
Posts: 324
Default Re: idle is low for first second at startup?

Quote:
Originally Posted by fdryer View Post
I agree, tps or iacv for an initial guess. With startup rpm initially lower than normal idle, this suggests an iacv issue because the lower idle jumping up to idle rpm is the pcm commanding the iacv to retract (initially extended) to allow more airflow thru the bypass air port in front of the throttle plate (supplemental bypass air). The mechanically fixed throttle plate is set for 500-600 rpm with bypass air port blocked. Unblocked, ported air is fed into the intake manifold to raise rpm to programmed values (cold idle around 1200-1500 rpm, warm idle around 650-800 rpm). The pcm commands the idle air control valve to choke/lower or open/raise idle rpm for varying loads and temperatures. It may be sticking and need cleaning or is announcing its demise. The tps has its own unusual characteristics when its wears down.

Under normal conditions, when ignition is turned on, the pcm uses the initial tps signal as 'zero' as a reference to all other tps positions. When the flat carbon resistor wears out from years of wiper action, the resistor value becomes compromised. This gives distinct symptoms of random high idling, corrected when the engine is shut off and restarted, the zero reference was lost leading to random idle fluctuations. Once diagnosed as a worn out tps, its replaced.
Thanks for the explanation. I do have the TPS issue you mention, but had no idea how that worked.

Maybe I can get away with just cleaning the IAC, as it does not happen every startup... more when it's cold.

...
2000 SL2 Automatic (back on the road) 17X,XXX miles.
1999 Chevy K3500

REWARD EXCELLENCE!

Add to 454cid's Reputation
Rate the quality of this post and help 454cid reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
454cid is offline   Reply With Quote
Old 11-30-2019, 11:26 PM   #6
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,524
 

2003 L-Series 3.0L Sedan
Default Re: idle is low for first second at startup?

When a worn tps is diagnosed and verified by restarting the engine when it randomly high idles, the restart is the pcm relearning the tps home position as a voltage signal to let the pcm restore idle back to normal. This can be repeated as many times to confirm a worn out tps.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast idle on startup sisjake S-Series Tech 1 11-26-2010 09:35 PM
High idle at startup... most likely culprit?... Hackster S-Series Tech 4 07-21-2007 11:09 PM
Rough idle on startup Imagyne S-Series Tech 4 08-17-2005 04:21 PM
rough idle at startup OldGeezer Ion General 16 07-30-2003 10:56 PM
Rough Idle at Startup Steve96SL2m Miscellaneous Tech 10 03-10-2002 01:44 PM


All times are GMT -4. The time now is 01:25 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.