SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Categories > General Saturn Discussion
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-10-2008, 07:27 PM   #1
annedeslongcham
Junior Member
annedeslongcham is on a distinguished road
 
annedeslongcham's Avatar
 
Join Date: Sep 2008
Location: Vermont
Posts: 11

1998 SW2
2001 SL2
Default horn on 98 sw2

My horn on my 98 sw2 doesn't work. I checked the fuse and it wasn't that. Anyone have any idea on what I should check now ?

REWARD EXCELLENCE!

Add to annedeslongcham's Reputation
Rate the quality of this post and help annedeslongcham reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
annedeslongcham is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
horn trouble-no power to horn/not fuse 2xsl2 S-Series Tech 6 03-06-2010 11:32 PM
expiermented to day on 97 sc1 horn replaced with honda horn,whadda ya think! maestro S-Series Tech 1 07-27-2007 12:52 AM
VUE horn location - adding 2nd horn? Robert H. Vue Tech 3 09-11-2006 04:20 PM
Two-Horn Setup Help: '96 SW2, Relay Pins 85, 86, 87, 30 ... Brendo613 S-Series Tech 9 12-10-2005 12:58 PM
Horn Dead, Its Not The Fuse , Cant Find Horn justinkr58 S-Series General 2 07-01-2005 06:39 AM


All times are GMT -4. The time now is 05:18 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.